Bug 257573 - [14-CURRENT] x11/nvidia-driver: compilation error: line 84: Could not find bsd.sanitizer.mk
Summary: [14-CURRENT] x11/nvidia-driver: compilation error: line 84: Could not find bs...
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Alexey Dokuchaev
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-02 21:12 UTC by O. Hartmann
Modified: 2021-08-15 21:48 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (danfe)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2021-08-02 21:12:23 UTC
On recent 14-CURRENT (14.0-CURRENT #147 main-n248437-600745f1e226: Mon Aug  2 18:34:54 CEST 2021  amd64) building port x11/nvidia-driver fails due to the error shown below.

[...]
:> export_syms
awk -f /usr/src/sys/conf/kmod_syms.awk nvidia-modeset.ko  export_syms | xargs -J% objcopy % nvidia-modeset.ko
===> lib (all)
===> lib/libGLX_nvidia (all)
===> lib/libnvidia-tls (all)
===> lib/libnvidia-cfg (all)
===> lib/libnvidia-glcore (all)
===> lib/libvdpau_nvidia (all)
===> lib/libnvidia-glvkspirv (all)
===> lib/libnvidia-eglcore (all)
===> lib/libnvidia-glsi (all)
===> lib/libEGL_nvidia (all)
===> lib/libGLESv2_nvidia (all)
===> lib/libGLESv1_CM_nvidia (all)
===> lib/libnvidia-egl-wayland (all)
===> lib/libnvidia-ml (all)
===> x11 (all)
===> x11/driver (all)
===> x11/extension (all)
===> doc (all)
make[6]: "/usr/share/mk/bsd.prog.mk" line 84: Could not find bsd.sanitizer.mk
make[6]: Fatal errors encountered -- cannot continue
make[6]: stopped in /usr/obj/usr/src/amd64.amd64/sys/THOR/usr/ports/x11/nvidia-driver/work/NVIDIA-FreeBSD-x86_64-460.84/doc
*** Error code 1

Stop.
make[5]: stopped in /usr/obj/usr/src/amd64.amd64/sys/THOR/usr/ports/x11/nvidia-driver/work/NVIDIA-FreeBSD-x86_64-460.84
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1
Comment 1 Kevin Bowling freebsd_committer 2021-08-15 21:48:12 UTC
This is some kind of local issue in your base system mk directory (/usr/share/mk) unrelated to the port or ports itself.