Bug 257665 - databases/mongodb50: Update to 5.0.2
Summary: databases/mongodb50: Update to 5.0.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Guangyuan Yang
URL: https://docs.mongodb.com/manual/relea...
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-06 20:07 UTC by Ronald Klop
Modified: 2021-08-08 10:41 UTC (History)
1 user (show)

See Also:
ygy: merge-quarterly+


Attachments
git diff (933 bytes, patch)
2021-08-06 20:07 UTC, Ronald Klop
ronald-lists: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ronald Klop 2021-08-06 20:07:13 UTC
Created attachment 226999 [details]
git diff

version bump

- passed poudriere testport for stage-qa on rpi4/aarch64/14-current
Comment 1 Ronald Klop 2021-08-06 20:55:15 UTC
NB: from the changelog

MongoDB version <= 5.0.1 is not recommended for production use due to a critical issue, SERVER-58936 [1]. The issue is fixed in version 5.0.2.

[1] https://jira.mongodb.org/browse/SERVER-58936
Comment 2 Guangyuan Yang freebsd_committer 2021-08-07 00:01:07 UTC
Looks like this should be MFH'ed. Can you confirm?
Comment 3 Ronald Klop 2021-08-07 06:31:53 UTC
(In reply to Guangyuan Yang from comment #2)
Yes, please merge to quarterly.
Comment 4 commit-hook freebsd_committer 2021-08-08 10:35:46 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=1156f7d08c7d00e48492c30cd9dcd54da92967c8

commit 1156f7d08c7d00e48492c30cd9dcd54da92967c8
Author:     Ronald Klop <ronald-lists@klop.ws>
AuthorDate: 2021-08-08 10:35:23 +0000
Commit:     Guangyuan Yang <ygy@FreeBSD.org>
CommitDate: 2021-08-08 10:35:23 +0000

    databases/mongodb50: Update to 5.0.2

    Changelog:      https://docs.mongodb.com/manual/release-notes/5.0/#5.0.2---aug-4--2021

    PR:             257665
    MFH:            2021Q3 (bugfix release)

 databases/mongodb50/Makefile | 2 +-
 databases/mongodb50/distinfo | 6 +++---
 2 files changed, 4 insertions(+), 4 deletions(-)
Comment 5 commit-hook freebsd_committer 2021-08-08 10:37:47 UTC
A commit in branch 2021Q3 references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=dc7eb65dcabb50d826a4ea4b59ae47b2d4042b60

commit dc7eb65dcabb50d826a4ea4b59ae47b2d4042b60
Author:     Ronald Klop <ronald-lists@klop.ws>
AuthorDate: 2021-08-08 10:35:23 +0000
Commit:     Guangyuan Yang <ygy@FreeBSD.org>
CommitDate: 2021-08-08 10:37:02 +0000

    databases/mongodb50: Update to 5.0.2

    Changelog:      https://docs.mongodb.com/manual/release-notes/5.0/#5.0.2---aug-4--2021

    PR:             257665

    (cherry picked from commit 1156f7d08c7d00e48492c30cd9dcd54da92967c8)

 databases/mongodb50/Makefile | 2 +-
 databases/mongodb50/distinfo | 6 +++---
 2 files changed, 4 insertions(+), 4 deletions(-)
Comment 6 Guangyuan Yang freebsd_committer 2021-08-08 10:41:14 UTC
Committed, thanks!