Bug 257835 - net/samba413 fails: Python module pytdb of version 1.4.3 not found
Summary: net/samba413 fails: Python module pytdb of version 1.4.3 not found
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Timur I. Bakeyev
Depends on:
Reported: 2021-08-14 14:31 UTC by Mohammad S. Babaei
Modified: 2021-08-14 15:04 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (timur)

the compressed config.log (50.65 KB, application/x-xz)
2021-08-14 14:33 UTC, Mohammad S. Babaei
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mohammad S. Babaei 2021-08-14 14:31:10 UTC
Checking for program 'python3'                                                    : /usr/local/bin/python3.8 
Checking for program 'python'                                                     : /usr/local/bin/python3.8 
Checking for program 'python3'                                                    : not found 
Checking for python version >= 3.6.0                                              : 3.8.11 
python-config                                                                     : /usr/local/bin/python3.8-config 
Asking python-config for pyembed '--cflags --libs --ldflags --embed' flags        : yes 
Testing pyembed configuration                                                     : yes 
Asking python-config for pyext '--cflags --libs --ldflags' flags                  : yes 
Testing pyext configuration                                                       : yes 
Dynconfig[BINDIR]:                                                                : '/usr/local/bin' 
Dynconfig[SBINDIR]:                                                               : '/usr/local/sbin' 
Dynconfig[LIBDIR]:                                                                : '/usr/local/lib/samba4' 
Dynconfig[LIBEXECDIR]:                                                            : '/usr/local/libexec' 
Dynconfig[DATADIR]:                                                               : '/usr/local/share/samba413' 
Dynconfig[SAMBA_DATADIR]:                                                         : '/usr/local/share/samba413/samba' 
Dynconfig[LOCALEDIR]:                                                             : '/usr/local/share/locale' 
Dynconfig[PYTHONDIR]:                                                             : '/usr/local/lib/python3.8/site-packages' 
Dynconfig[PYTHONARCHDIR]:                                                         : '/usr/local/lib/python3.8/site-packages' 
Dynconfig[PERL_LIB_INSTALL_DIR]:                                                  : '/usr/local/share/samba413/perl5' 
Dynconfig[PERL_ARCH_INSTALL_DIR]:                                                 : '/usr/local/lib/samba4/perl5' 
Dynconfig[INCLUDEDIR]:                                                            : '/usr/local/include/samba4' 
Dynconfig[SCRIPTSBINDIR]:                                                         : '/usr/local/sbin' 
Dynconfig[SETUPDIR]:                                                              : '/usr/local/share/samba413/setup' 
Dynconfig[PKGCONFIGDIR]:                                                          : '/usr/local/libdata/pkgconfig' 
Dynconfig[CODEPAGEDIR]:                                                           : '/usr/local/share/samba413/codepages' 
Dynconfig[PRIVATELIBDIR]:                                                         : '/usr/local/lib/samba4/private' 
Dynconfig[MODULESDIR]:                                                            : '/usr/local/lib/samba4/modules' 
Dynconfig[PAMMODULESDIR]:                                                         : '/usr/local/lib' 
Dynconfig[CONFIGDIR]:                                                             : '/usr/local/etc' 
Dynconfig[PRIVATE_DIR]:                                                           : '/var/db/samba4/private' 
Dynconfig[BINDDNS_DIR]:                                                           : '/var/db/samba4/bind-dns' 
Dynconfig[LOCKDIR]:                                                               : '/var/db/samba4' 
Dynconfig[PIDDIR]:                                                                : '/var/run/samba4' 
Dynconfig[STATEDIR]:                                                              : '/var/db/samba4' 
Dynconfig[CACHEDIR]:                                                              : '/var/db/samba4' 
Dynconfig[LOGFILEBASE]:                                                           : '/var/log/samba4' 
Dynconfig[SOCKET_DIR]:                                                            : '/var/run/samba4' 
Dynconfig[PRIVILEGED_SOCKET_DIR]:                                                 : '/var/run/samba4' 
Dynconfig[WINBINDD_SOCKET_DIR]:                                                   : '/var/run/samba4/winbindd' 
Dynconfig[NMBDSOCKETDIR]:                                                         : '/var/run/samba4/nmbd' 
Dynconfig[NTP_SIGND_SOCKET_DIR]:                                                  : '/var/run/samba4/ntp_signd' 
Dynconfig[NCALRPCDIR]:                                                            : '/var/run/samba4/ncalrpc' 
Dynconfig[CONFIGFILE]:                                                            : '/usr/local/etc/smb4.conf' 
Dynconfig[LMHOSTSFILE]:                                                           : '/usr/local/etc/lmhosts' 
Dynconfig[SMB_PASSWD_FILE]:                                                       : '/var/db/samba4/private/smbpasswd' 
Checking for 'zlib'                                                               : yes 
Checking for library z                                                            : yes 
Checking for inflateInit2 in z                                                    : not found 
Checking for longjmp                                                              : ok 
Checking for siglongjmp                                                           : ok 
Checking for system cmocka (>=1.1.3)                                              : yes 
Checking for system popt                                                          : yes 
Checking for header popt.h                                                        : yes 
Checking for library popt                                                         : yes 
Checking for poptGetContext in popt                                               : ok 
Checking compiler accepts -Wp,-E,-lang-asm                                        : no 
Checking compiler accepts -xassembler-with-cpp                                    : yes 
Compiling with Intel AES instructions
Checking linker accepts -Wl,-z,noexecstack                                        : yes 
Checking for system tdb (>=1.4.3)                                                 : yes 
ERROR: Python module pytdb of version 1.4.3 not found, and bundling disabled
===>  Script "configure" failed unexpectedly.
Please report the problem to timur@FreeBSD.org [maintainer] and attach the
"/usr/ports/net/samba413/work/samba-4.13.8/bin/config.log" including the
output of the failure of your make command. Also, it might be a good idea to
provide an overview of all packages installed on your system (e.g. a
/usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

make[2]: stopped in /usr/ports/net/samba413
*** Error code 1

make[1]: stopped in /usr/ports/net/samba413
*** Error code 1

make: stopped in /usr/ports/net/samba413
Comment 1 Mohammad S. Babaei 2021-08-14 14:33:04 UTC
Created attachment 227182 [details]
the compressed config.log
Comment 2 Mohammad S. Babaei 2021-08-14 15:04:57 UTC
Wierd. I did an pkg autoremove and tried to rebuild and it worked.