Bug 257997 - editors/libreoffice core dumps during Poudriere build for FreeBSD 12.2 x64 and i386
Summary: editors/libreoffice core dumps during Poudriere build for FreeBSD 12.2 x64 an...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: FreeBSD Office Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-23 04:04 UTC by ddrinnon
Modified: 2021-09-14 08:25 UTC (History)
14 users (show)

See Also:
bugzilla: maintainer-feedback? (office)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ddrinnon 2021-08-23 04:04:25 UTC
It happens well into the build - usually 10 Hours or more.  
Here's the tail end of the build log:

[build LNK] Executable/gengal.bin
S=/wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4 && I=$S/instdir && W=$S/workdir &&  c++ -pthread    -Wl,-z,origin '-Wl,-rpath,$ORIGIN' -Wl,-rpath-link,$I/program  -fstack-protector-strong -Wl,-rpath-link,/lib:/usr/lib -Wl,-z,combreloc  -Wl,--hash-style=gnu  -Wl,-Bsymbolic-functions -L$W/LinkTarget/StaticLibrary -L$I/sdk/lib  -L$I/program  -L$I/program -L/usr/local/lib  -fstack-protector-strong    -L/usr/local/lib  $W/CxxObject/svx/source/gengal/gengal.o      -Wl,--start-group $W/LinkTarget/StaticLibrary/libglxtest.a $W/LinkTarget/StaticLibrary/libvclmain.a -lX11   -Wl,--end-group -Wl,--no-as-needed -lbasegfxlo -luno_sal -ltllo -lsfxlo -lsvllo -lsvtlo -lcomphelper -luno_cppu -luno_cppuhelpergcc3 -lutllo -lsvxcorelo -lvcllo  -o $I/program/gengal.bin
TEMPFILE=/wrkdirs/usr/ports/editors/libreoffice/work/gbuild.XXXXXX.rgIqeu6T && mv ${TEMPFILE} /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/LinkTarget/Executable/gengal.bin.objectlist
touch /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/Executable/gengal.run
mkdir -p /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/Gallery/
mkdir -p /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/Gallery/backgrounds/
mkdir -p /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/Package/prepared/Gallery/Files/ && touch /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/Package/prepared/Gallery/Files/backgrounds
[build GAL] backgrounds
S=/wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4 && I=$S/instdir && W=$S/workdir &&  rm -f $W/Gallery/backgrounds/* && RESPONSEFILE=/wrkdirs/usr/ports/editors/libreoffice/work/gbuild.XXXXXX.8MEKple0 &&  (  LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"$I/program:$I/program"   $I/program/gengal.bin --build-tree --destdir file://$S/extras/source/gallery --name "backgrounds" --path $W/Gallery/backgrounds --filenames file://$RESPONSEFILE ) && rm $RESPONSEFILE && touch $W/Gallery/backgrounds.done
Abort trap (core dumped)
gmake[2]: *** [/wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/solenv/gbuild/Gallery.mk:56: /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/Gallery/backgrounds.done] Error 134
rm /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/CustomTarget/i18npool/breakiterator/dict_word.brk /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/CustomTarget/i18npool/breakiterator/sent.brk /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/CustomTarget/i18npool/breakiterator/sent.txt /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/CustomTarget/i18npool/breakiterator/edit_word_hu.txt /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/CustomTarget/i18npool/breakiterator/dict_word_hu.brk /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/CustomTarget/i18npool/breakiterator/dict_word_hu.txt /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/CustomTarget/i18npool/breakiterator/dict_word.txt /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/CustomTarget/i18npool/breakiterator/count_word.brk /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/CustomTarget/i18npool/breakiterator/edit_word_hu.brk /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/CustomTarget/i18npool/breakiterator/line.brk /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/CustomTarget/i18npool/breakiterator/dict_word_nodash.brk /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/CustomTarget/i18npool/breakiterator/dict_word_nodash.txt /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/CustomTarget/i18npool/breakiterator/dict_word_prepostdash.txt /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/CustomTarget/i18npool/breakiterator/dict_word_he.txt /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/CustomTarget/i18npool/breakiterator/edit_word.txt /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/CustomTarget/i18npool/breakiterator/edit_word_he.txt /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/CustomTarget/i18npool/breakiterator/count_word.txt /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/CustomTarget/i18npool/breakiterator/edit_word_he.brk /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/CustomTarget/i18npool/breakiterator/edit_word.brk /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/CustomTarget/i18npool/breakiterator/dict_word_he.brk /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/CustomTarget/i18npool/breakiterator/dict_word_prepostdash.brk /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/CustomTarget/i18npool/breakiterator/line.txt
gmake[2]: Leaving directory '/wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4'
gmake[1]: *** [Makefile:287: build] Error 2
gmake[1]: Leaving directory '/wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4'
*** Error code 1

Stop.
make: stopped in /usr/ports/editors/libreoffice
=>> Cleaning up wrkdir
===>  Cleaning for libreoffice-7.2.0.4_1
build of editors/libreoffice | libreoffice-7.2.0.4_1 ended at Sun Aug 22 20:06:49 MST 2021
build time: 10:34:41
!!! build failure encountered !!!
Comment 1 Li-Wen Hsu freebsd_committer 2021-08-23 04:08:59 UTC
We aware this from the official pkg builders but still are not lucky to reproduce it locally. We somehow suspect this may related to resource limitations. Can you let us know how much memory do you have in your poudriere box?
Comment 2 ddrinnon 2021-08-23 16:44:06 UTC
It's failing on a ESXi VM Ware FreeBSD 12.2 x64 system with 40GB RAM as well as a physical FreeBSD 12.2 x64 system with 32GB of ram.  

I will boost the VM machine to 64GB and try it again.
Comment 3 ddrinnon 2021-08-23 18:54:50 UTC
A 64GB Poudriere server also core dumps.
Comment 4 Dima Panov freebsd_committer 2021-08-23 20:38:33 UTC
Strange, I can't repeat build failures on my Intel S2600 server with 64GB RAM. 
Also fine on Win2008R2 HyperV container. 
However, both machines have set MAX_FILES=2048 for poudriere due to past jdk12+ build failures, caused by default settings of 1024.
Comment 5 ddrinnon 2021-08-23 20:57:01 UTC
My last successful build was on 8/18 with libreoffice-7.1.5.2_2.  Failure started with 7.2.x.
I changed poudriere.conf MAX_FILES=2048 to see what happens.
Comment 6 ddrinnon 2021-08-23 21:16:50 UTC
Increasing MAX_FILES to 2048 did not help -

...
[build GAL] backgrounds
S=/wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4 && I=$S/instdir && W=$S/workdir &&  rm -f $W/Gallery/backgrounds/* && RESPONSEFILE=/wrkdirs/usr/ports/editors/libreoffice/work/gbuild.XXXXXX.LGbKdHDb &&  (  LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"$I/program:$I/program"   $I/program/gengal.bin --build-tree --destdir file://$S/extras/source/gallery --name "backgrounds" --path $W/Gallery/backgrounds --filenames file://$RESPONSEFILE ) && rm $RESPONSEFILE && touch $W/Gallery/backgrounds.done
Abort trap (core dumped)
gmake[2]: *** [/wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/solenv/gbuild/Gallery.mk:56: /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/Gallery/backgrounds.done] Error 134
...
Comment 7 Dima Panov freebsd_committer 2021-08-23 21:33:37 UTC
Which options set you are use to build? It may matters

Just to ensure and compare my build logs available at https://build.dimapanov.com/
Comment 8 ddrinnon 2021-08-23 21:46:38 UTC
# This file is auto-generated by 'make config'.
# Options for libreoffice-7.1.2.2_7
_OPTIONS_READ=libreoffice-7.1.2.2_7
_FILE_COMPLETE_OPTIONS_LIST=COINMP CUPS DOCS GNOME GTK3 JAVA KF5 LTO MARIADB MMEDIA PGSQL QT5 SDK TEST WEBDAV
OPTIONS_FILE_UNSET+=COINMP
OPTIONS_FILE_SET+=CUPS
OPTIONS_FILE_SET+=DOCS
OPTIONS_FILE_UNSET+=GNOME
OPTIONS_FILE_UNSET+=GTK3
OPTIONS_FILE_UNSET+=JAVA
OPTIONS_FILE_UNSET+=KF5
OPTIONS_FILE_UNSET+=LTO
OPTIONS_FILE_UNSET+=MARIADB
OPTIONS_FILE_SET+=MMEDIA
OPTIONS_FILE_UNSET+=PGSQL
OPTIONS_FILE_UNSET+=QT5
OPTIONS_FILE_UNSET+=SDK
OPTIONS_FILE_UNSET+=TEST
OPTIONS_FILE_UNSET+=WEBDAV

I will re-run poudriere options to make sure the config is for 7.2 and try again.
Comment 9 Dima Panov freebsd_committer 2021-08-23 22:03:07 UTC
Just for test purposes try to reenable GTK3 or QT5 options, your current set shows pure x11 config which is non-default and lacks of cairo renderer support
Comment 10 ddrinnon 2021-08-24 00:33:41 UTC
I enabled QT5 and still got the core dump:

# This file is auto-generated by 'make config'.
# Options for libreoffice-7.2.0.4_1
_OPTIONS_READ=libreoffice-7.2.0.4_1
_FILE_COMPLETE_OPTIONS_LIST=COINMP CUPS DOCS GNOME GTK3 JAVA KF5 LTO MARIADB MMEDIA PGSQL QT5 SDK TEST WEBDAV
OPTIONS_FILE_UNSET+=COINMP
OPTIONS_FILE_SET+=CUPS
OPTIONS_FILE_SET+=DOCS
OPTIONS_FILE_UNSET+=GNOME
OPTIONS_FILE_UNSET+=GTK3
OPTIONS_FILE_SET+=JAVA
OPTIONS_FILE_UNSET+=KF5
OPTIONS_FILE_UNSET+=LTO
OPTIONS_FILE_UNSET+=MARIADB
OPTIONS_FILE_SET+=MMEDIA
OPTIONS_FILE_UNSET+=PGSQL
OPTIONS_FILE_SET+=QT5
OPTIONS_FILE_UNSET+=SDK
OPTIONS_FILE_UNSET+=TEST
OPTIONS_FILE_UNSET+=WEBDAV


...
[build GAL] backgrounds
S=/wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4 && I=$S/instdir && W=$S/workdir &&  rm -f $W/Gallery/backgrounds/* && RESPONSEFILE=/wrkdirs/usr/ports/editors/libreoffice/work/gbuild.XXXXXX.vFywsqmr &&  (  LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"$I/program:$I/program"   $I/program/gengal.bin --build-tree --destdir file://$S/extras/source/gallery --name "backgrounds" --path $W/Gallery/backgrounds --filenames file://$RESPONSEFILE ) && rm $RESPONSEFILE && touch $W/Gallery/backgrounds.done
Abort trap (core dumped)
...
Comment 11 Vidar Karlsen 2021-08-25 08:21:50 UTC
Can confirm, I get the same error as ddrinnon when building in poudriere on 13.0-RELEASE.
Running make in the port's dir works fine.
I haven't dug any further, but I can run some tests if it might help to solve the issue as it doesn't take me 10+ hours to do a test run.
Comment 12 Li-Wen Hsu freebsd_committer 2021-08-25 09:03:21 UTC
I tested again locally with (13.0, 12.2, 11.4) x (amd64, i386) jails in poudriere on a 13.0 host, still cannot reproduce this. That hosts has an i7-6700 and 16GB ram.

If possible, please use -i or -w poudriere-testport(8) to try to get the core dump file then it's easier to do the further investigation.
Comment 13 Vidar Karlsen 2021-08-25 13:26:31 UTC
Running poudriere testport did not produce the error, it built fine.
However, poudriere bulk -I did, but I can't find any .core files in there.
Am I missing something?
Comment 14 Alan Hicks 2021-08-26 15:40:54 UTC
Perhaps these build logs might help with better libreoffice foo than myself

Poudriere build on amd64 fails yet testport succeeds

https://p-o.co.uk/downloads/libreoffice-build.log
https://p-o.co.uk/downloads/libreoffice-testport.log
https://p-o.co.uk/downloads/libreoffice.diff
Comment 15 Dima Panov freebsd_committer 2021-08-26 20:01:06 UTC
Folks, I have a crazy idea, but what happens if u set DEFAULT_VERSIONS+=java=11 in pou's make.conf?
Comment 16 ddrinnon 2021-08-26 20:34:32 UTC
I ran poudriere with DEFAULT_VERSIONS+=java=11 and got the same core dump:

...
[build GAL] backgrounds
S=/wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4 && I=$S/instdir && W=$S/workdir &&  rm -f $W/Gallery/backgrounds/* && RESPONSEFILE=/wrkdirs/usr/ports/editors/libreoffice/work/gbuild.XXXXXX.Anis5M64 &&  (  LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"$I/program:$I/program"   $I/program/gengal.bin --build-tree --destdir file://$S/extras/source/gallery --name "backgrounds" --path $W/Gallery/backgrounds --filenames file://$RESPONSEFILE ) && rm $RESPONSEFILE && touch $W/Gallery/backgrounds.done
Abort trap (core dumped)
gmake[2]: *** [/wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/solenv/gbuild/Gallery.mk:56: /wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/workdir/Gallery/backgrounds.done] Error 134
...

I am running poudriere with the -w option and can provide the .core file if needed.  Just need to know where to upload it to.
Comment 17 ddrinnon 2021-08-26 22:09:11 UTC
Here's the .core file:  https://www.datapanic.com/gengal.bin.core.tar.gz
Comment 18 Li-Wen Hsu freebsd_committer 2021-08-27 02:20:37 UTC
(In reply to ddrinnon from comment #17)
Thanks, this core file looks really staange:

$ file gengal.bin.core 
gengal.bin.core: ELF 64-bit LSB core file, x86-64, version 1 (FreeBSD), FreeBSD-style, from '/wrkdirs/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/instdir/program/', pid=92983

Note that the path is a directory, not a file.

Maybe this is related to the issue we saw in bug258002.
Comment 19 Paul Boehmer 2021-08-27 20:17:40 UTC
I am seeing the build fail with a core dump as well when building from ports.  Looks like gengal is failing at:

ktrace
-------
...
 66297 gengal.bin NAMI  "/usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/instdir/program/../program/liblocaledata_en.so"
 66297 gengal.bin RET   openat -1 errno 2 No such file or directory
...


Copying /usr/local/lib/libreoffice/program/liblocaledata_en.so --> /usr/ports/editors/libreoffice/work/libreoffice-7.2.0.4/instdir/program/../program/liblocaledata_en.so

Allows me to finish the build.
Comment 20 Li-Wen Hsu freebsd_committer 2021-08-30 20:42:57 UTC
(In reply to Paul Boehmer from comment #19)
This seems a dependency issue in build.  From the log of comment #14,

https://p-o.co.uk/downloads/libreoffice-testport.log (success)

has:

    [build LNK] Library/liblocaledata_en.so

and other related stuff, however,

https://p-o.co.uk/downloads/libreoffice-build.log (failed)

has no liblocaledata_en.so at all.
Comment 21 Andriy Gapon freebsd_committer 2021-09-03 04:55:34 UTC
Just 2 cents of general observations.
It appears that the world at large is not affected by this issue.
So, either we are too good at parallel builds or there is some FreeBSD peculiarity.
Comment 22 ddrinnon 2021-09-03 19:55:53 UTC
(In reply to Andriy Gapon from comment #21)

The only pkg of libreoffice at the Latest repo for FreeBSD12.2 amd64 is libreoffice6-6.4.7_14.  Here's what I get when /etc/pkg/FreeBSD.conf is set to use "latest" instead of "quarterly" 

root@aux02:/usr/local/etc/pkg/repos # pkg search libreoffice
libreoffice6-6.4.7_14          Full integrated office productivity suite

I think that means that freebsd.org's builder machines are not building the latest version of libreoffice either.

Would this mean that this bug affects everyone?
Comment 23 Serge Volkov 2021-09-04 05:28:25 UTC
(In reply to ddrinnon from comment #22)

Yes, I'm also waiting for the latest libreoffice package to be ready.
It is not currently in the latest package database.

FreeBSD 12.2 amd64.
Comment 24 commit-hook freebsd_committer 2021-09-13 14:52:10 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=98936bda48a278bf4b450b66a40a618d0e83ecc3

commit 98936bda48a278bf4b450b66a40a618d0e83ecc3
Author:     Michael Gmelin <grembo@FreeBSD.org>
AuthorDate: 2021-09-13 14:45:48 +0000
Commit:     Michael Gmelin <grembo@FreeBSD.org>
CommitDate: 2021-09-13 14:45:48 +0000

    editors/libreoffice: Unbreak build

    Adds liblocaledata_en dependency to solenv.
    Tested using poudriere build & testport.

    See also:
    https://gerrit.libreoffice.org/c/core/+/120837

    PR: 257997
    Reported by: ddrinnon
    Approved by: portmgr (build fix blanket)

 editors/libreoffice/files/patch-RepositoryExternal.mk (new)  | 12 ++++++++++++
 .../patch-solenv_gbuild_extensions_pre__BuildTools.mk (new)  | 12 ++++++++++++
 2 files changed, 24 insertions(+)
Comment 25 ddrinnon 2021-09-14 06:57:33 UTC
My Poudriere system successfully built LibreOffice 7.2.x for FreeBSD12.2-RELEASE!
Comment 26 Michael Gmelin freebsd_committer 2021-09-14 08:25:50 UTC
(In reply to ddrinnon from comment #25)

Official builders are fine too: http://beefy16.nyi.freebsd.org/data/130amd64-default/0cb9a1b3d773/logs/libreoffice-7.2.0.4_2.log

Packages should show up in official repos later this week.