Bug 258446 - emulators/wine-proton: link fail - undefined reference to `sysinfo'
Summary: emulators/wine-proton: link fail - undefined reference to `sysinfo'
Status: Closed DUPLICATE of bug 257398
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-12 11:18 UTC by Ivan Rozhuk
Modified: 2021-09-16 06:17 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (iwtcex)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Rozhuk 2021-09-12 11:18:56 UTC
...
tools/winegcc/winegcc -o dlls/packager/packager.dll.so --wine-objdir . -m64 -fPIC -fasynchronous-unwind-tables -shared \
  dlls/packager/packager.spec -mno-cygwin dlls/packager/packager_main.o dlls/packager/packager.res \
  dlls/packager/packager_classes_r.res dlls/uuid/libuuid.a -lshell32 -lshlwapi -luser32 \
  dlls/ucrtbase/libucrtbase.a -fstack-protector-strong -Wl,-rpath=/usr/local/lib/gcc10 -L/usr/local/lib/gcc10 
/usr/local/bin/ld: dlls/ntdll/unix/virtual.o: in function `virtual_get_system_info':
virtual.c:(.text+0x6927): undefined reference to `sysinfo'
collect2: error: ld returned 1 exit status
winegcc: /usr/local/libexec/ccache/gcc10 failed
gmake[1]: *** [Makefile:96178: dlls/ntdll/ntdll.so] Error 2
gmake[1]: *** Waiting for unfinished jobs....
gmake[1]: Leaving directory '/tmp/ports/usr/ports/emulators/wine-proton/work/wine-97f962cd469ee9b9b68d32e79849bf94cfe15581'
...
Comment 1 Alex S 2021-09-12 11:32:44 UTC
Duplicate of bug 257398.
Comment 2 Fernando Apesteguía freebsd_committer 2021-09-16 06:17:30 UTC
Closing as newer duplicate

*** This bug has been marked as a duplicate of bug 257398 ***