Bug 258540 - print/cups-filters is missing pdftoraster required for printing to Brother MFC-J4510DW inkjet printer
Summary: print/cups-filters is missing pdftoraster required for printing to Brother MF...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: Tijl Coosemans
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-16 17:32 UTC by David.Boyd49
Modified: 2021-09-20 17:57 UTC (History)
1 user (show)

See Also:
linimon: maintainer-feedback? (tijl)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David.Boyd49 2021-09-16 17:32:20 UTC
Customer wishes to deploy FreeBSD workstations and servers throughout his enterprise.  Things are going well...except for printing.

Customer has many Debian, Fedora, openSUSE (Leap 15.3 and Tumbleweed and CentOS desktops, but most of his servers and some workstations are FreeBSD (12.2 and 13.0).

CUPS driverless printing is the standard throughout.

When attempting print a "Test Page" from system-config-printer, the CUPS web application or from the command line using lpr /usr/local/share/cups/data/testprint, the CUPS error log accumulates many lines of:

        [Job nn] Filter pdftoraster missing for \"output-format=apple-raster\"
        [Job nn] Print job was not accepted.
        [Job nn] Backend returned status 7 (retry job immediately)

This sequence is repeated until the job is removed from the print queue.

This same problem occurs when attempting to print from LibreOffice writer.

Attempting to print an ascii file (e.g. /etc/hosts) is successful.

No modifications of the CUPS software have been made to any of the systems under test.  All testing is performed exactly the same on each platform.
Comment 1 Tijl Coosemans freebsd_committer 2021-09-17 07:33:23 UTC
You have to build cups-filters with the POPPLER option enabled.  I could enable that by default if you want because poppler is already a dependency via the PSHYBRID option.
Comment 2 David.Boyd49 2021-09-17 13:47:18 UTC
Thanks for the quick response.

That option should be enabled so that FreeBSD is on a level playing field with the other distributions being considered.

As I stated, we (FreeBSD) already have a significant presence with this customer, so anything that happens without extra effort (automatically) always looks good.
Comment 3 commit-hook freebsd_committer 2021-09-18 17:55:46 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=03e35e391322633ead31d3c2ced12f23b8dbf4b2

commit 03e35e391322633ead31d3c2ced12f23b8dbf4b2
Author:     Tijl Coosemans <tijl@FreeBSD.org>
AuthorDate: 2021-09-18 15:41:21 +0000
Commit:     Tijl Coosemans <tijl@FreeBSD.org>
CommitDate: 2021-09-18 17:54:06 +0000

    print/cups-filters: Update to 1.28.10

    Enable POPPLER option by default to support some Brother printers.
    (Poppler was already a dependency through the PSHYBRID option.)

    PR:             258540

 print/cups-filters/Makefile  | 7 +++----
 print/cups-filters/distinfo  | 6 +++---
 print/cups-filters/pkg-plist | 1 -
 3 files changed, 6 insertions(+), 8 deletions(-)
Comment 4 David.Boyd49 2021-09-20 17:57:07 UTC
Thanks for everything.

We achieved parity with the other distributions due to your efforts.

We (FreeBSD) have made a long-time customer very happy.