Bug 258555 - www/rt44: Latest update to 4.4.5 has invalid plist entry
Summary: www/rt44: Latest update to 4.4.5 has invalid plist entry
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Mikael Urankar
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-17 06:59 UTC by Christian Ullrich
Modified: 2021-09-17 07:17 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (mikael)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Ullrich 2021-09-17 06:59:41 UTC
The recent update of www/rt44 to version 4.4.5 introduced a plist entry that uses the %%APACHE_VERSION%% substitution. This change is a mistake caused by replacing "2.4" with the variable, including in 

-%%DATADIR%%/static/js/jquery-1.12.4p1.min.js
+%%DATADIR%%/static/js/jquery-1.1%%APACHE_VERSION%%p1.min.js

The ports builds by accident if APACHE_VERSION=2.4 is in SUB_LIST. With the SPAWN_FCGI option selected for the WEB group, it is not, exposing the bug.
Comment 1 commit-hook freebsd_committer 2021-09-17 07:16:31 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=d075c71e44acfd0fdb8ed9682c8f5cae82b3433f

commit d075c71e44acfd0fdb8ed9682c8f5cae82b3433f
Author:     Mikael Urankar <mikael@FreeBSD.org>
AuthorDate: 2021-09-17 07:14:32 +0000
Commit:     Mikael Urankar <mikael@FreeBSD.org>
CommitDate: 2021-09-17 07:14:32 +0000

    www/rt44: Fix pkg-plist

    PR:             258555
    Reported by:    Christian Ullrich

 www/rt44/pkg-plist | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 2 commit-hook freebsd_committer 2021-09-17 07:16:31 UTC
A commit in branch 2021Q3 references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=c61c5aa76a8c089b8b55eb6a1c2396374013c8c5

commit c61c5aa76a8c089b8b55eb6a1c2396374013c8c5
Author:     Mikael Urankar <mikael@FreeBSD.org>
AuthorDate: 2021-09-17 07:14:32 +0000
Commit:     Mikael Urankar <mikael@FreeBSD.org>
CommitDate: 2021-09-17 07:16:07 +0000

    www/rt44: Fix pkg-plist

    PR:             258555
    Reported by:    Christian Ullrich

    (cherry picked from commit d075c71e44acfd0fdb8ed9682c8f5cae82b3433f)

 www/rt44/pkg-plist | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 3 Mikael Urankar freebsd_committer 2021-09-17 07:17:22 UTC
Thanks!