Bug 258760 - databases/postgresql14-server: libpq.pc should not require openssl from ports when built with base -lssl
Summary: databases/postgresql14-server: libpq.pc should not require openssl from ports...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: pgsql
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2021-09-28 12:07 UTC by Phil Krylov
Modified: 2021-09-29 09:43 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (pgsql)


Attachments
Patch to fix libpq.pc (517 bytes, patch)
2021-09-28 12:07 UTC, Phil Krylov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Phil Krylov 2021-09-28 12:07:16 UTC
Created attachment 228230 [details]
Patch to fix libpq.pc

/usr/local/libdata/pkgconfig/libpq.pc unconditionally (even when built with base OpenSSL) required libssl and libcrypto pkgconfig files, which are only available from the openssl port. Patch attached. The patched line appears only in version 14+, so the old versions are not affected.
Comment 1 commit-hook freebsd_committer 2021-09-29 09:39:56 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=59611d61d70a85f4418f3f701db1b7baf58560ba

commit 59611d61d70a85f4418f3f701db1b7baf58560ba
Author:     Palle Girgensohn <girgen@FreeBSD.org>
AuthorDate: 2021-09-29 09:36:43 +0000
Commit:     Palle Girgensohn <girgen@FreeBSD.org>
CommitDate: 2021-09-29 09:39:17 +0000

    databases/postgresql14-server: fix openssl dependency

    libpq.pc should not require openssl from ports when built with base -lssl

    PR:     258760

 databases/postgresql14-server/Makefile | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)
Comment 2 Palle Girgensohn freebsd_committer 2021-09-29 09:43:52 UTC
Committed. Thanks!