Bug 260185 - devel/yasm-devel: Mark DEPRECATED
Summary: devel/yasm-devel: Mark DEPRECATED
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Guangyuan Yang
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-03 05:22 UTC by Guangyuan Yang
Modified: 2021-12-22 09:42 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (koobs)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Guangyuan Yang freebsd_committer 2021-12-03 05:22:22 UTC
The latest version of yasm was released on August 10, 2014. [1] I think there is no need to keep the -devel port, and it is even more confusing since the -devel version is currently even older (at 1.2.0.29).

[1]: https://yasm.tortall.net/Download.html
Comment 1 commit-hook freebsd_committer 2021-12-22 09:40:13 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=0322258c93783588f211462c2a13a2b6fc20a55f

commit 0322258c93783588f211462c2a13a2b6fc20a55f
Author:     Guangyuan Yang <ygy@FreeBSD.org>
AuthorDate: 2021-12-22 09:37:52 +0000
Commit:     Guangyuan Yang <ygy@FreeBSD.org>
CommitDate: 2021-12-22 09:37:52 +0000

    devel/yasm-devel: Mark DEPRECATED and set EXPIRATION_DATE

    The latest version of yasm was released on August 10, 2014. There is no
    need to keep the -devel port, and it is even more confusing since it is
    currently older than the non-devel port.

    PR:             260185
    Approved by:    koobs (maintainer timeout, > 3 weeks)

 devel/yasm-devel/Makefile | 3 +++
 1 file changed, 3 insertions(+)