Bug 260187 - java/bootstrap-openjdk17: broken on aarch64
Summary: java/bootstrap-openjdk17: broken on aarch64
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm64 Any
: --- Affects Many People
Assignee: freebsd-java (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-03 11:55 UTC by Mikael Urankar
Modified: 2022-01-20 09:27 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (java)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikael Urankar freebsd_committer 2021-12-03 11:55:27 UTC
/usr/local/bootstrap-openjdk17/bin/java
Error occurred during initialization of VM
Could not allocate compressed class space: 1073741824 bytes
Exit 1

Any ideas?
Comment 1 Greg Lewis freebsd_committer 2021-12-07 02:25:44 UTC
Hmmm, I'm not sure what might be going wrong, but I can add details about the binary itself.

It was built on an AWS aarch64 instance.  I installed 12.2 and built the current version of the openjdk17 port.  I then deleted things that weren't needed for bootstrap, like src.zip, the manual pages, the examples, etc.

What version are you trying this on and how much memory does the machine have?
Comment 2 Mikael Urankar freebsd_committer 2021-12-07 09:34:45 UTC
(In reply to Greg Lewis from comment #1)
It's on a recent 14-current, the board has 64gb of RAM.
Comment 3 Greg Lewis freebsd_committer 2021-12-29 04:45:01 UTC
I tried this on both FreeBSD 12.3/arm64 and FreeBSD 13.0/arm64 and it worked on both of them.

The JDK sometimes encounters problems on -CURRENT.  These often end up being bugs in -CURRENT if they can't be reproduced on released versions.  In this case I would suggest transferring this to the Base System category unless FreeBSD 14 is planning to deliberately break compatibility with earlier releases.
Comment 4 Mikael Urankar freebsd_committer 2022-01-19 11:54:02 UTC
Cannot reproduce with a recent 14-current, closing.
Comment 5 Mikael Urankar freebsd_committer 2022-01-20 09:27:50 UTC
(In reply to Mikael Urankar from comment #4)
It happened again, setting kern.elf64.aslr.pie_enable=0 fixed it