Bug 261217 - devel/e2fsprogs-libss fails to build in poudriere testport (ld: error: unable to find library -lcom_err)
Summary: devel/e2fsprogs-libss fails to build in poudriere testport (ld: error: unable...
Status: Closed DUPLICATE of bug 254751
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Fernando Apesteguía
URL:
Keywords:
Depends on: 254751
Blocks:
  Show dependency treegraph
 
Reported: 2022-01-15 04:12 UTC by tech-lists
Modified: 2022-01-28 00:12 UTC (History)
3 users (show)

See Also:
mandree: maintainer-feedback-


Attachments
log from poudriere testport (45.59 KB, text/plain)
2022-01-15 04:12 UTC, tech-lists
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description tech-lists 2022-01-15 04:12:45 UTC
Created attachment 231018 [details]
log from poudriere testport

Hi,

This is failing again with poudriere testport -j 13S-localhost -J1 -i -c devel/e2fsprogs-libss.
This is with a frest ports tree as of a few minutes ago and the poudriere jail is new:
13.0-STABLE 1300523 1a86aab86     amd64 git+https 2022-01-14 14:13:18

I've attached the full log.

[...]

[00:00:40] (if test -r libss.a; then /bin/rm -f libss.a.bak && /bin/mv libss.a libss.a.bak; fi)
[00:00:40] ar rc libss.a ss_err.o std_rqs.o invocation.o help.o execute_cmd.o listen.o parse.o error.o prompt.o request_tbl.o list_rqs.o pager.o requests.o data.o get_readline.o
[00:00:40] /bin/rm -f ../libss.a
[00:00:40] (cd ..; /bin/ln  \
[00:00:40]      `echo lib/ss | sed -e 's;lib/;;'`/libss.a libss.a)
[00:00:40] (cd elfshared; cc -o libss.so.2.0 \
[00:00:40]      -L../../../lib  -pthread  -fstack-protector-strong  -fPIC -shared \
[00:00:40]      -Wl,-soname,libss.so.2 ss_err.o std_rqs.o invocation.o help.o execute_cmd.o listen.o parse.o error.o prompt.o request_tbl.o list_rqs.o pager.o requests.o data.o get_readline.o -lcom_err -ldl)
[00:00:40] ld: error: unable to find library -lcom_err
[00:00:40] cc: error: linker command failed with exit code 1 (use -v to see invocation)
[00:00:40] gmake[1]: *** [Makefile:450: libss.so.2.0] Error 1
[00:00:40] gmake[1]: Leaving directory '/wrkdirs/usr/ports/devel/e2fsprogs-libss/work/e2fsprogs-1.46.4/lib/ss'
[00:00:40] ===> Compilation failed unexpectedly.
[00:00:40] Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
[00:00:40] the maintainer.
[00:00:40] *** Error code 1
[00:00:40] 
[00:00:40] Stop.
[00:00:40] make: stopped in /usr/ports/devel/e2fsprogs-libss
=======================<phase: Interactive    >============================
[00:00:41] Installing packages
[00:00:41] Installing run-depends for devel/e2fsprogs-libss | e2fsprogs-libss-1.46.4_1
[00:00:41] Installing devel/e2fsprogs-libss | e2fsprogs-libss-1.46.4_1
pkg-static: /tmp/pkgs/e2fsprogs-libss-1.46.4_1.pkg: No such file or directory
pkg-static: Was 'pkg install /tmp/pkgs/e2fsprogs-libss-1.46.4_1.pkg' meant?

Failed to install the following 1 package(s): /tmp/pkgs/e2fsprogs-libss-1.46.4_1.pkg
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/e2fsprogs-libss
[00:00:42] Warning: Failed to install devel/e2fsprogs-libss | e2fsprogs-libss-1.46.4_1
[00:00:42] Installing local Pkg repository to /usr/local/etc/pkg/repos
[00:00:42] Remounting /usr/ports read-write
[00:00:42] Mounting logs from: /usr/local/poudriere/data/logs/bulk/13S-localhost-default/2022-01-15_03h48m51s
[00:00:42] Entering interactive test mode. Type 'exit' when done.
nobody@pkg:/usr/ports/devel/e2fsprogs-libss % 

[...]
Comment 1 Fernando Apesteguía freebsd_committer 2022-01-17 13:08:48 UTC
I'm sorry. I'm again unable to reproduce. Builds fine for me in 12.2{amd64,i386} 13.0amd64 and CURRENT-amd64.

Also there aren't any pkg-fallout messages for this port:

https://docs.freebsd.org/mail/current/freebsd-pkg-fallout.html
Comment 2 Matthias Andree freebsd_committer 2022-01-17 19:34:51 UTC
maintainer timeout on 254751, see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=254751#c10 for a similar failure mode.
Comment 3 Matthias Andree freebsd_committer 2022-01-17 21:26:11 UTC

*** This bug has been marked as a duplicate of bug 254751 ***
Comment 4 commit-hook freebsd_committer 2022-01-17 22:18:50 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=29b349b2dba2a188140cb73fe451a9b9793178d4

commit 29b349b2dba2a188140cb73fe451a9b9793178d4
Author:     Matthias Andree <mandree@FreeBSD.org>
AuthorDate: 2022-01-16 12:09:14 +0000
Commit:     Matthias Andree <mandree@FreeBSD.org>
CommitDate: 2022-01-17 22:17:48 +0000

    devel/e2fsprogs-libss: merge to sysutils/e2fsprogs

    This is to break dependency cycles between e2fsprogs-libss and
    e2fsprogs (see 254751 comment #18 for details), and to avoid creating
    yet another split-out port, then for e2fsprogs's libcom_err.

    Bump PORTREVISION of the four e2fsprogs consumers to flush out
    their e2fsprogs-libss dependency records.

    PR:             254751
    Reported by:    Felix Palmen
    PR:             261217
    Reported by:    tech-lists@zyxst.net
    Fixes:          8e6ae60 devel/e2fsprogs-libss: use local compile_et...

    Approved by:    prior maintainer timeout (Ben Kaduk, 7 months) on 254751

 MOVED                                              |  1 +
 devel/Makefile                                     |  1 -
 devel/e2fsprogs-libss/Makefile (gone)              | 33 ----------------------
 devel/e2fsprogs-libss/pkg-descr (gone)             |  5 ----
 devel/e2fsprogs-libss/pkg-plist (gone)             | 11 --------
 sysutils/e2fsprogs/Makefile                        |  7 +++--
 .../e2fsprogs}/files/fix-ss_err.h.sed              |  0
 sysutils/e2fsprogs/files/unwanted                  | 13 ---------
 sysutils/e2fsprogs/pkg-plist                       | 13 +++++++++
 sysutils/e2tools/Makefile                          |  2 +-
 sysutils/fusefs-ext2/Makefile                      |  2 +-
 sysutils/unetbootin/Makefile                       |  1 +
 sysutils/vzvol/Makefile                            |  2 +-
 13 files changed, 22 insertions(+), 69 deletions(-)
Comment 5 commit-hook freebsd_committer 2022-01-28 00:12:12 UTC
A commit in branch 2022Q1 references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=69d35222fd84c30922c302fb08873d371cea333e

commit 69d35222fd84c30922c302fb08873d371cea333e
Author:     Matthias Andree <mandree@FreeBSD.org>
AuthorDate: 2022-01-16 12:09:14 +0000
Commit:     Matthias Andree <mandree@FreeBSD.org>
CommitDate: 2022-01-27 23:55:46 +0000

    devel/e2fsprogs-libss: merge to sysutils/e2fsprogs

    This is to break dependency cycles between e2fsprogs-libss and
    e2fsprogs (see 254751 comment #18 for details), and to avoid creating
    yet another split-out port, then for e2fsprogs's libcom_err.

    Bump PORTREVISION of the four e2fsprogs consumers to flush out
    their e2fsprogs-libss dependency records.

    PR:             254751
    Reported by:    Felix Palmen
    PR:             261217
    Reported by:    tech-lists@zyxst.net
    Fixes:          8e6ae60 devel/e2fsprogs-libss: use local compile_et...

    Approved by:    prior maintainer timeout (Ben Kaduk, 7 months) on 254751

    (cherry picked from commit 29b349b2dba2a188140cb73fe451a9b9793178d4)

 MOVED                                              |  1 +
 devel/Makefile                                     |  1 -
 devel/e2fsprogs-libss/Makefile (gone)              | 33 ----------------------
 devel/e2fsprogs-libss/pkg-descr (gone)             |  5 ----
 devel/e2fsprogs-libss/pkg-plist (gone)             | 11 --------
 sysutils/e2fsprogs/Makefile                        |  7 +++--
 .../e2fsprogs}/files/fix-ss_err.h.sed              |  0
 sysutils/e2fsprogs/files/unwanted                  | 13 ---------
 sysutils/e2fsprogs/pkg-plist                       | 13 +++++++++
 sysutils/e2tools/Makefile                          |  2 +-
 sysutils/fusefs-ext2/Makefile                      |  2 +-
 sysutils/unetbootin/Makefile                       |  1 +
 sysutils/vzvol/Makefile                            |  2 +-
 13 files changed, 22 insertions(+), 69 deletions(-)