Bug 261717 - devel/py-qt5-pyqt: 'make check-plist' fails if devel/py-dbus is installed
Summary: devel/py-qt5-pyqt: 'make check-plist' fails if devel/py-dbus is installed
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-kde (Team)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-02-04 19:26 UTC by John Hein
Modified: 2022-05-29 11:28 UTC (History)
6 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Hein 2022-02-04 19:26:40 UTC
If you build devel/py-qt5-pyqt with devel/py-dbus already installed, 'make check-plist' fails:

====> Checking for pkg-plist issues (check-plist)
===> Parsing plist
===> Checking for items in STAGEDIR missing from pkg-plist
Error: Orphaned: %%PYTHON_SITELIBDIR%%/dbus/mainloop/pyqt5.abi%%PYTHON_MAJOR_VER%%.so
===> Checking for items in pkg-plist which are not in STAGEDIR
===> Error: Plist issues found.
*** Error code 1


devel/py-qt5-pyqt should probably be more explicit about whether to build with dbus support or not.  Maybe the right move is to disable building that.  Or maybe it's better to just include a build/run dependency on py-dbus.  I don't think it's worthwhile to make dbus support an option.  It's probably just better to explicitly enable or disable it (so it's not an implicit detection that changes the build - which then might break the installed py-qt5-pyqt if the py-dbus pkg is removed later because the dependency is not recorded)
Comment 1 Adriaan de Groot freebsd_committer 2022-05-24 10:16:27 UTC
Can't reproduce: whatever I do in poudriere, at least, gets me only this:

Checking to see if the dbus-python support should be built...
pkg-config --cflags-only-I --libs dbus-1
DBus v1 does not seem to be installed.
dbus/dbus-python.h could not be found and so the dbus-python support module will be disabled. If dbus-python is installed then use the --dbus argument to explicitly specify the directory containing dbus/dbus-python.h.
Comment 2 John Hein 2022-05-24 22:33:08 UTC
(In reply to Adriaan de Groot from comment #1)
Forgive me for asking, but did you install devel/py-dbus in your poudriere environment before trying to build devel/py-qt5-pyqt (as described in the original problem description)?
Comment 3 commit-hook freebsd_committer 2022-05-29 11:22:10 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=78e416d826472fd8eca9f3cf702e171914443273

commit 78e416d826472fd8eca9f3cf702e171914443273
Author:     Adriaan de Groot <adridg@FreeBSD.org>
AuthorDate: 2022-05-24 11:55:14 +0000
Commit:     Adriaan de Groot <adridg@FreeBSD.org>
CommitDate: 2022-05-29 11:16:33 +0000

    devel/py-qt5-pyqt: add DBus dependency

    This makes DBus explicitly available when installing py-qt5-pyqt,
    which is good for desktop use. Previously, building this with
    DBus installed **and** pkgconfig and the Python DBus bindings
    would trip up in `check-plist`.

    PR:             261717
    Reported by:    John Hein

 devel/py-qt5-pyqt/Makefile  | 7 +++++--
 devel/py-qt5-pyqt/pkg-plist | 1 +
 2 files changed, 6 insertions(+), 2 deletions(-)
Comment 4 Adriaan de Groot freebsd_committer 2022-05-29 11:28:17 UTC
Answering #c2: Yes, I did install the relevant package in my poudriere builder. However, you also need to have `pkgconfig` installed, otherwise the DBus bits aren't found even if they **are** installed. All those dependencies are now added, so there is explicit dbus support in pyqt now.