Bug 263059 - mail/claws-mail: update to latest 3.19.0
Summary: mail/claws-mail: update to latest 3.19.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Juraj Lutter
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-04-05 11:54 UTC by bsd
Modified: 2022-05-20 09:44 UTC (History)
3 users (show)

See Also:
portmaster: maintainer-feedback+


Attachments
Patch to update port to latest 3.19.0 (3.67 KB, patch)
2022-04-05 11:54 UTC, bsd
no flags Details | Diff
git diff to update claws-mail to 3.19.0 (2.30 KB, patch)
2022-04-14 16:18 UTC, Chris Hutchinson
portmaster: maintainer-approval-
Details | Diff
git diff for mail/claws-mail (patch) (4.17 KB, patch)
2022-05-16 21:51 UTC, Chris Hutchinson
portmaster: maintainer-approval+
Details | Diff
git diff for mail/claws-mail (updated) (4.61 KB, patch)
2022-05-17 15:49 UTC, Chris Hutchinson
portmaster: maintainer-approval+
Details | Diff
git diff for mail/claws-mail ( final ) (12.34 KB, patch)
2022-05-18 16:26 UTC, Chris Hutchinson
portmaster: maintainer-approval+
Details | Diff
Last minute fixes (13.03 KB, patch)
2022-05-19 10:22 UTC, bsd
no flags Details | Diff
final patch for mail/claws-mail (13.17 KB, patch)
2022-05-19 17:59 UTC, Chris Hutchinson
portmaster: maintainer-approval+
Details | Diff
Build log on 12.x (954.98 KB, text/plain)
2022-05-19 19:54 UTC, Chris Hutchinson
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description bsd 2022-04-05 11:54:22 UTC
Created attachment 232960 [details]
Patch to update port to latest 3.19.0

3rd April 2022                              Claws Mail 3.19.0 / 4.1.0

		    CLAWS MAIL  RELEASE NOTES
                    http://www.claws-mail.org

Claws Mail is a GTK+ based, user-friendly, lightweight, and fast 
email client.

New in this release:
~~~~~~~~~~~~~~~~~~~~

* Text zooming in the Message View is now possible, using CTRL+mouse
  wheel up/down, CRTL+touchpad two-fingered vertical swiping, or
  the Message View's right-click menu.

* GtkColorChooser is now used in the Spell Checking preferences,
  Colour Label preferences, and the folder Properties pages.

* 'Default From:' has been added to the Compose page of the folder
  Properties. This allows setting an email address which will
  override the Account's email address.

* An option has been added to the 'General' page of the folder
  Properties, 'Skip folder when searching for unread or new
  messages', so that the folder can be skipped when using Go To
  next/previous unread/new message.

* 'By Sender' has been added to '/Tools/Create filtering rule/...'
  and '/Tools/Create processing rule/...'

* The option 'Run processing rules before marking all messages in a
  folder as read or unread' has been added to
  '/Configuration/Preferences/Display/Summaries'.

* It is now possible to add a toolbar button to 'Run folder
  processing rules'.

* The Actions configuration list now has 'Top' and 'Bottom' buttons.

* In '/Tools/List URLs' it is now possible to CTRL+c or right-click
  a list item and 'Copy URL'; copying multiple selections is also
  possible.
  Phishing URLs are now indicated in red by default. This uses the
  colour defined in the hidden preference, log_error_color.

* The method of handling Tags has been improved.

* When using the separate Message View the Enter key will open the
  currently selected message in the Message List. So, for example,
  if you delete the current message, pressing Enter will open the
  next message without having to leave the separate Message View.

* The quicksearch type-ahead keypress delay is now customizable
  using a hidden preference ("qs_press_timeout").

* Improvements to the storage of OAuth2 refresh tokens.

* A "View all" button has been added to the Themes preferences page
  in order to preview all icons of a theme.

* The term 'master passphrase' has been replaced in the UI with
  'primary passphrase'.

* The label 'SSL/TLS' has been replaced with 'TLS' in the UI.

* chmod 0600 is set on log files, history files, saved parts, etc.

* "Keyword Warner" plugin has been added. This shows a warning when
  sending or queueing a message and a reference to one or more
  user-defined keywords are found in the message text.

* Adding a new RSSyl feed or subscribing to a Webcal will
  automatically suggest using any suitable URI found on the
  clipboard.

* The user manuals have been updated.

* Updated translations: Brazilian Portuguese, British English,
  Catalan, Czech, French, Indonesian, Polish, Romanian, Russian,
  Slovak, Spanish, Turkish.

* bug fixes:
	o bug 4312, 'litehtml plugin loops (hangup)'
	o bug 4346, 'Error: Certificate is for invalid2.invalid, but
		     connection is to imap.gmail.com'
	o bug 4442, 'vcalendar segfault if in invitation email and
		     switch to another folder'
	o bug 4495, 'Improve text strings for OAuth2'
	o bug 4496, 'Fancy crashes when opening an email'
	o bug 4511, 'Uses deprecated ghostscript operator'
	o bug 4513, 'msg window too small in 3 column layout'
	o bug 4517, 'Thread safety issues in signature checking code'
	o bug 4524, 'Problems exiting/closing Claws Mail'
	o bug 4534, 'Address book causing claws to terminate
		     unexpectedly'
	o bug 4535, 'Setting msgview_date_format=1 does not work'
	o bug 4536, 'Tab for address selects second entry'
	o bug 4556, 'Filesize in kilobytes versus kibibytes'
	o bug 4577, 'Fancy plugin with GTK3 seems to ignore content
		     encoding'
	o when using 'hide_timezone' use UTC when generating
	  MessageID
	o non-translation of some button labels
	o the initial position of the (X-)Face image
	o return receipts from accounts without a name
	o folderview pixmaps not being updated after icon theme
	  change until restart
	o spell checker underlining when black is chosen
	o text on various buttons
	o scrolling in a message's attachments bar (scrolling left or
	  right were scrolling down).
	o scrolling not working when GTK smooth scroll is set
	o scroll to next/prev page in pdf_viewer
	o build error with -Werror=format-security
	o invalid crypto engine (gpgme_op_verify failed)
	o vCalendar tooltip in Day View showed the wrong month.
	o View Log button
	o when closing Compose window dialogue requesting choice from
	  user is not shown and some options are lost in drafted copy
	o weird logic with the 'Edit filter action' dialog
	o resource leaks; memory corruption

For further details of the numbered bugs and RFEs listed above
see https://www.claws-mail.org/bug/[BUG NUMBER]

---------------------------------------------------------------------
See ChangeLog for full information regarding changes in this release.
Comment 1 bsd 2022-04-05 12:07:31 UTC
Patch provided does upgrade of main mail/claws-mail port, upgrade of mail/claws-mail-plugins metaport and reset PORTREVISION for mail/claws-mail-pdf_viewer plugin port. These three should be commited together, I think. Additionally, two new plugins are being added, which probably may be commited separatelly, at the commiter's discretion. First one is mail/claws-mail-acpi_notifier, which was missing in FreeBSD ports collection. Second one is mail/claws-mail-keyword_warner, newly introduced in this release.

All affected ports were built for test on newly created jail from scratch without issue (together with all their dependencies) on recent 13.1-STABLE/amd64 system.
Comment 2 Chris Hutchinson 2022-04-05 15:09:35 UTC
Comment on attachment 232960 [details]
Patch to update port to latest 3.19.0

Tested on a running 12 box to no ill avail.
Works on a 13 Jail. Untested on 14.

APPROVED Thank you!

Agreed. I think the additional plugin should be added separately. If
for no other reason, because it's a new port.

Thanks again!

--Chris
Comment 3 bsd 2022-04-09 05:03:43 UTC
I think you forgot set maintainer feedback flag to + as signal of acceptance so a commiter could act on this...
Comment 4 bsd 2022-04-11 05:50:28 UTC
Now was just added following line into mail/claws-mail/Makefile (to mark some dependency update):

PORTREVISION=	1

It should be removed before committing patch for port update.
Comment 5 Chris Hutchinson 2022-04-12 04:47:57 UTC
(In reply to bsd from comment #4)
Yes. Agreed. I'll fix it tomorrow.
Thanks. :-)
Comment 6 Chris Hutchinson 2022-04-14 16:18:02 UTC
Created attachment 233220 [details]
git diff to update claws-mail to 3.19.0

Heres a new patch that addresses all the problems
raised against the original patch submitted by Milan.

This patch only contains the necessary bits to upgrade
claws-mail to 3.19.0

The additional bits for the added plugins will be added
as separate pr(1)s accordingly.

Thanks Milan for all you're efforts here! :-)

--Chris
Comment 7 Chris Hutchinson 2022-04-14 16:19:05 UTC
Comment on attachment 232960 [details]
Patch to update port to latest 3.19.0

Disregard this patch (is obsolete)
Comment 8 bsd 2022-05-15 06:30:25 UTC
Two more slave ports need now their PORTREVISION reset - mail/claws-mail-clamd and mail/claws-mail-litehtml_viewer.
Comment 9 Juraj Lutter freebsd_committer 2022-05-16 14:32:43 UTC
Chris, please review patches and set maintainer feedback on patches and also on the port itself, so we can proceed with the commit.
Comment 10 Chris Hutchinson 2022-05-16 17:16:02 UTC
Comment on attachment 232960 [details]
Patch to update port to latest 3.19.0

Approved.
Thanks!
Comment 11 Chris Hutchinson 2022-05-16 17:19:05 UTC
(In reply to Chris Hutchinson from comment #10)
Strike that.
The mozilla pr(1) system is NOT functioning
as directed. If I can't make it accept my intentions.
I'll open a new one. I'll attempt to submit an updated
patch in a few.
Comment 12 Chris Hutchinson 2022-05-16 17:19:45 UTC
Comment on attachment 232960 [details]
Patch to update port to latest 3.19.0

Delete this
Comment 13 Chris Hutchinson 2022-05-16 17:20:09 UTC
Comment on attachment 232960 [details]
Patch to update port to latest 3.19.0

Delete this
Comment 14 Chris Hutchinson 2022-05-16 21:51:34 UTC
Created attachment 233974 [details]
git diff for mail/claws-mail (patch)

OK This should be all that's needed.
Builds and works as intended.
Passes check-plist | stage-qa | check-sanity && portlint

please commit.

Thanks!

Chris
Comment 15 Chris Hutchinson 2022-05-17 15:49:03 UTC
Created attachment 234002 [details]
git diff for mail/claws-mail (updated)

Updated patch to cover a couple of PORTREVISION resets that
I missed.

That's it.

Thanks!
Comment 16 Chris Hutchinson 2022-05-18 16:26:41 UTC
Created attachment 234024 [details]
git diff for mail/claws-mail ( final )

Was feeling a bit pedantic today and
noticed this hadn't been committed yet.
So cleaned up some nits I had.

This is it, please commit. :-)

Chris
Comment 17 bsd 2022-05-19 10:22:23 UTC
Created attachment 234032 [details]
Last minute fixes

Fixed typo in sources (reported and accepted upstream)
Comment 18 Chris Hutchinson 2022-05-19 17:55:03 UTC
(In reply to bsd from comment #17)
Thanks for your work here Milan. But you must
have been working with an old(er) checkout.
As the patch wouldn't apply. eg;
diff --git a/mail/claws-mail-notification/Makefile ...
showed:
-PORTREVISION=	0
 but should hve been
-PORTREVISION=	1

I'm attaching one I tested against a fresh c/o today.

Thanks again -- especially for your work/efforts upstream.

Chris
Comment 19 Chris Hutchinson 2022-05-19 17:59:05 UTC
Created attachment 234036 [details]
final patch for mail/claws-mail

FINAL patch. Includes a recent update accepted
upstream.

We ARE done here.
I will approve nothing else until this gets comitted. :-)

Thanks! :-)

Chris
Comment 20 Chris Hutchinson 2022-05-19 18:00:02 UTC
Comment on attachment 234032 [details]
Last minute fixes

diff/patch doesn't apply.
Comment 21 Juraj Lutter freebsd_committer 2022-05-19 18:01:56 UTC
Please, attach also poudriere build logs. (poudriere bulk, poudriere testport)
Comment 22 bsd 2022-05-19 19:37:15 UTC
(In reply to Chris Hutchinson from comment #18)

This change was commited today after I did git fetch to my local repository... I just found it now.
Comment 23 Chris Hutchinson 2022-05-19 19:49:52 UTC
(In reply to bsd from comment #22)
No prob. I was jest being pedantic. So I
tested the patch before signing off on it. :-)

Thanks again, Milan!

Chris
Comment 24 Chris Hutchinson 2022-05-19 19:54:35 UTC
Created attachment 234039 [details]
Build log on 12.x

This is fog food. I tested it on my 12 box.
This is the build log.

SUMMARY:

12:04pm
root@portsdev:/usr/ports/mail/claws-mail # make check-plist

...

====> Compressing man pages (compress-man)
====> Running Q/A tests (stage-qa)
====> Checking for pkg-plist issues (check-plist)
===> Parsing plist
===> Checking for items in STAGEDIR missing from pkg-plist
===> Checking for items in pkg-plist which are not in STAGEDIR
===> No pkg-plist issues found (check-plist)
12:04pm
root@portsdev:/usr/ports/mail/claws-mail # make stage-qa

====> Running Q/A tests (stage-qa)
12:03pm
root@portsdev:/usr/ports/mail/claws-mail # make check-sanity

===>  License GPLv3 accepted by the user
12:05pm
root@portsdev:/usr/ports/mail/claws-mail #


That's all folks...

Chris
Comment 25 Juraj Lutter freebsd_committer 2022-05-19 20:23:36 UTC
Which of the patches is the correct one to be committed?
Comment 26 Chris Hutchinson 2022-05-19 20:25:15 UTC
Comment on attachment 234036 [details]
final patch for mail/claws-mail

THIS is the correct patch.
Please use this one.

HTH

Chris
Comment 27 commit-hook freebsd_committer 2022-05-20 09:32:41 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=32ad969046297db0f37da5dcf83e0965a2f0a66d

commit 32ad969046297db0f37da5dcf83e0965a2f0a66d
Author:     Milan Obuch <bsd@dino.sk>
AuthorDate: 2022-05-20 08:58:13 +0000
Commit:     Juraj Lutter <otis@FreeBSD.org>
CommitDate: 2022-05-20 09:31:53 +0000

    mail/claws-mail: Update to 3.19.0

    - Update to 3.19.0
    - Reset PORTREVISION where apropriate (notably in slave ports)

    And while here, also portclippy and portfmt a bit.

    Approved by:    Chris Hutchinson <portmaster@bsdforge.com> (maintainer)
    PR:             263059

 mail/claws-mail-address_keeper/Makefile        |  1 -
 mail/claws-mail-archive/Makefile               |  1 -
 mail/claws-mail-att_remover/Makefile           |  1 -
 mail/claws-mail-attachwarner/Makefile          |  1 -
 mail/claws-mail-bogofilter/Makefile            |  1 -
 mail/claws-mail-bsfilter/Makefile              |  1 -
 mail/claws-mail-clamd/Makefile                 |  1 -
 mail/claws-mail-dillo/Makefile                 |  1 -
 mail/claws-mail-dillo/pkg-descr                |  3 +-
 mail/claws-mail-fetchinfo/Makefile             |  1 -
 mail/claws-mail-gdata/Makefile                 |  1 -
 mail/claws-mail-gdata/pkg-descr                |  2 +-
 mail/claws-mail-libravatar/Makefile            |  1 -
 mail/claws-mail-litehtml_viewer/Makefile       |  1 -
 mail/claws-mail-mailmbox/Makefile              |  1 -
 mail/claws-mail-managesieve/Makefile           |  1 -
 mail/claws-mail-newmail/Makefile               |  1 -
 mail/claws-mail-notification/Makefile          |  1 -
 mail/claws-mail-pdf_viewer/Makefile            |  1 -
 mail/claws-mail-perl/Makefile                  |  1 -
 mail/claws-mail-pgp/Makefile                   |  1 -
 mail/claws-mail-plugins/Makefile               |  2 +-
 mail/claws-mail-rssyl/Makefile                 |  1 -
 mail/claws-mail-rssyl/pkg-descr                |  2 +-
 mail/claws-mail-spam_report/Makefile           |  1 -
 mail/claws-mail-spamassassin/Makefile          |  1 -
 mail/claws-mail-tnef_parse/Makefile            |  1 -
 mail/claws-mail-vcalendar/Makefile             |  1 -
 mail/claws-mail/Makefile                       | 49 +++++++++++++-------------
 mail/claws-mail/Makefile.claws                 |  2 +-
 mail/claws-mail/Makefile.claws.plugins         |  1 +
 mail/claws-mail/distinfo                       |  8 ++---
 mail/claws-mail/files/patch-configure.ac (new) | 11 ++++++
 33 files changed, 46 insertions(+), 58 deletions(-)
Comment 28 Juraj Lutter freebsd_committer 2022-05-20 09:44:31 UTC
Committed, thanks.