Bug 30854 - bootpd(8) bootpgw change - skip ARP modifications by option
Summary: bootpd(8) bootpgw change - skip ARP modifications by option
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: CURRENT
Hardware: Any Any
: Normal Affects Only Me
Assignee: Mark Johnston
URL: https://reviews.freebsd.org/D2581
Keywords: easy, feature
Depends on:
Blocks:
 
Reported: 2001-09-26 23:40 UTC by Dan Lukes
Modified: 2019-05-28 14:20 UTC (History)
3 users (show)

See Also:
koobs: mfc-stable12+
koobs: mfc-stable11-


Attachments
file.diff (3.29 KB, patch)
2001-09-26 23:40 UTC, Dan Lukes
no flags Details | Diff
updated patch (3.86 KB, patch)
2015-05-19 03:46 UTC, Mark Felder
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Lukes 2001-09-26 23:40:01 UTC
	I have pre-set ARP table with permanent records (MAC addresses) 
for all possible directly connected IP address. It complicate IP address 
spoofing a lot. I want retain distribution of IP adresses (and other
options) via BOOTP (central management is easy).

	The bootpd and bootpgw replace already present ARP permanent 
records with temporary ones. I want disable this functionality by option.

	The new [-a] option force bootpd and bootpgw to skip the ARP table
modifications.
	
	(Yes, I know, skilled user can change the MAC address of NIC, so
spoofing is still possible - but it's better than nothing)

How-To-Repeat: 	N/A
Comment 1 Dan Lukes 2009-12-10 10:54:25 UTC
Despite originally requested for 4.4-RELEASE, it still apply to current 
as well.

						Dan
Comment 2 Mark Felder freebsd_committer 2015-05-19 03:46:48 UTC
Created attachment 156923 [details]
updated patch

This is one of the oldest PRs I've ever seen and it nearly applies cleanly.

I fixed the patch rejection and added a man page modification.

Maybe 14 years later someone will take notice? :-)
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2015-05-19 05:49:45 UTC
If the issue is still in CURRENT, update the Version field to suit, and possibly assign to freebsd-net?
Comment 4 Dan Lukes 2015-05-19 08:41:32 UTC
It's not issue but rather enhancement request (this ancient PR has been created at the times the database has been used not only to report bugs but enhancement requests as well).

Yes, the "issue" still exists and the patch apply to all supported RELEASES and to HEAD as well, it "solve" the "issue" and harm nothing  ...

... but I'm not so sure if there's anyone using bootpd.

We will not use BOOTPD anymore so I'm interested in this feature no longer. 

Feel free to either commit or close this historic PR.
Comment 5 Mark Felder freebsd_committer 2015-05-19 13:25:53 UTC
I added a phabic review for this:

https://reviews.freebsd.org/D2581
Comment 6 commit-hook freebsd_committer 2019-05-21 21:23:12 UTC
A commit references this bug:

Author: markj
Date: Tue May 21 21:22:44 UTC 2019
New revision: 348066
URL: https://svnweb.freebsd.org/changeset/base/348066

Log:
  bootpd: Add an option to skip modifications to the ARP table.

  PR:		30854
  Submitted by:	Dan Lukes <dan@obluda.cz>
  Reviewed by:	imp (previous version)
  MFC after:	1 week
  Event:		Waterloo Hackathon 2019
  Differential Revision:	https://reviews.freebsd.org/D2581

Changes:
  head/libexec/bootpd/bootpd.8
  head/libexec/bootpd/bootpd.c
  head/libexec/bootpd/bootpgw/bootpgw.c
Comment 7 Kubilay Kocak freebsd_committer freebsd_triage 2019-05-22 03:39:31 UTC
Thanks Mark!
Comment 8 commit-hook freebsd_committer 2019-05-28 14:18:02 UTC
A commit references this bug:

Author: markj
Date: Tue May 28 14:17:04 UTC 2019
New revision: 348326
URL: https://svnweb.freebsd.org/changeset/base/348326

Log:
  MFC r348066, r348090:
  bootpd: Add an option to skip modifications to the ARP table.

  PR:	30854

Changes:
_U  stable/12/
  stable/12/libexec/bootpd/bootpd.8
  stable/12/libexec/bootpd/bootpd.c
  stable/12/libexec/bootpd/bootpgw/bootpgw.c
Comment 9 Mark Johnston freebsd_committer 2019-05-28 14:19:08 UTC
Thanks for the patch.  I'm sorry that it lingered for so long.