Bug 30904 - [PATCH] allow route to create "proxy only" arp entries
Summary: [PATCH] allow route to create "proxy only" arp entries
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 4.4-RELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: ru
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2001-09-29 01:40 UTC by Craig Leres
Modified: 2001-10-02 11:05 UTC (History)
1 user (show)

See Also:


Attachments
file.diff (6.58 KB, patch)
2001-09-29 01:40 UTC, Craig Leres
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Craig Leres freebsd_committer 2001-09-29 01:40:01 UTC
	It would be really nice if route(8) could add the necessary
	magic to create "proxy only" arp entries.

Fix: There is background about this change here:

	    http://www.FreeBSD.org/cgi/query-pr.cgi?pr=12357

	It looks like 
	
	The appended context diffs add -announce and -proxy flags
	to route(8). I've also included some minor gcc/lint and
	prototype fixes. But the actual code changes to add the
	new flags are minimal.

	BTW, the route(8) man page says it was last modified on
	March 19th, 1994 but it's obviously been updated many times
	since then.

===================================================================
RCS file: RCS/Makefile,v
retrieving revision 1.1
Comment 1 ru freebsd_committer 2001-10-02 09:42:43 UTC
I have already committed your changes in route.c,v 1.51.
Modulo the -announce (gratuitous ARP) part, which is
turned on automatically for -proxy.  Will MFC shortly.


Cheers,
-- 
Ruslan Ermilov		Oracle Developer/DBA,
ru@sunbay.com		Sunbay Software AG,
ru@FreeBSD.org		FreeBSD committer,
+380.652.512.251	Simferopol, Ukraine

http://www.FreeBSD.org	The Power To Serve
http://www.oracle.com	Enabling The Information Age
Comment 2 ru freebsd_committer 2001-10-02 11:04:04 UTC
State Changed
From-To: open->closed

Duplicate of PR 12357. 
Please resubmit your style fixes. 


Comment 3 ru freebsd_committer 2001-10-02 11:04:04 UTC
Responsible Changed
From-To: freebsd-bugs->ru