Bug 33320 - print/acroread5 does not install the Netscape plugin correctly
Summary: print/acroread5 does not install the Netscape plugin correctly
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: sada
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2001-12-30 02:40 UTC by John Merryweather Cooper
Modified: 2004-07-25 11:38 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Merryweather Cooper 2001-12-30 02:40:00 UTC
	The plugin should be installed in:

	/usr/local/lib/netscape-linux/plugins

	instead of it's current location.

Fix: 

1) install nppdf.so in the correct directory;
	2) and /usr/local/Acrobat4/bin to the PATH;
	3) add linux-netscapce-communicator as a RUN_DEPENDS;
	4) add pkg-message to the effect:

To use the plugin with Linux Netscape, the plugin must be manually
activiated.  To do this, goto Edit->Preferences->Navigator->Applications
add the following as 'New':

	Description:  Portable Document Format
	MIMEType:  application/pdf
	Suffixes:  pdf

	[X] Use this MIME as the outgoing default for these extensions

	Handled by

	[X] Plug In:  nppdf.so
How-To-Repeat: 	Observe pkg-plist installation path for nppdf.so
Comment 1 Patrick Li freebsd_committer 2001-12-30 07:43:09 UTC
Responsible Changed
From-To: freebsd-ports->dima

Over to maintainer
Comment 2 Dima Ruban 2002-02-23 02:14:40 UTC
I would think that acroread4 port should take the same approach as
mozilla port (java plugin). In other words, wouldn't it be simplier
to have a symlink from ${PREFIX}/local/linux-netscape/plugins (or 
whatever the correct path is) to nppdf.so?


(It's just a suggestion, not a statement :-)
Comment 3 John Merryweather Cooper 2002-08-25 15:07:01 UTC
I like the symlink idea too.  Note that Acroread5 has inherited the same 
problem (the plugin is not installed accessible to linux-netscape).

jmc
Comment 4 Jun Kuriyama freebsd_committer 2003-07-08 00:07:19 UTC
Responsible Changed
From-To: dima->trevor

Over to print/acroread5 maintainer.
Comment 5 John Merryweather Cooper 2004-02-22 02:30:30 UTC
The problems with print/acroread5 and the installation of the plugin 
still exist and their correction is now magnified by the existance of 
linuxpluginwrapper which makes the plugin from this port viable for the 
majority of FreeBSD web browsers.

jmc
Comment 6 Volker Stolz freebsd_committer 2004-07-02 13:34:57 UTC
Sorry guys, I don't think that's never going to work out your way: Should  
Acrobat5 depend on Netscape
so that it can install the link? Never. Should Netscape depend on  
Acrobat5? Neither.

This here's a different solution (cut'n'pasted for reading, not patching)  
which solves the
problem neatly I think. Kenji-san, could you please take a look at this  
patch and maybe approve it?

Cheers,
   Volker

netscape48-communicator@menelaos [14:33:51]> !cvs
cvs diff -u
cvs diff: Diffing .
Index: Makefile
===================================================================
RCS file:  
/usr/freebsdcvs/cvs-ports/ports/www/netscape48-communicator/Makefile,v
retrieving revision 1.87
diff -u -r1.87 Makefile
--- Makefile    6 Mar 2003 19:23:19 -0000       1.87
+++ Makefile    2 Jul 2004 12:28:36 -0000
@@ -49,6 +49,7 @@
         ${SED}  -e "s;@PREFIX@;${PREFIX};g" -e "s;@NSUBDIR@;${NSUBDIR};g" \
                 -e "s;@BROWSER@;${BROWSER_ARC};g" \
                 -e "s;@BROWSER_VER@;${BROWSER_VER};g" \
+               -e "s;@LOCALBASE@;${LOCALBASE};" \
                 ${WRAPPER_TEMPLATE} >${WRKSRC}/netscape
         ${CHMOD} +x ${WRKSRC}/netscape
         ${ECHO_CMD} -n ${INFILE_HEAD},${NDIR} >${WRKSRC}/infile
cvs diff: Diffing files
Index: files/netscape.sh
===================================================================
RCS file:  
/usr/freebsdcvs/cvs-ports/ports/www/netscape48-communicator/files/netscape.sh,v
retrieving revision 1.12
diff -u -r1.12 netscape.sh
--- files/netscape.sh   5 Aug 2001 17:46:40 -0000       1.12
+++ files/netscape.sh   2 Jul 2004 12:29:17 -0000
@@ -1,6 +1,6 @@
  #!/bin/sh
  export MOZILLA_HOME; MOZILLA_HOME=${MOZILLA_HOME:=@PREFIX@/@NSUBDIR@}
-export NPX_PLUGIN_PATH; NPX_PLUGIN_PATH=${MOZILLA_HOME}/plugins
+export NPX_PLUGIN_PATH;  
NPX_PLUGIN_PATH=${MOZILLA_HOME}/plugins:@LOCALBASE@/Acrobat5/Browsers/intellinux/
  export CLASSPATH ; CLASSPATH=.:$MOZILLA_HOME
  export XCMSDB; XCMSDB=/dev/null
  ulimit -c 0
cvs diff: Diffing scripts
Comment 7 Volker Stolz freebsd_committer 2004-07-02 13:35:25 UTC
Responsible Changed
From-To: trevor->sada

Suggest fixing Netscape's plugin-path and ask sada@ for approval.
Comment 8 Volker Stolz freebsd_committer 2004-07-25 11:37:43 UTC
State Changed
From-To: open->closed

Fixed, thanks!