Bug 36028 - cannot build gnomevfs with gettext WANT_FULL_GETTEXT
Summary: cannot build gnomevfs with gettext WANT_FULL_GETTEXT
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-03-18 00:40 UTC by obraun
Modified: 2002-03-28 12:46 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description obraun 2002-03-18 00:40:01 UTC
After building gettext with WANT_FULL_GETTEXT=yes gnomevfs build failed,
because gnomevfs depends on msgfmt-new, but msgfmt-new is only available
after installing gettext *WITHOUT* WANT_FULL_GETTEXT=yes.

Fix: 

change in devel/gnomevfs/Makefile:

-BUILD_DEPENDS=  msgfmt-new:${PORTSDIR}/devel/gettext \
+BUILD_DEPENDS=  msgfmt:${PORTSDIR}/devel/gettext \

Regards,
         Olli
How-To-Repeat: cd /usr/ports/devel/gettext && make WANT_FULL_GETTEXT=yes install
cd /usr/ports/devel/gnomevfs && make
Comment 1 obraun 2002-03-18 00:43:03 UTC
same problem with:

  x11-wm/windowmaker
  devel/bonobo
  devel/bugbuddy
  devel/gtranslator
  devel/gnomevfs2
  games/gnomegames
  irc/xchat
  misc/gnomeutils
  net/gabber
  www/galeon
  x11/gnomeapplets
  x11/gnomecore
  x11-fm/nautilus

depending on xgettext-new and/or msgfmt-new.

Regards,
         Olli
-- 
Department of Computing Science
Federal Armed Forces University Munich
http://ist.unibw-muenchen.de/People/obraun/
Comment 2 Ying-Chieh Liao freebsd_committer 2002-03-18 03:49:08 UTC
Responsible Changed
From-To: freebsd-ports->gnome

over to maintainer
Comment 3 Maxim Sobolev 2002-03-18 07:42:24 UTC
- Doctor, it hurts when I do this!
- Well, don't do it then.

:)

The problem is that WANT_FULL_GETTEXT knob is provided for developers
only, who know what they do. For all others, it just going to break many
things. Therefore, please deinstall gettext-0.10.40, rebuild it without
WANT_FULL_GETTEXT and reinstall. After that you should be fine.

-Maxim

On Mon, 2002-03-18 at 04:10, Oliver Braun wrote:
> The following reply was made to PR ports/36028; it has been noted by GNATS.
> 
> From: Oliver Braun <obraun@informatik.unibw-muenchen.de>
> To: FreeBSD-gnats-submit@FreeBSD.ORG
> Cc:  
> Subject: Re: ports/36028: cannot build gnomevfs with gettext WANT_FULL_GETTEXT
> Date: Mon, 18 Mar 2002 01:43:03 +0100
> 
>  same problem with:
>  
>    x11-wm/windowmaker
>    devel/bonobo
>    devel/bugbuddy
>    devel/gtranslator
>    devel/gnomevfs2
>    games/gnomegames
>    irc/xchat
>    misc/gnomeutils
>    net/gabber
>    www/galeon
>    x11/gnomeapplets
>    x11/gnomecore
>    x11-fm/nautilus
>  
>  depending on xgettext-new and/or msgfmt-new.
>  
>  Regards,
>           Olli
>  -- 
>  Department of Computing Science
>  Federal Armed Forces University Munich
>  http://ist.unibw-muenchen.de/People/obraun/
> 
> To Unsubscribe: send mail to majordomo@FreeBSD.org
> with "unsubscribe freebsd-ports" in the body of the message
> 
>
Comment 4 obraun 2002-03-18 09:38:31 UTC
Hi Maxim,

> The problem is that WANT_FULL_GETTEXT knob is provided for developers
> only, who know what they do. For all others, it just going to break many
> things. Therefore, please deinstall gettext-0.10.40, rebuild it without
> WANT_FULL_GETTEXT and reinstall. After that you should be fine.

Ok. I got this, but as Udo Schweigert has pointed out already [1] on
this list:

> I just run portupgrade wihich updated gettext to 0.10.40. Unfortunately this
> port now does not build the shared libraries by default, you have to turn
> it on via the WANT_FULL_GETTEXT knob.
> Because I hadn't a working libintl after that upgrade other portupgrades
> e.g mozilla, failed because configure did not detect the libintl.

So I just want to point out that turning on WANT_FULL_GETTEXT could
cause other problems.

Is it recommended to have both gettext-0.10.40 and gettext-0.10.35
installed?

Regards,
         Olli

1. Message-ID: <20020316083402.GA68217@alaska.cert.siemens.de>
-- 
Department of Computing Science
Federal Armed Forces University Munich
http://ist.unibw-muenchen.de/People/obraun/
Comment 5 Maxim Sobolev freebsd_committer 2002-03-18 17:20:40 UTC
Oliver Braun wrote:
> 
> Hi Maxim,
> 
> > The problem is that WANT_FULL_GETTEXT knob is provided for developers
> > only, who know what they do. For all others, it just going to break many
> > things. Therefore, please deinstall gettext-0.10.40, rebuild it without
> > WANT_FULL_GETTEXT and reinstall. After that you should be fine.
> 
> Ok. I got this, but as Udo Schweigert has pointed out already [1] on
> this list:
> 
> > I just run portupgrade wihich updated gettext to 0.10.40. Unfortunately this
> > port now does not build the shared libraries by default, you have to turn
> > it on via the WANT_FULL_GETTEXT knob.
> > Because I hadn't a working libintl after that upgrade other portupgrades
> > e.g mozilla, failed because configure did not detect the libintl.
> 
> So I just want to point out that turning on WANT_FULL_GETTEXT could
> cause other problems.
> 
> Is it recommended to have both gettext-0.10.40 and gettext-0.10.35
> installed?

Not only recommended, but it is currently required.

-Maxim
Comment 6 Maxim Sobolev freebsd_committer 2002-03-28 12:46:02 UTC
State Changed
From-To: open->closed

The problem was resolved.