Bug 36104 - Patch for some XFree86-4 ports.
Summary: Patch for some XFree86-4 ports.
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-03-19 17:00 UTC by Hidekazu Kuroki
Modified: 2002-03-20 00:34 UTC (History)
0 users

See Also:


Attachments
file.diff (10.33 KB, patch)
2002-03-19 17:00 UTC, Hidekazu Kuroki
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Hidekazu Kuroki 2002-03-19 17:00:04 UTC
This patch is applying xfree86.org's public fixes for some XFree86-4 ports.
 Applying public fixes list:
   4.2.0-libGLU-bad-extern.patch
   4.2.0-xlib-i18n-module.patch
   4.2.0-zlib-security.patch
Comment 1 Will Andrews 2002-03-19 17:59:04 UTC
On Wed, Mar 20, 2002 at 01:55:03AM +0900, Hidekazu Kuroki wrote:
>    4.2.0-libGLU-bad-extern.patch

This doesn't apply to us, we don't use "newer versions" of GCC.

>    4.2.0-xlib-i18n-module.patch

This patch was applied to XFree86-4-libraries earlier.

>    4.2.0-zlib-security.patch

Doesn't apply to us, we link to libz in the system, which is
unaffected by this problem thanks to phkmalloc.

Thanks for your submission.
-- 
wca
Comment 2 Hidekazu Kuroki 2002-03-19 19:09:44 UTC
  Will Andrews <will@csociety.org> wrote in :
  -------------------------------------------------------
  Date       : Tue, 19 Mar 2002 12:59:04 -0500
  Subject    : Re: ports/36104: Patch for some XFree86-4 ports.
  Message-ID : <20020319175904.GJ22998@squall.waterspout.com>
  -------------------------------------------------------

> >    4.2.0-libGLU-bad-extern.patch
> This doesn't apply to us, we don't use "newer versions" of GCC.
OK.
But if anyone use gcc30, gcc31 or gcc32 for building XFree86-4,
doesn't a problem occur?
Comment 3 Will Andrews 2002-03-19 19:15:54 UTC
On Wed, Mar 20, 2002 at 04:09:44AM +0900, Hidekazu Kuroki wrote:
> > >    4.2.0-libGLU-bad-extern.patch
> > This doesn't apply to us, we don't use "newer versions" of GCC.
> OK.
> But if anyone use gcc30, gcc31 or gcc32 for building XFree86-4,
> doesn't a problem occur?

No, because they will use the system CC for it.

-- 
wca
Comment 4 Will Andrews freebsd_committer 2002-03-20 00:33:54 UTC
State Changed
From-To: open->closed

xlib i18n fix & libGLU compile fix committed.  zlib patch ignored because 
it doesn't affect FreeBSD.