Bug 36401 - devel/bonobo: can't make package because of missing file
Summary: devel/bonobo: can't make package because of missing file
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-gnome mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-03-28 02:10 UTC by Alan E
Modified: 2002-04-24 16:50 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alan E 2002-03-28 02:10:02 UTC
First the make install gets an ignorable error:

db2html ./audio_ulaw.sgml
TMPDIR is DBTOHTML_OUTPUT_DIR86650
Using stylesheet: "/usr/local/share/sgml/docbook/dsssl/cygnus/cygnus-both.dsl"

input file was called audio_ulaw.sgml -- output will be in audio_ulaw

working on ./audio_ulaw.sgml
jade:E: cannot open "./audio_ulaw.sgml" (No such file or directory)
about to copy cascading stylesheet and admon graphics to temp dir
cp: /usr/local/share/sgml/docbook/dsssl/modular/test/docbook.css: No such file or directory
about to rename temporary directory to audio_ulaw
cp audio_ulaw/index.html .
cp: audio_ulaw/index.html: No such file or directory
gmake[5]: [audio_ulaw.html] Error 1 (ignored)

Then the make package fails because the file that was supposed to be created 
wasn't.

Fix: Easy fix:

==8<====8<====8<====8<====8<====8<====8<====8<====8<====8<==
[alane ~/FreeBSD/ports]$ cvs diff devel/bonobo


Real fix: fix the underlying problem. However, since it looks, on surface
examination, to be a missing file in the source distribution, that may be
difficult.--RR4nyn5vKa9EFnkzih2Uqd2HlgIkwjPPo1X8bLloy3EWPE01
Content-Type: text/plain; name="file.diff"
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment; filename="file.diff"

Index: devel/bonobo/pkg-plist
===================================================================
RCS file: /home/alane/cvsup-ports/cvsroot/ports/devel/bonobo/pkg-plist,v
retrieving revision 1.29
diff -u -3 -r1.29 pkg-plist
--- devel/bonobo/pkg-plist      24 Jan 2002 07:39:39 -0000      1.29
+++ devel/bonobo/pkg-plist      28 Mar 2002 01:55:40 -0000
@@ -105,7 +105,6 @@
 lib/libefs.so
 lib/libefs.so.1
 libdata/pkgconfig/libefs.pc
-share/gnome/bonobo/docs/audio_ulaw/C/index.html
 share/gnome/bonobo/html/bonobo-api.html
 share/gnome/bonobo/html/bonobo-api.sgml
 share/gnome/bonobo/html/bonobo-decl.txt
==8<====8<====8<====8<====8<====8<====8<====8<====8<====8<==
Comment 1 Patrick Li freebsd_committer 2002-03-28 03:57:50 UTC
Responsible Changed
From-To: freebsd-ports->gnome

Over to maintainers
Comment 2 Joe Marcus Clarke freebsd_committer 2002-04-07 01:52:45 UTC
State Changed
From-To: open->closed
Comment 3 Joe Marcus Clarke freebsd_committer 2002-04-07 02:05:20 UTC
State Changed
From-To: closed->open

Whoops.  I meant to add a follow-up. 

Is this problem still reproduceable with bonobo-1.0.19?  I am unable to 
reproduce it on my -stable machines.
Comment 4 Joe Marcus Clarke freebsd_committer 2002-04-24 16:50:20 UTC
State Changed
From-To: open->closed

This is fixed with the recent --disable-gtk-doc commit.