Bug 41206 - kdebase3 fails to compile with qt-3.0.5
Summary: kdebase3 fails to compile with qt-3.0.5
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-kde (Team)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-07-31 18:20 UTC by Vivek Khera
Modified: 2002-08-04 11:28 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vivek Khera 2002-07-31 18:20:01 UTC
	

kdebase3 compile dies when building kpersonalizer:

Making all in pics
source='keyecandypagedlg.cpp' object='keyecandypagedlg.o' libtool=no  depfile='.deps/keyecandypagedlg.Po' tmpdepfile='.deps/keyecandypagedlg.TPo'  depmode=gcc /bin/sh ../admin/depcomp  c++ -DHAVE_CONFIG_H -I. -I. -I.. -I/usr/local/include -I/usr/X11R6/include   -pthread -DQT_THREAD_SUPPORT  -I/usr/local/include -I/usr/local/include  -I/usr/X11R6/include -D_THREAD_SAFE  -DNDEBUG -DNO_DEBUG -O2 -O -pipe -ffast-math -mfancy-math-387 -fno-exceptions -fno-check-new -DQT_CLEAN_NAMESPACE -DQT_NO_COMPAT -DQT_NO_ASCII_CAST  -c -o keyecandypagedlg.o `test -f keyecandypagedlg.cpp || echo './'`keyecandypagedlg.cpp
keyecandypagedlg.cpp: In method `KEyeCandyPageDlg::KEyeCandyPageDlg(QWidget * = 0, const char * = 0, unsigned int = 0)':
keyecandypagedlg.cpp:96: invalid use of undefined type `class KListView'
keyecandypagedlg.h:17: forward declaration of `class KListView'
keyecandypagedlg.cpp:97: invalid use of undefined type `class KListView'
keyecandypagedlg.h:17: forward declaration of `class KListView'
keyecandypagedlg.cpp:98: invalid use of undefined type `class KListView'
keyecandypagedlg.h:17: forward declaration of `class KListView'
keyecandypagedlg.cpp:100: no matching function for call to `QGridLayout::addWidget (KListView *&, int, int)'
/usr/X11R6/include/qlayout.h:323: candidates are: void QGridLayout::addWidget(QWidget *, int, int, int = 0)
*** Error code 1

Stop in /u/onceler1/usr/ports/x11/kdebase3/work/kdebase-3.0.2/kpersonalizer.
*** Error code 1

Stop in
/u/onceler1/usr/ports/x11/kdebase3/work/kdebase-3.0.2/kpersonalizer.


It seems to be related to the update to qt-3.0.5.

my kdebase3 was updated on July 29 via portupgrade, but I forgot a
patch that fixes the problem in ports/40428.  yesterday, i updated qt
to 3.0.5 from the prior version in ports.  today I went to rebuild
kdebase3 and it fails with the error above.

Fix: 

unknown.
How-To-Repeat: 	

update qt to 3.0.5
cd /usr/ports/x11/kdebase3
make

all other ports are up-to-date.
Comment 1 Christian Weisgerber freebsd_committer 2002-07-31 23:23:30 UTC
Responsible Changed
From-To: freebsd-ports->kde

over to maintainer
Comment 2 Alan Eldridge freebsd_committer 2002-08-04 11:25:49 UTC
State Changed
From-To: open->closed

This turned out be to a (hopefully) transient problem, caused by the Trolls 
breaking binary compatibility between 3.0.4 and 3.0.5. It should not persist 
once 3.06 or later come out. 

No operational fix. Just put messages in the appropriate ports to warn the 
user of the consequences of not rebuilding kdelibs afterward.