Bug 43332 - [FIX/UPDATE]: x11-wm/bbkeys
Summary: [FIX/UPDATE]: x11-wm/bbkeys
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-09-24 14:40 UTC by stijn
Modified: 2002-10-05 20:24 UTC (History)
0 users

See Also:


Attachments
file.diff (673 bytes, patch)
2002-09-24 14:40 UTC, stijn
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description stijn 2002-09-24 14:40:01 UTC
- Update bbkeys to 0.8.5 to fix user problems with the new blackbox 0.65.0.

Although this is not a bento fix I would be very happy if this would make
it into 4.7-RELEASE because it affects the bbkeys user experience using
the latest blackbox.

Most notable bugs fixed:

  - when we recieve a startup message from blackbox, clear out any leftover
    windows in the window list. These are caused by the fact that on shutdown
    of blackbox, if any windows are unmanaged after bbkeys, bbkeys doesn't get
    notified of their destruction and so ends up with extra windows in its list.
    [xOr]

  - fix window focus tracking bug. Fixes bug where you could manipulate the
    last focused window on a nono-visible workspace.
    [xOr]

How-To-Repeat: 
N/A
Comment 1 Oliver Braun freebsd_committer 2002-10-05 20:24:04 UTC
State Changed
From-To: open->closed

Committed, thanks!