Bug 46284 - [Maintainer update] lang/gauche 0.6.5 -> 0.6.6
Summary: [Maintainer update] lang/gauche 0.6.5 -> 0.6.6
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Akinori MUSHA
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-12-16 03:40 UTC by erik
Modified: 2004-07-05 17:58 UTC (History)
0 users

See Also:


Attachments
gauche-0.6.6.patch (4.56 KB, patch)
2002-12-16 03:40 UTC, erik
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description erik 2002-12-16 03:40:01 UTC
Update from 0.6.5 to 0.6.6

Please remove files/patch-src-gauche-arith_i386.h

(thanks for holding it for me, knu)

the following is the freshmeat blurb

A number of bugs are fixed, including a gauche.net bug and do-form
compilation bug which were sometimes the cause of crashes. Several
new modules are added, including message digest libraries (rfc.md5,
rfc.sha1, rfc.hmac, and util.digest), thread-local parameter support,
and port seek. Other enhancements include string split to take
strings and a regexp as a splitter.

Fix: <how to correct or work around the problem, if known (multiple lines)>
How-To-Repeat: 	<code/input/activities to reproduce the problem (multiple lines)>
Comment 1 Norikatsu Shigemura freebsd_committer 2002-12-16 05:03:03 UTC
Responsible Changed
From-To: freebsd-ports->nork

I'll handle this.
Comment 2 Norikatsu Shigemura freebsd_committer 2002-12-16 08:46:46 UTC
Responsible Changed
From-To: nork->portmgr

portmgr@ (knu) hopes to handle this.
Comment 3 Akinori MUSHA freebsd_committer 2002-12-18 14:12:57 UTC
State Changed
From-To: open->closed

Committed, thanks. 

By the way, even the latest version has a build problem on the alpha 
platform. (I've confirmed that on an alpha box)  Seems gosh coredumps 
within libgc.  Would you report the issue to the author and help him 
investigate the issue?  I can also give some help.  FYI, Compaq/HP 
TestDrive and SourceForge are offering FreeBSD/alpha accounts for free.
Comment 4 Akinori MUSHA freebsd_committer 2002-12-18 14:12:57 UTC
Responsible Changed
From-To: portmgr->knu

I'm interested in gauche.