Bug 52087 - error while building japanese/openoffice
Summary: error while building japanese/openoffice
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-openoffice (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-05-12 02:50 UTC by TsurutaniNaoki
Modified: 2005-06-19 05:02 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description TsurutaniNaoki 2003-05-12 02:50:03 UTC
	In making japanese/openoffice(ja-openoffice-1.0.3_2), an error arises with message : "/usr/ports/japanese/openoffice/work/oo_1.0.3_src/solenv/unxfbsd/bin/makedepend: No such file or directory."
	I guess this is caused through the error of redirection in the next part:
	> if ( !( -x $SOLARENV/$OUTPATH/bin/makedepend ) ) then
	> 	echo "exit 0" >> $SOLARENV/$OUTPATH/bin/makedepend
	> 	chmod +x $SOLARENV/$OUTPATH/bin/makedepend
	> endif
	in /usr/ports/japanese/openoffice/work/oo_1.0.2_src/bootstrap.
	Shell variable of "noclobber" in C-shell will cause this error when appending to non-existing file.

Fix: 

One of the followings:
	1. Do not use "csh script".
	2. Add "unset noclobber" before the code above.
	3. Replace ">>" with ">>!" in the code above.
	In the latter 2 cases, I cannot to specify the source(or patch)-code
	to fix.
How-To-Repeat: 	Always, since OOo 1.02_1.
Comment 1 Pete Fritchman freebsd_committer 2003-05-12 03:36:16 UTC
Responsible Changed
From-To: freebsd-ports-bugs->openoffice

Over to maintainers.
Comment 2 Martin Blapp freebsd_committer 2003-05-13 19:00:25 UTC
State Changed
From-To: open->analyzed

I don't see these problems here. Can you check your make.conf 
and see if there are any special settings in it ? 

It must be definitly caused by your setup.
Comment 3 TsurutaniNaoki 2003-05-14 02:09:43 UTC
Here is my /etc/make.conf:

CPUTYPE=i686
CFLAGS= -O -pipe
COMPAT20=       yes
COMPAT21=       yes
COMPAT22=       yes
COMPAT3X=       yes
COMPAT4X=       yes
XFREE86_VERSION=        4
HAVE_MOTIF=     yes
IPFW2=true

/root/.cshrc (and also my .cshrc) contain next line:
set noclobber

I guess this does cause error, but this is not so rare setting, 
and I think scripts for building programs should not be effected 
by user settings and configuration files. Is it wrong?
Comment 4 TsurutaniNaoki 2003-05-15 05:36:10 UTC
Martin Blapp <mb@imp.ch> wrote:

> Please remove all options and see it it works then !

I tried:
1. making /etc/make.conf empty  ->  same error arised.
2. remove "set noclobber" from /root/.cshrc  ->  no error.

Therefore I know what is wrong.
But I wonder why I must change my configuration file only for building
openoffice.
Comment 5 Maho Nakata freebsd_committer 2005-06-19 05:00:25 UTC
State Changed
From-To: analyzed->closed

Now it has been fixed. 
Thank you very much for your report.