Bug 54092 - LCDd daemon from sysutils/lcdproc starts in the foreground
Summary: LCDd daemon from sysutils/lcdproc starts in the foreground
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-07-04 14:00 UTC by Christian Ullrich
Modified: 2003-09-30 00:41 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Ullrich 2003-07-04 14:00:34 UTC
	The LCDd.sh.sample start script from the LCDproc-0.4.3_2 ports
	starts the LCDd process that's also part of the port in the
	foreground, thereby blocking the system startup.

	This may be a driver issue. It happens with both the
	"curses" driver, where it could be intentional (output to
	the controlling tty should probably continue uninterrupted),
	and the "lcdm001" driver, which could be a bug in the driver.
	I don't have any other output devices to test with.

Fix: 

Add a '&' character at the end of the fifth line of
	/usr/local/etc/rc.d/LCDd.sh.sample .
	If this is indeed an issue with the "lcdm001" driver,
	this change breaks the intended behaviour of the 
	"curses" driver.
How-To-Repeat: 	- install ports/sysutils/lcdproc-0.4.3_2
	- copy /usr/local/etc/LCDd.conf.sample to LCDd.conf
	- configure /usr/local/etc/LCDd.conf to your liking
	- copy /usr/local/etc/rc.d/LCDd.sh.sample to LCDd.sh
	- run /usr/local/etc/rc.d/LCDd.sh
	
	The script waits for termination of the LCDd process.
Comment 1 Edwin Groothuis freebsd_committer 2003-09-28 02:35:21 UTC
State Changed
From-To: feedback->closed

If this is still a problem with the latest (3.23.58) one, please 
resubmit the problem. Most likely it was caused by the not running 
of ldconfig by the port. If it still occures, please add the output 
of "ldconfig -r" to the PR.
Comment 2 Edwin Groothuis freebsd_committer 2003-09-28 02:35:21 UTC
State Changed
From-To: open->open

euhmm.. I'll redit this PR.
Comment 3 Edwin Groothuis freebsd_committer 2003-09-28 02:35:21 UTC
State Changed
From-To: open->open
Comment 4 Edwin Groothuis freebsd_committer 2003-09-28 02:35:21 UTC
State Changed
From-To: open->open
Comment 5 Edwin Groothuis freebsd_committer 2003-09-28 02:35:21 UTC
State Changed
From-To: open->open

Fix synopses.
Comment 6 Edwin Groothuis freebsd_committer 2003-09-28 02:35:21 UTC
State Changed
From-To: open->open

Fix synopses
Comment 7 Edwin Groothuis freebsd_committer 2003-09-28 02:35:21 UTC
State Changed
From-To: open->open

Fix synopses
Comment 8 Edwin Groothuis freebsd_committer 2003-09-28 02:35:21 UTC
State Changed
From-To: open->open

Fix synopses
Comment 9 Edwin Groothuis freebsd_committer 2003-09-28 02:35:21 UTC
State Changed
From-To: open->open

Fix synopses
Comment 10 Edwin Groothuis freebsd_committer 2003-09-28 02:35:21 UTC
State Changed
From-To: open->open

Fix synopses
Comment 11 Edwin Groothuis freebsd_committer 2003-09-28 02:35:21 UTC
State Changed
From-To: open->open

Fix synopses
Comment 12 Edwin Groothuis freebsd_committer 2003-09-28 02:35:21 UTC
State Changed
From-To: open->open

Fix synopses
Comment 13 Edwin Groothuis freebsd_committer 2003-09-28 02:35:21 UTC
State Changed
From-To: open->open

Fix category
Comment 14 Edwin Groothuis freebsd_committer 2003-09-28 02:35:21 UTC
State Changed
From-To: open->open

Fix synopsesFix synopsesFix synopses
Comment 15 Edwin Groothuis freebsd_committer 2003-09-28 02:35:21 UTC
State Changed
From-To: open->open

Fix synopses
Comment 16 Edwin Groothuis freebsd_committer 2003-09-28 02:35:21 UTC
State Changed
From-To: open->open

Fix synopses
Comment 17 Edwin Groothuis freebsd_committer 2003-09-28 02:35:21 UTC
State Changed
From-To: open->open

Fix synopses
Comment 18 Edwin Groothuis freebsd_committer 2003-09-28 02:35:21 UTC
State Changed
From-To: open->open

Fix synopses
Comment 19 Edwin Groothuis freebsd_committer 2003-09-28 02:35:21 UTC
State Changed
From-To: analyzed->analyzed

Fix synopses
Comment 20 Edwin Groothuis freebsd_committer 2003-09-28 02:35:21 UTC
State Changed
From-To: open->open

Fix synopses
Comment 21 Edwin Groothuis freebsd_committer 2003-09-28 02:35:21 UTC
State Changed
From-To: open->open

Fix synopses
Comment 22 Edwin Groothuis freebsd_committer 2003-09-28 02:35:21 UTC
State Changed
From-To: open->open

Fix synopses
Comment 23 Edwin Groothuis freebsd_committer 2003-09-28 02:35:21 UTC
State Changed
From-To: open->open

FIx category
Comment 24 Edwin Groothuis freebsd_committer 2003-09-28 02:35:21 UTC
State Changed
From-To: open->open

Fix synopses
Comment 25 Edwin Groothuis freebsd_committer 2003-09-28 02:35:21 UTC
State Changed
From-To: open->open

Fix synopses
Comment 26 Edwin Groothuis freebsd_committer 2003-09-30 00:41:17 UTC
State Changed
From-To: open->closed

Commited, thanks!