Bug 58444 - Install of editors/xemacs-devel fails
Install of editors/xemacs-devel fails
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: gj
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-23 17:10 UTC by zaks
Modified: 2003-10-26 13:12 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zaks 2003-10-23 17:10:20 UTC
    Port install target fails due to -d option requirement of install(1) for
    creating directories

    Build log tail:
    Copying include files for ellcc...
    install   -o root -g wheel -m 555  /usr/local/lib/xemacs-21.5-b15/i386--freebsd/modules
    line 179
    usage: install [-bCcpSsv] [-B suffix] [-f flags] [-g group] [-m mode]
                   [-o owner] file1 file2
           install [-bCcpSsv] [-B suffix] [-f flags] [-g group] [-m mode]
                   [-o owner] file1 ... fileN directory
           install -d [-v] [-g group] [-m mode] [-o owner] directory ...
    *** Error code 64

    Stop in /usr/ports/work/xemacs-21.5.15/xemacs-21.5.15/modules/postgresql.
    *** Error code 1

Fix: 

Notify the vendor?
How-To-Repeat: 	make install in editors/xemacs-devel
Comment 1 krion freebsd_committer 2003-10-23 17:31:56 UTC
Responsible Changed
From-To: freebsd-ports-bugs->gj

Over to maintainer
Comment 2 gj freebsd_committer 2003-10-26 13:10:23 UTC
State Changed
From-To: open->closed

The problem was caused by having postgresql installed which resulted in 
trying to install the experimental postgresql module, which broke the install. 
Support for postgresql is no longer allowed in the Makefile.