Bug 6 - System hangs while using slip or ppp connection
System hangs while using slip or ppp connection
Status: Closed FIXED
Product: Base System
Classification: Unclassified
Component: kern
unspecified
Any Any
: Normal Affects Only Me
Assigned To: FreeBSD core team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 1994-10-07 03:30 UTC by root
Modified: 2006-01-16 09:40 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description root 1994-10-07 03:30:05 UTC
The system will hang while connected to my internet service provider. By
hang, I mean I can switch between consoles using alt-F?, but cannot use
any of them. All outgoing netowrk activity indicated by the modem leds
appears to  cease. The hang may occur when the remote site opens a new
smtp connection, but that may be a coincidence.  The hang can occur
anytime after making the dialup connection. It doesn't always happen.

If I use ALT-F9 to switch to console 9, when only 8 have been compiled in,
instead of the normal short beep the speaker will beep continuosly.

I  thought at first that it was something to do with PPP, so I switched
to using slip.  No joy.

No diagnostics or core-dumps are produced.  The only thing I can do
is to reboot and fsck the disks. 

PPP has worked 100% using 1.1.5.1 for many months.

Fix: 

None known at this time.
How-To-Repeat: 
I don't know of any way to provoke the bug.
Comment 1 davidg freebsd_committer 1995-11-11 18:16:58 UTC
State Changed
From-To: open->closed

There were a variety of causes of system hangs and panics in this 
area caused by improper allocation/reservation of cblocks. This has 
been fixed during the past few months and should no longer occur. 

Comment 2 james 2006-01-16 09:37:15 UTC
>Submitter-Id:	current-users
>Originator:	James Seward
>Organization:	
>Confidential:	no
>Synopsis:	amd64/6-STABLE can't see disks at boot
>Severity:	serious
>Priority:	low
>Category:	amd64
>Class:		sw-bug
>Release:	6-STABLE
>Environment:	Output from a kernel that boots; all kernels after this have had the problem:
FreeBSD tomo.jamesoff.net 6.0-STABLE FreeBSD 6.0-STABLE #6: Sun Nov  6 13:10:48                                                       GMT 2005     root@tomo.jamesoff.net:/usr/obj/usr/src/sys/TOMO64  amd64
>Description:
Since approx Nov 6, 6-STABLE kernels are unable to see my ATA disks on my amd64 machine. Until that point, I have had no problems with that machine or 6-RELEASE/6-STABLE. The boot fails when it tries to mount the root partition but apparently can't see any ATA disks. I have both SATA and PATA disks on the machine and it can't see any of them. The IDE LED on the case goes on solidly and sticks at this point in the boot.

This problem occurs with both my custom config (as used in the working kernel) and with GENERIC. I have cvsup'd an entire clean src tree as well as nuked /usr/obj. My most recent test was a cvsup on the evening of Jan 15th 2006, and that failed too.

dmesg output from a successful boot:
http://sakaki.jamesoff.net/~james/dmesg-working.txt

dmesg -v output from an unsuccessful boot:
http://sakaki.jamesoff.net/~james/dmesg-broken.txt

>How-To-Repeat:
Boot a kernel > 6 Nov 2005
>Fix:
No fix; workaround is to boot a kernel from <= Nov 6 2005.