Bug 66011 - mail/courier-imap needs to depend on libfam
mail/courier-imap needs to depend on libfam
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Any Any
: Normal Affects Only Me
Assigned To: Oliver Lehmann
Depends on:
  Show dependency treegraph
Reported: 2004-04-27 04:50 UTC by Jim Trigg
Modified: 2004-04-28 19:07 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Jim Trigg 2004-04-27 04:50:15 UTC
If courier-imap is installed while devel/fam is installed, it will build
dependent on libfam.so whether WITH_FAM is set or not, but will only be
marked as dependent on libfam.so if WITH_FAM is set.


Change mail/courier-imap/Makefile to add libfam to LIB_DEPENDS if libfam
is installed or write patch to honor WITH_FAM in actual build.
How-To-Repeat: Install devel/fam, install mail/courier-imap with WITH_FAM unset, and
deinstall devel/fam.  Courier-imap will stop working.
Comment 1 Mark Linimon freebsd_committer 2004-04-27 16:42:30 UTC
Responsible Changed
From-To: freebsd-ports-bugs->oliver

Over to maintainer.
Comment 2 Oliver Lehmann freebsd_committer 2004-04-27 21:51:42 UTC
State Changed
From-To: open->analyzed

Awaiting Ports-Tree to unfreeze
Comment 3 Oliver Lehmann freebsd_committer 2004-04-28 19:07:32 UTC
State Changed
From-To: analyzed->closed

Fixed, Thanks!