Bug 66547 - [ucom] Palm Tungsten T USB does not initialize correctly
Summary: [ucom] Palm Tungsten T USB does not initialize correctly
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: usb (show other bugs)
Version: 4.10-PRERELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-usb mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-05-11 20:50 UTC by espen
Modified: 2017-12-31 22:36 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description espen 2004-05-11 20:50:13 UTC
Palm Tungsten T USB fails to initialize with the uvisor/ucom driver.
Kernel is configured with device uvisor and device ucom. When pressing
the hotsync-button on the cradle, connected to one of the USB-ports, the
following is written out on the console:

ucom0: Palm, Inc. Palm Handheld, rev 1.10/1.00, addr 3
ucom0: Palm, Inc. Palm Handheld, rev 1.10/1.00, addr 3

(Yes, to identical lines.)

Then, after about 2-3 seconds, this error message follows:

ucom0: init failed, TIMEOUT
device_probe_and_attach: ucom0 attach returned 6
uhub0: port 2, set config at addr 3 failed
uhub0: device problem, disabling port 2

I guess the device should be connected to ucom0, or ugen0. I can't find
any good documentation on how to do this but I suppose that device should
come up as ucom0, which then could be used from pilot-link, or some of
the other sync utilities.

Fix: 

Have no idea.
How-To-Repeat: Press the hotsync button.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2004-11-04 07:28:49 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-usb

Reassign to appropriate mailing list.
Comment 2 iedowse freebsd_committer 2005-03-25 00:18:03 UTC
State Changed
From-To: open->feedback


Does this problem still occur in FreeBSD 4.11 or 5.x?
Comment 3 Stefan 'Steve' Tell 2005-04-07 18:05:35 UTC
> Does this problem still occur in FreeBSD 4.11 or 5.x?

Same problem here with FreeBSD 5.4-BETA1.

,----
| Apr  7 18:40:25 pandora kernel: ucom0: Palm, Inc. Palm-Handheld, rev 1.10/1.00, addr 3
| Apr  7 18:40:25 pandora kernel: ucom0: Palm, Inc. Palm-Handheld, rev 1.10/1.00, addr 3
| Apr  7 18:40:30 pandora kernel: ucom0: init failed, TIMEOUT
| Apr  7 18:40:30 pandora kernel: device_attach: ucom0 attach returned 6
| Apr  7 18:40:30 pandora kernel: uhub1: port 1, set config at addr 3 failed
| Apr  7 18:40:30 pandora kernel: uhub1: device problem (STALLED), disabling port 1
`----

-- 
By(t)e,
        Steve           /\          http://www.crashmail.de

GnuPG/PGP: 0X9B6C7E15, encrypted mail prefered, see header
Comment 4 Mark Linimon freebsd_committer freebsd_triage 2005-12-04 02:47:26 UTC
State Changed
From-To: feedback->open

Feedback was received some time ago.
Comment 5 Rasmus Kaj 2006-07-25 18:18:52 UTC
Regarding http://www.freebsd.org/cgi/query-pr.cgi?pr=66547 :

For what it's worth, I got the same problem here, running FreeBSD
5.5-RELEASE (GENERIC kernel, i386, kernel modules loaded: kernel,
snd_ich.ko, sound.ko, acpi.ko, radeon.ko, nnpfs.ko, uvisor.ko, ucom.ko).


-- 
Rasmus Kaj <rasmus@kaj.se> -- http://www.stacken.kth.se/~kaj/
Comment 6 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 07:59:13 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped