Bug 74009 - sysutils/tree: make install fails for version 1.5.0
Summary: sysutils/tree: make install fails for version 1.5.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Tom Hukins
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-11-16 18:10 UTC by Linh Pham
Modified: 2004-11-17 09:40 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Linh Pham 2004-11-16 18:10:25 UTC
When trying to install sysutils/tree, the port installation process fails
with the following error:

===>  Installing for tree-1.5.0
===>   Generating temporary packing list
===>  Checking if sysutils/tree already installed
/usr/local/bin
/usr/local/bin:Permission denied
*** Error code 1

Stop in /usr/ports/sysutils/tree/work/tree-1.5.0.
*** Error code 1

Stop in /usr/ports/sysutils/tree.

The problem is reproduceable on a 4.10 and 5.2.1

Fix: 

I compared the install portion of the extracted (and patched?) Makefile
from the distfile and noted a difference in the two versions:

From version 1.3.0:
install: $(TREE_DEST) $(MAN)
        mkdir -p $(BINDIR)
        mkdir -p $(MANDIR)
        ${BSD_INSTALL_PROGRAM} $(TREE_DEST) $(BINDIR)
        ${BSD_INSTALL_MAN} $(MAN) $(MANDIR)

From version 1.5.0:
install: $(TREE_DEST) $(MAN)
        $(MKDIR) $(BINDIR)
        $(MKDIR) $(MANDIR)
        ${BSD_INSTALL_PROGRAM} $(TREE_DEST) $(BINDIR)
        ${BSD_INSTALL_MAN} $(MAN) $(MANDIR)

Replacing the two $(MKDIR) with the respective "mkdir -p" lines from the
previous version results in a different error when trying to run a
"make install":

===>  Installing for tree-1.5.0
===>   Generating temporary packing list
===>  Checking if sysutils/tree already installed
"Makefile", line 51: Need an operator
make: fatal errors encountered -- cannot continue
*** Error code 1

Stop in /usr/ports/sysutils/tree.
How-To-Repeat: fetch latest version of sysutils/tree
run: cd sysutils/tree ; make install
Comment 1 Volker Stolz freebsd_committer 2004-11-17 08:53:29 UTC
Responsible Changed
From-To: freebsd-ports-bugs->tom

Tom did the update. Setting the following would be a fix: 
MAKE_ENV=MKDIR="/bin/mkdir -p"
Comment 2 Tom Hukins freebsd_committer 2004-11-17 09:40:14 UTC
State Changed
From-To: open->closed

Fixed in revision 1.10 of ports/sysutils/tree/Makefile. 

Thanks for your report.