Bug 77010 - [patch] conflict between p5-XML-SAX and p5-XML-SAX-Base
Summary: [patch] conflict between p5-XML-SAX and p5-XML-SAX-Base
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: skv
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-02-02 15:30 UTC by Angelo Turetta
Modified: 2005-09-30 14:03 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Angelo Turetta 2005-02-02 15:30:14 UTC
	textproc/p5-XML-SAX-Base installs files with names conflicting with those
	installed by textproc/p5-XML-SAX.
	As a side effect, if you have textproc/p5-XML-SAX installed and you
	install net/p5-perl-ldap (which depends on p5-XML-SAX-Base by checking a file
	which is in conflict) you break your dependency database.

Fix: 

--j12FCTx3057752.1107357149/dev.lan.bestunion.it----EnvrZ1PSsjd0bqEb4gtZynK2h9kJBk6FAN5wOrmLx51ZL2i6
Content-Type: text/plain; name="patch-xml-sax-conflicts"
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment; filename="patch-xml-sax-conflicts"

Index: textproc/p5-XML-SAX/Makefile
===================================================================
RCS file: /home/ncvs/ports/textproc/p5-XML-SAX/Makefile,v
retrieving revision 1.7
diff -u -r1.7 Makefile
--- textproc/p5-XML-SAX/Makefile	12 Aug 2004 12:48:00 -0000	1.7
+++ textproc/p5-XML-SAX/Makefile	2 Feb 2005 14:46:26 -0000
@@ -15,6 +15,8 @@
 MAINTAINER=	skv@FreeBSD.org
 COMMENT=	Simple API for XML
 
+CONFLICTS=	${PKGNAMEPREFIX}${PORTNAME}-Base-*
+
 RUN_DEPENDS=	${SITE_PERL}/XML/NamespaceSupport.pm:${PORTSDIR}/textproc/p5-XML-NamespaceSupport
 BUILD_DEPENDS=	${RUN_DEPENDS}
 
Index: textproc/p5-XML-SAX-Base/Makefile
===================================================================
RCS file: /home/ncvs/ports/textproc/p5-XML-SAX-Base/Makefile,v
retrieving revision 1.4
diff -u -r1.4 Makefile
--- textproc/p5-XML-SAX-Base/Makefile	20 Jan 2005 14:28:05 -0000	1.4
+++ textproc/p5-XML-SAX-Base/Makefile	2 Feb 2005 14:51:20 -0000
@@ -17,6 +17,8 @@
 MAINTAINER=	svenasse@polaris.ca
 COMMENT=	Base class SAX Drivers and Filters
 
+CONFLICTS=	${PKGNAMEPREFIX}XML-SAX-[0-9]*
+
 PERL_CONFIGURE=	yes
 
 MAN3=		XML::SAX::Exception.3 \
Index: net/p5-perl-ldap/Makefile
===================================================================
RCS file: /home/ncvs/ports/net/p5-perl-ldap/Makefile,v
retrieving revision 1.11
diff -u -r1.11 Makefile
--- net/p5-perl-ldap/Makefile	30 Jul 2004 15:08:25 -0000	1.11
+++ net/p5-perl-ldap/Makefile	2 Feb 2005 14:34:10 -0000
@@ -21,8 +21,7 @@
 BUILD_DEPENDS=	${SITE_PERL}/Convert/ASN1.pm:${PORTSDIR}/converters/p5-Convert-ASN1 \
 		${SITE_PERL}/URI/ldap.pm:${PORTSDIR}/net/p5-URI \
 		${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL \
-		${SITE_PERL}/Authen/SASL.pm:${PORTSDIR}/security/p5-Authen-SASL \
-		${SITE_PERL}/XML/SAX/Base.pm:${PORTSDIR}/textproc/p5-XML-SAX-Base
+		${SITE_PERL}/Authen/SASL.pm:${PORTSDIR}/security/p5-Authen-SASL
 RUN_DEPENDS=	${BUILD_DEPENDS}
 
 PERL_CONFIGURE=	yes
@@ -68,5 +67,10 @@
 .if ${PERL_LEVEL} < 500800
 BUILD_DEPENDS+=	${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
 .endif
+.if !exists(${SITE_PERL}/${PERL_ARCH}/auto/XML/SAX/.packlist)
+BUILD_DEPENDS+=	${SITE_PERL}/XML/SAX/Base.pm:${PORTSDIR}/textproc/p5-XML-SAX-Base
+.else
+BUILD_DEPENDS+=	${SITE_PERL}/XML/SAX/Base.pm:${PORTSDIR}/textproc/p5-XML-SAX
+.endif
 
 .include <bsd.port.post.mk>
How-To-Repeat: 	portupgrade -N p5-XML-SAX
	portupgrade -N p5-perl-ldap
	portversion -v
Comment 1 Volker Stolz freebsd_committer 2005-02-14 17:29:35 UTC
Responsible Changed
From-To: freebsd-ports-bugs->skv

Over to one of the maintainers
Comment 2 skv freebsd_committer 2005-02-14 17:46:44 UTC
XML-SAX-Base is useless by design because it is subset of XML-SAX.

I suppose the better way is to replace dependencies on XML-SAX-Base with 
XML-SAX and remove XML-SAX-Base at all.

-- 
Sergey Skvortsov
mailto: skv@FreeBSD.org
Comment 3 skv freebsd_committer 2005-09-30 14:03:34 UTC
State Changed
From-To: open->closed

Mark p5-XML-SAX-Base as depreciated.