Bug 78527 - wrong x11-toolkits/Xaw3D version
wrong x11-toolkits/Xaw3D version
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Any Any
: Normal Affects Only Me
Assigned To: freebsd-x11
Depends on:
  Show dependency treegraph
Reported: 2005-03-07 12:30 UTC by rea
Modified: 2005-06-14 06:45 UTC (History)
1 user (show)

See Also:

Xaw3d.diff (1.50 KB, patch)
2005-03-08 13:22 UTC, michaelnottebrock
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description rea 2005-03-07 12:30:02 UTC
  Wrong Xaw3D version in ports when using xorg distribution.

How-To-Repeat: 	Compile Xaw3D, this will produce /usr/X11R6/lib/libXqw3d.so.7. But for system
 with xorg XAWVER will be 8 (for example, try installing print/gv port). So
 any builds that depend on Xaw3D will be broken.
Comment 1 vs freebsd_committer 2005-03-08 11:34:54 UTC
State Changed
From-To: open->feedback

Maybe you have a pre-xorg Xaw-installation on your system or something? 
The ports-infrastructure seems to DTRT: 
Xaw3d@menelaos [12:34:27]> X_WINDOW_SYSTEM=xorg make -V XAWVER 
Could you please send the complete transcript of the build e.g. 
in print/gv? 

Comment 2 vs freebsd_committer 2005-03-08 11:34:54 UTC
Responsible Changed
From-To: freebsd-ports-bugs->freebsd-x11

Over to x11-ulators
Comment 3 michaelnottebrock 2005-03-08 13:22:08 UTC
The xaw3d port is pretty broken atm.

I made a patch some time ago and had it tested successfully by some people on 
ports@, but never got around to committing. Please review.
Comment 4 dejan.lesjak 2005-03-09 00:02:12 UTC
The trouble is that Xaw3d will install library with the highest version of Xaw 
library. The current xorg-libraries port will install libXaw.so.6, 
libXaw.so.7 and libXaw.so.8. Xaw3d will therefore install libXaw3d.so.8. It 
should not install libXaw3d.so.7 on a system with up to date imake and 
The current XFree86-4-libraries port on the other hand will install 
libXaw.so.6 and libXaw.so.7. In that case Xaw3d will install libXaw3d.so.7.
I agree that detecting this is somewhat fragile and should be fixed. I'll try 
to come up with something, but for now Xaw3d port works as it should, given 
up-to-date ports tree and up-to-date versions of ports installed.
Because of the above, proposed patch would break 'make package' on up-to-date 
RELENG_5 system:

===>   Registering installation for Xaw3d-1.5_1
===>  Building package for Xaw3d-1.5_1
tar: lib/libXaw3d.so.7: Could not stat: No such file or directory
pkg_create: make_dist: tar command failed with code 256
Creating package /tmp/packages/All/Xaw3d-1.5_1.tbz
Registering depends: xorg-libraries-6.8.2 fontconfig-2.2.3,1 freetype2-2.1.7_4 
pkgconfig-0.15.0_1 expat-1.95.8.
Creating bzip'd tar ball in '/tmp/packages/All/Xaw3d-1.5_1.tbz'
*** Error code 1

Stop in /a/ports/x11-toolkits/Xaw3d.
Comment 5 anholt freebsd_committer 2005-06-13 08:22:08 UTC
State Changed
From-To: feedback->analyzed

This PR hasn't really been in "feedback" state for a while.  I'm still not 
clear on what needs to be done, but it sounds like lesi's got a handle on it. 
(This so version handling sounds exceptionally shady to me, though).
Comment 6 anholt freebsd_committer 2005-06-14 06:43:46 UTC
State Changed
From-To: analyzed->closed

Submitter reports that the problem was due to mismatched imake in 
his installation.  We have traditionally not hacked in version 
checks to avoid these problems (and needing to update imake for 
XFree86->X.Org is documented in UPDATING), unless the problem is 
very serious.  So, close this PR at this point.