Bug 80081 - [if_ndis] Problem loading a NDIS kernel module.
Summary: [if_ndis] Problem loading a NDIS kernel module.
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: i386 (show other bugs)
Version: 5.4-STABLE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-i386 (Nobody)
Depends on:
Reported: 2005-04-18 22:50 UTC by Julien Gabel
Modified: 2007-07-08 07:28 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Julien Gabel 2005-04-18 22:50:29 UTC
Trying to get wireless networking on my notebook, i tried the NDISulator.

After copying the configuration and binary files to the corresponding
path at /usr/src/sys/modules/if_ndis, i created the driver definition
header using ndiscvt(8).  Then, i have build and install the driver module
without problem: if_ndis.ko is copied to /boot/kernel and kldxref -v seems
happy (kldxref: /boot/kernel/if_ndis.ko: 488 REL entries).

But, if i can load the NDIS driver wrapper correctly (using kldload ndis),
loading the network interface seems more problematic:
 # kldload if_ndis
 kldload: can't load if_ndis: No such file or directory

Here is the kernel message:
 # tail -1 /var/log/messages
 Apr 16 15:05:46 boboche kernel: link_elf: symbol windrv_load undefined

I tried this with the two available Windows versions for this wireless
network module: win98/2k and winxp... without much success.


Not known to me.
Just try to load the corresponding NDIS wrapper and provided module:
 # kldload ndis
 # kldload /path/to/if_ndis.ko
 kldload: can't load /path/to/if_ndis.ko: No such file or directory
 # tail -1 /var/log/messages
 Apr 18 23:28:14 hostname kernel: link_elf: symbol windrv_load undefined

Attached files (wlan.tar.gz):
 - if_ndis.ko;
 - WIndows 98/2K and Windows XP configuration and binary files.
Comment 1 Julien Gabel 2005-04-23 18:23:32 UTC
Hello Hanspeter,

> I've seen your PR 80081. I have a similar problem. Just I've only
> tried with WinXP.
> In your PR you mentioned attachment wlan.tar.gz. But in webinterface
> of the PR database none is visible.
> Maybe you need to uuencode it?

Yes, sorry.  I had use the '-a' option of send-pr(1) to automatically
uuencode binary file... without success it seems.

The previously named files can be found at the folowing url:

Comment 2 Julien Gabel 2005-11-06 13:02:25 UTC
As i am the originator of this PR, i think it may be closed now:

 - I didn't try to play with this device for a long time now (integrated
   WLAN support);
 - I bought an external WLAN PCCARD, supported out the box by FreeBSD;
 - I will not have this notebook for a long time, so i could not answer
   to reply(ies) on this PR in a near future (one or two months)... if

As a side note -- and for future reference to this one -- the updated
location for provided PR's data is:

Thank you,
Comment 3 Mark Linimon freebsd_committer freebsd_triage 2007-07-08 07:28:20 UTC
State Changed
From-To: open->closed

Closed at submitter's request.