Bug 82826 - Tcl 8.4.10 build is broken.
Tcl 8.4.10 build is broken.
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Any Any
: Normal Affects Only Me
Assigned To: pav
Depends on:
  Show dependency treegraph
Reported: 2005-06-30 16:20 UTC by kutulu
Modified: 2005-06-30 19:57 UTC (History)
0 users

See Also:

file.diff (435 bytes, patch)
2005-06-30 16:20 UTC, kutulu
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description kutulu 2005-06-30 16:20:17 UTC
There is a known problem building Tcl v8.4.10 with GCC 3.x.  The problem is apparently hidden by a bug in gcc4.0.  This problem is resolved in the CVS version of Tcl but the fix hasn't made it into a release version yet.

Fix: Add the following patch file to lang/tcl84/files:
Comment 1 pav freebsd_committer 2005-06-30 18:11:41 UTC
State Changed
From-To: open->feedback

I can build tcl 8.4.10 just fine with 

/usr/ports/lang/tcl84 # gcc --version 
gcc (GCC) 3.4.2 [FreeBSD] 20040728
Comment 2 pav freebsd_committer 2005-06-30 18:11:41 UTC
Responsible Changed
From-To: freebsd-ports-bugs->pav

Comment 3 kutulu 2005-06-30 19:47:47 UTC
The problem appears to be specific to the threaded Tcl.  That is, I have 
WITH_THREADS defined in /etc/make.conf.  When I build lang/tcl84 with 
this configuration, I receive this error:

tclUnixNotfy.c: In function `Tcl_FinalizeNotifier':
tclUnixNotfy.c:297: too few arguments to function `Tcl_JoinThread'

The thread from tcl-core which describes the problem can be found here:


A better patch (the one that is actually in Tcl's CVS) is:


Comment 4 pav freebsd_committer 2005-06-30 19:57:20 UTC
State Changed
From-To: feedback->closed

Patched in CVS, thank you!