Bug 92142 - [uhub] SET_ADDR_FAILED and SHORT_XFER errors from usb drivers on GA-7DX+
Summary: [uhub] SET_ADDR_FAILED and SHORT_XFER errors from usb drivers on GA-7DX+
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: usb (show other bugs)
Version: 6.0-STABLE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-usb mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-01-22 09:00 UTC by Christopher Armstrong
Modified: 2017-12-31 22:36 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Armstrong 2006-01-22 09:00:17 UTC
During booting, or when plugging in different USB devices after unplugging
them, I get the following errors:

uhub0: port 1, set config at addr 2 failed
uhub0: device problem (SHORT_XFER), disabling port 1
uhub0: device problem (SHORT_XFER), disabling port 2

The kernel output before this suggests that it has detected my usb hub
and plugged in devices correctly. Running usbdevs after bootup gives an
error message:

addr 0: (this shouldn't happen)

(or something like that). If I leave the computer for a small while
(1-2 min), I get error messages similar to the above, but with
SET_ADDR_FAILED in parenthesis. I can unplug devices and put them
somewhere else, but I get the SET_ADDR_FAILED error messages with
FreeBSD reporting that it has disabled the corresponding port, rendering
the device unusable or undetectable. This prevents me from using my USB
Ethernet modem (Motorola SB5100), which otherwise ends up with a device
node (/dev/net/cdce0). Disabling and enabling ACPI seems to make no
difference (same error messages).

I am using a Gigabyte GA-7DX+ motherboard, latest BIOS update. It has
a VIA 686B south-bridge chipset, and a AMD 761 chipset. I'm thinking that
the drivers are not giving enough time to the usb bus to send data back.
The hardware works correctly and without errors in Windows 2000, and
works with Linux kernel version 2.6.14, with the irqpoll option on
(without this, the Linux usb stack would crash, reporting an irq
conflict, which I think I solved by moving by SBLive5.1 card).

How-To-Repeat: Hardware:

Gigabyte GA-7DX+ motherboard (AMD 761 chipset, VIA 686B south-bridge)
AMD Athlon XP 2000+
2 usb ports with following layout:
  port 0: nothing
  port 1: generic usb hub with 4 ports
   port 1a: brother hl2040 printer
   port 1b: Motorola Surfboard SB5100 modem
   port 1c,1d: nothing

try bootup with devices plugged in.
Comment 1 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 08:00:02 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped