Bug 93066 - slib 3a2 upgrade breaks guile
slib 3a2 upgrade breaks guile
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: lawrance
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-08 22:20 UTC by mainland
Modified: 2006-06-08 17:03 UTC (History)
0 users

See Also:


Attachments
guile.patch (3.32 KB, patch)
2006-06-07 12:44 UTC, robbak
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mainland 2006-02-08 22:20:04 UTC
	The upgrade of slib to 3a2 causes problems with guile. In particular
	gnucash to fail with the message:

	ERROR: Unbound variable: with-load-pathname

	See: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=337359

How-To-Repeat: 	Upgrade slib and try to run gnucash.
Comment 1 Mark Linimon freebsd_committer 2006-02-13 09:29:43 UTC
Responsible Changed
From-To: freebsd-ports-bugs->gnome

Over to gnome since they maintain lang/guile, which is where the Debian 
bug report followup claims the underlying problem is.
Comment 2 mnag freebsd_committer 2006-02-20 15:22:58 UTC
State Changed
From-To: open->closed

Fixed in slib 3a3. Thanks.
Comment 3 mainland 2006-02-20 17:13:08 UTC
How was this determined to be fixed?

I upgraded to slib 3a3. With lang/slib-guile 3a1 installed gnucash still
failed with the same error. Of course slib-guile is now marked broken
since installing it with slib 3a3 gives the error

ERROR: Unbound variable: with-load-pathname

Maybe I'm missing something, but the 3a3 upgrade does not appear to have
fixed anything.
Comment 4 mnag freebsd_committer 2006-02-20 20:06:37 UTC
State Changed
From-To: closed->open

Keep open. Not fixed yet.
Comment 5 lawrance freebsd_committer 2006-04-02 11:46:52 UTC
Responsible Changed
From-To: gnome->lawrance

Take it.  I think this is a problem with the slib-guile port, not 
guile itself.  Testing a solution now.
Comment 6 robbak 2006-06-07 12:44:11 UTC
This is reported to be a fault in guile. The fix has been made in 
current versions of guile. Until the next update, we will have to patch 
ourselves.

This should be given further regression testing in other uses of guile. 
No problems reported from gnucash yet.

Fix: apply atached patch to guile and rebuild guile and slib-guile

This patch should be removed from the ports tree when guile is next updated.

Robert Backhaus
robbak@gmail.com
Comment 7 lawrance freebsd_committer 2006-06-08 17:03:37 UTC
State Changed
From-To: open->closed

Fix committed, thanks!