Bug 93312 - [PATCH] www/opera-devel: enable installation of 4.x static binaries on FreeBSD >= 5
[PATCH] www/opera-devel: enable installation of 4.x static binaries on FreeBS...
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: krion
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-13 22:00 UTC by avleeuwen
Modified: 2006-02-14 17:48 UTC (History)
1 user (show)

See Also:


Attachments
opera-devel.diff (1.64 KB, patch)
2006-02-13 22:00 UTC, avleeuwen
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description avleeuwen 2006-02-13 22:00:14 UTC

This patch gives the user the option to install a version of Opera
that either uses a shared Qt library or a statically linked one.

Because there are no static builds available for FreeBSD >= 5, 
choosing a static build on these systems installs the FreeBSD 4.x
binary and depends on compatxx ports.

Requested by: Kirill Ponomarew <krion at voodoo dot bawue dot com>
Comment 1 krion freebsd_committer 2006-02-14 17:42:38 UTC
State Changed
From-To: open->feedback

Seems fine, you need to move WITH_ASPELL after bsd.port.pre.mk though. 


Comment 2 krion freebsd_committer 2006-02-14 17:42:38 UTC
Responsible Changed
From-To: freebsd-ports-bugs->krion

Seems fine, you need to move WITH_ASPELL after bsd.port.pre.mk though.
Comment 3 krion freebsd_committer 2006-02-14 17:48:26 UTC
State Changed
From-To: feedback->closed

Committed. Thanks!