Bug 93941 - [maintainer] update science/mcstas to v1.9
Summary: [maintainer] update science/mcstas to v1.9
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-28 13:50 UTC by Joerg Pulz
Modified: 2006-04-09 13:43 UTC (History)
0 users

See Also:


Attachments
science_mcstas.diff (16.72 KB, patch)
2006-02-28 13:50 UTC, Joerg Pulz
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Joerg Pulz 2006-02-28 13:50:03 UTC
	Update science/mcstas to the most recent version.
	Makefile:
	  - chase new version
	  - use new official website as MASTER_SITES
	  - fix *_DEPENDS
	    - graphics/pgplot has to be installed before configure is running
	      so use BUILD_DEPENDS to achieve this
	    - math/PDL is required for various things
	      depend on it rather than on graphics/pgperl
	    - as math/PDL depends on graphics/pgperl and graphics/pgplot
	      don't list them as dependence here
	distinfo:
	  - chase new version and checksums
	pkg-descr:
	  - update WWW to the official website
	pkg-plist:
	  - updated with new files, removed old stuff
	files/patch-Makefile.in:
	  - regen for the slightly different Makefile in v1.9

	Attention:
	PR ports/93938 has to hit the tree first, as we depend on
	math/PDL now, and this is known to be broken in the build stage.
Comment 1 Pav Lucistnik freebsd_committer 2006-04-09 13:43:01 UTC
State Changed
From-To: open->closed

Committed with minor modifications.