Bug 96408 - bitlbee port fails install on missing files
Summary: bitlbee port fails install on missing files
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Sam Lawrance
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-27 11:30 UTC by Michael Stevens
Modified: 2006-05-11 10:57 UTC (History)
0 users

See Also:


Attachments
patch-bitlbee (1.36 KB, application/octet-stream; x-unix-mode=0644)
2006-04-27 12:51 UTC, Sam Lawrance
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Stevens 2006-04-27 11:30:25 UTC
		I'm trying to update bitlbee using portupgrade. The 1.0.2 port won't install with the following output:

--->  Upgrading 'bitlbee-1.0.1' to 'bitlbee-1.0.2' (irc/bitlbee)
--->  Building '/usr/ports/irc/bitlbee'
===>  Cleaning for gmake-3.80_2
===>  Cleaning for pkgconfig-0.20
===>  Cleaning for gnutls-1.2.10_1
===>  Cleaning for glib-2.8.6_1
===>  Cleaning for texinfo-4.8_3
===>  Cleaning for libgcrypt-1.2.2
===>  Cleaning for libgpg-error-1.1
===>  Cleaning for libiconv-1.9.2_2
===>  Cleaning for gettext-0.14.5_2
===>  Cleaning for perl-5.8.8
===>  Cleaning for libtool-1.5.22_2
===>  Cleaning for bitlbee-1.0.2
===>  Vulnerability check disabled, database not found
===>  Found saved configuration for bitlbee-1.0.1
=> bitlbee-1.0.2-msn6.akke.diff doesn't seem to exist in /usr/ports/distfiles/.
=> Attempting to fetch from http://get.bitlbee.org/patches/.
fetch: http://get.bitlbee.org/patches/bitlbee-1.0.2-msn6.akke.diff: Not Found
=> Attempting to fetch from ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/.
fetch: ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/bitlbee-1.0.2-msn6.akke.diff: File unavailable (e.g., file not found, no access)
=> Couldn't fetch it - please try to retrieve this
=> port manually into /usr/ports/distfiles/ and try again.
*** Error code 1

Stop in /usr/ports/irc/bitlbee.

I waited a day and re-cvsupped to confirm the problem hadn't been fixed yet.

How-To-Repeat: 		Attempt to install bitlbee.
Comment 1 Edwin Groothuis freebsd_committer 2006-04-27 12:41:20 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback
Comment 2 Sam Lawrance 2006-04-27 12:51:04 UTC
How about this patch:
Comment 3 Sam Lawrance freebsd_committer 2006-04-27 14:20:25 UTC
Responsible Changed
From-To: freebsd-ports-bugs->lawrance

Grab
Comment 4 Sam Lawrance freebsd_committer 2006-05-11 10:57:17 UTC
State Changed
From-To: feedback->closed

Fix committed. Thanks for the report!