Bug 187030 - emulators/virtualbox-ose doesn't compile with X11 option only
Summary: emulators/virtualbox-ose doesn't compile with X11 option only
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Virtualbox Team (Nobody)
URL:
Keywords:
Depends on: 200764
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-25 11:50 UTC by kaltheat
Modified: 2018-01-12 18:37 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kaltheat 2014-02-25 11:50:01 UTC
Hi,

when compiling virtualbox with these options

OPTIONS_FILE_UNSET+=DBUS
OPTIONS_FILE_UNSET+=DEBUG
OPTIONS_FILE_UNSET+=GUESTADDITIONS
OPTIONS_FILE_UNSET+=NLS
OPTIONS_FILE_UNSET+=PULSEAUDIO
OPTIONS_FILE_UNSET+=PYTHON
OPTIONS_FILE_UNSET+=QT4
OPTIONS_FILE_UNSET+=UDPTUNNEL
OPTIONS_FILE_UNSET+=VDE
OPTIONS_FILE_SET+=VNC
OPTIONS_FILE_UNSET+=VPX
OPTIONS_FILE_UNSET+=WEBSERVICE
OPTIONS_FILE_UNSET+=X11

configure exits with this error:
..
Checking for Xrandr:
  Xrandr not found at -L/usr/X11R6/lib -L/usr/X11R6/lib64 -L/usr/local/lib -lXext -lX11 -lXrandr -I/usr/local/include or Xrandr header
s not found
  Check the file /work/a/ports/emulators/virtualbox-ose/work/VirtualBox-4.3.6/configure.log for detailed error information.
Check /work/a/ports/emulators/virtualbox-ose/work/VirtualBox-4.3.6/configure.log for details
===>  Script "configure" failed unexpectedly.
Please report the problem to vbox@FreeBSD.org [maintainer] and attach the
"/work/a/ports/emulators/virtualbox-ose/work/VirtualBox-4.3.6/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** [do-configure] Error code 1
..

virtualbox compiles fine without X11 option or with X11 option and QT4 option enabled.

Regards,
kaltheat

Fix: 

Possibly add xrandr as run dependency if X11 option is choosed.
Comment 1 Edwin Groothuis freebsd_committer 2014-02-25 16:02:05 UTC
Responsible Changed
From-To: freebsd-ports-bugs->vbox

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 kaltheat 2014-03-29 10:11:05 UTC
Sorry, as I review this report I see an error: options list above does not show 
it right. Every option needs to be unset except X11-option. Otherwise the 
report does not make sense to me. I might have done a copy and paste error ...

Regards,
kaltheat
Comment 3 Walter Schwarzenfeld freebsd_triage 2018-01-12 07:40:31 UTC
Is this still a problem. If not please close the PR:
Comment 4 kaltheat 2018-01-12 18:37:36 UTC
I'm not able to reproduce it since the environment changed remarkable since those days. Problem might still exist though. I will close this issue anyway.