Bug 187979 - devel/talloc 2.1.0 make package fails
Summary: devel/talloc 2.1.0 make package fails
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Timur I. Bakeyev
URL:
Keywords:
: 189844 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-03-26 19:20 UTC by pasko.boris
Modified: 2014-08-11 20:31 UTC (History)
0 users

See Also:


Attachments
file.txt (45.63 KB, text/plain)
2014-03-26 19:20 UTC, pasko.boris
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description pasko.boris 2014-03-26 19:20:01 UTC
When building talloc 2.1.0 using poudriere or simply by invoking 'make package' the port builds successfully, installs successfully but fails to create a package. I have attached the poudriere log, here is the relevant error message:


=======================<phase: package        >============================
===>  Building package for talloc-2.1.0
pkg-static: lstat(/wrkdirs/usr/ports/devel/talloc/work/stage/usr/local/include/pytalloc.h): No such file or directory
pkg-static: lstat(/wrkdirs/usr/ports/devel/talloc/work/stage/usr/local/lib/libpytalloc-util.so): No such file or directory
pkg-static: lstat(/wrkdirs/usr/ports/devel/talloc/work/stage/usr/local/lib/libpytalloc-util.so.2): No such file or directory
pkg-static: lstat(/wrkdirs/usr/ports/devel/talloc/work/stage/usr/local/lib/python2.7/site-packages/talloc.so): No such file or directory
pkg-static: lstat(/wrkdirs/usr/ports/devel/talloc/work/stage/usr/local/libdata/pkgconfig/pytalloc-util.pc): No such file or directory
pkg-static: lstat(/wrkdirs/usr/ports/devel/talloc/work/stage/usr/local/lib/python2.7/site-packages/): No such file or directory
pkg-static: lstat(/wrkdirs/usr/ports/devel/talloc/work/stage/usr/local/lib/python2.7/): No such file or directory
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/talloc

Fix: Packaging manifest is wrong ?

Patch attached with submission follows:
How-To-Repeat: root@serv6:/ # cd /usr/ports/devel/talloc
root@serv6:/usr/ports/devel/talloc # make package
Comment 1 Edwin Groothuis freebsd_committer 2014-03-26 21:54:56 UTC
Responsible Changed
From-To: freebsd-ports-bugs->timur

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Timur I. Bakeyev freebsd_committer 2014-03-27 00:46:05 UTC
I'm not sure, what's wrong in your development environment, but lines:

Checking for program python
                         : /usr/local/bin/python2.7
Checking for program python
                         : /usr/local/bin/python2.7
Checking for Python version >= 2.4.2
                         : ok 2.7.6
Checking for library python2.7
                         : yes
Checking for program python2.7-config
                         : /usr/local/bin/python2.7-config
Checking for custom code
                         : Could not find the python development
headers
Disabling pytdb as python devel libs not found

explain, why Python related staff isn't build.


Also this looks suspicious:

===>   talloc-2.1.0 depends on file: /usr/local/bin/python2.7 - not found
===>    Verifying install for /usr/local/bin/python2.7 in
/usr/ports/lang/python27
===>   Installing existing package /packages/All/python27-2.7.6_4.txz
Installing python27-2.7.6_4...


And then:

===>   Returning to build of talloc-2.1.0

===>   talloc-2.1.0 depends on executable: python2 - not found
===>    Verifying install for python2 in /usr/ports/lang/python2
===>   Installing existing package /packages/All/python2-2_2.txz
Installing python2-2_2... done


Please check config.log why python development libs are not found and
where did they go.


Regards,

Timur.



On Wed, Mar 26, 2014 at 10:54 PM, <edwin@freebsd.org> wrote:

> Synopsis: devel/talloc 2.1.0 make package fails
>
> Responsible-Changed-From-To: freebsd-ports-bugs->timur
> Responsible-Changed-By: edwin
> Responsible-Changed-When: Wed Mar 26 21:54:56 UTC 2014
> Responsible-Changed-Why:
> Over to maintainer (via the GNATS Auto Assign Tool)
>
> http://www.freebsd.org/cgi/query-pr.cgi?pr=187979
>
Comment 3 pasko.boris 2014-03-28 16:04:31 UTC
Most likely similar problem as described here:
http://lists.freebsd.org/pipermail/freebsd-python/2013-October/006020.html

I do hope following helps:

$ /usr/local/bin/python2.7-config --cflags
-I/usr/local/include/python2.7 -I/usr/local/include/python2.7
-fno-strict-aliasing -O2 -pipe -march=athlon64 -fno-strict-aliasing
-DNDEBUG -I/usr/local/include/pth

$ /usr/local/bin/python2.7-config --libs
-L/usr/local/lib -L/usr/local/lib/pth -lpth -lintl -lutil -lm -lpython2.7

$ /usr/local/bin/python2.7-config --includes
-I/usr/local/include/python2.7 -I/usr/local/include/python2.7

$ /usr/local/bin/python2.7-config --ldflags
-L/usr/local/lib/python2.7/config -L/usr/local/lib -L/usr/local/lib/pth
-lpth -lintl -lutil -lm -lpython2.7 -Wl,--export-dynamic




2014-03-26 15:20 GMT-04:00 <FreeBSD-gnats-submit@freebsd.org>:

> Thank you very much for your problem report.
> It has the internal identification `ports/187979'.
> The individual assigned to look at your
> report is: freebsd-ports-bugs.
>
> You can access the state of your problem report at any time
> via this link:
>
> http://www.freebsd.org/cgi/query-pr.cgi?pr=187979
>
> >Category:       ports
> >Responsible:    freebsd-ports-bugs
> >Synopsis:       talloc 2.1.0 make package fails
> >Arrival-Date:   Wed Mar 26 19:20:01 UTC 2014
>
Comment 4 pasko.boris 2014-03-31 17:01:55 UTC
After some investigation, it turned out that the problem was caused by
badly built python27 package. The package was built with both PTH and
THREADS switches which caused mayhem.

I suggest closing this bug as "Not a bug"


2014-03-28 12:04 GMT-04:00 Pasko Boris <pasko.boris@gmail.com>:

> Most likely similar problem as described here:
> http://lists.freebsd.org/pipermail/freebsd-python/2013-October/006020.html
>
> I do hope following helps:
>
> $ /usr/local/bin/python2.7-config --cflags
> -I/usr/local/include/python2.7 -I/usr/local/include/python2.7
> -fno-strict-aliasing -O2 -pipe -march=athlon64 -fno-strict-aliasing
> -DNDEBUG -I/usr/local/include/pth
>
> $ /usr/local/bin/python2.7-config --libs
> -L/usr/local/lib -L/usr/local/lib/pth -lpth -lintl -lutil -lm -lpython2.7
>
> $ /usr/local/bin/python2.7-config --includes
> -I/usr/local/include/python2.7 -I/usr/local/include/python2.7
>
> $ /usr/local/bin/python2.7-config --ldflags
> -L/usr/local/lib/python2.7/config -L/usr/local/lib -L/usr/local/lib/pth
> -lpth -lintl -lutil -lm -lpython2.7 -Wl,--export-dynamic
>
>
>
>
> 2014-03-26 15:20 GMT-04:00 <FreeBSD-gnats-submit@freebsd.org>:
>
> Thank you very much for your problem report.
>> It has the internal identification `ports/187979'.
>> The individual assigned to look at your
>> report is: freebsd-ports-bugs.
>>
>> You can access the state of your problem report at any time
>> via this link:
>>
>> http://www.freebsd.org/cgi/query-pr.cgi?pr=187979
>>
>> >Category:       ports
>> >Responsible:    freebsd-ports-bugs
>> >Synopsis:       talloc 2.1.0 make package fails
>> >Arrival-Date:   Wed Mar 26 19:20:01 UTC 2014
>>
>
>
Comment 5 Marcus von Appen freebsd_committer freebsd_triage 2014-07-29 16:48:53 UTC
*** Bug 189844 has been marked as a duplicate of this bug. ***
Comment 6 Timur I. Bakeyev freebsd_committer 2014-08-11 20:31:11 UTC
It turns our that the problem lays in the wrongly built Python.