Bug 189320 - www/trac does not work
Summary: www/trac does not work
Status: Closed DUPLICATE of bug 187133
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-03 21:30 UTC by mwisnicki+freebsd
Modified: 2014-08-26 07:52 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mwisnicki+freebsd 2014-05-03 21:30:00 UTC
Trac does not work at all when trac-accountmanager-plugin is installed, thoughI've tried removing the plugin and it still does not work:

Trac detected an internal error:

AttributeError: NullTranslationsBabel instance has no attribute 'isactive'


This is a known problem and a patch is available:

http://trac.edgewall.org/ticket/11345
https://bugzilla.redhat.com/show_bug.cgi?id=1089490
https://bugs.archlinux.org/task/37982

Fix: 

Apply patch from link above.
Comment 1 Edwin Groothuis freebsd_committer 2014-05-03 21:30:04 UTC
Responsible Changed
From-To: freebsd-ports-bugs->clsung

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 John Marino freebsd_committer 2014-07-28 08:28:47 UTC
port now unmaintained, resetting assignee
Comment 3 John Marino freebsd_committer 2014-08-19 14:55:49 UTC
please provide a patch to be applied to the port itself, otherwise the PR will be closed due to lack of information.  (It's unlikely a committer is going to follow those links to make a patch)
Comment 4 lorne 2014-08-26 07:50:31 UTC
For a patch (and similar bug report), see https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=187133
Comment 5 John Marino freebsd_committer 2014-08-26 07:52:55 UTC

*** This bug has been marked as a duplicate of bug 187133 ***