Bug 194435 - [PATCH] databases/mariadb55-server update for 5.5.40
Summary: [PATCH] databases/mariadb55-server update for 5.5.40
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: John Marino
URL:
Keywords: patch-ready
Depends on:
Blocks: 194434
  Show dependency treegraph
 
Reported: 2014-10-17 21:27 UTC by Bernard Spil
Modified: 2014-11-24 00:19 UTC (History)
2 users (show)

See Also:
brnrd: maintainer-feedback? (never)


Attachments
patch mariadb55-server version to 5.5.40 (2.86 KB, patch)
2014-10-17 21:27 UTC, Bernard Spil
no flags Details | Diff
Build log (35.42 KB, application/x-gzip)
2014-10-17 21:29 UTC, Bernard Spil
no flags Details
Patch to upgrade mysql55-server port to 5.5.40 (12.83 KB, patch)
2014-11-16 20:15 UTC, Bernard Spil
no flags Details | Diff
Patch to upgrade mysql55-server port to 5.5.40 (13.38 KB, patch)
2014-11-21 22:27 UTC, Bernard Spil
no flags Details | Diff
Build log with latest patch (805.64 KB, text/plain)
2014-11-21 22:28 UTC, Bernard Spil
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernard Spil freebsd_committer 2014-10-17 21:27:54 UTC
Created attachment 148410 [details]
patch mariadb55-server version to 5.5.40

MariaDB 5.5.40 was released Oct 9 2014
Patch attached, buildlog will follow.
Comment 1 Bugzilla Automation freebsd_committer 2014-10-17 21:27:54 UTC
Maintainer CC'd
Comment 2 Bernard Spil freebsd_committer 2014-10-17 21:29:10 UTC
Created attachment 148411 [details]
Build log
Comment 3 John Marino freebsd_committer 2014-10-17 21:34:33 UTC

*** This bug has been marked as a duplicate of bug 194434 ***
Comment 4 Bernard Spil freebsd_committer 2014-10-18 09:05:23 UTC
Not a duplicate of bug 194434 this is a patch for
194435 mariadb55-server 
194434 mariadb55-client
Comment 5 John Marino freebsd_committer 2014-10-18 09:47:37 UTC
sorry.  We get a lot of double PRs because people submit twice.  Visually it looked the same.  

Honestly this probably should have been submitted as a single PR, not two PRs.  They are chained, no?
Comment 6 Bernard Spil freebsd_committer 2014-10-18 14:16:57 UTC
Hi Marino, no problem... And you're right. -client is a slave port of -server. 
I have more updates for mysql and mariadb to create and I'll make sure I combine them.
Comment 7 John Marino freebsd_committer 2014-10-31 18:47:26 UTC
It's been exactly 14 days, so this PR timed out.  Since other mariadb PRs have are also timed out, I'm moving this to patch-ready now (no maintainer approval needed)
Comment 8 Bernard Spil freebsd_committer 2014-11-16 20:15:41 UTC
Created attachment 149490 [details]
Patch to upgrade mysql55-server port to 5.5.40

The previous patch had some issues still, these are fixed.
Updated the CONFLICTS as per the other MySQL/MariaDB/Percona ports
Removed the superfluous tests from the plist
Comment 9 John Marino freebsd_committer 2014-11-16 21:14:28 UTC
This was probably pre-existing, but it fails make check-plist --

Error: Orphaned: lib/mysql/plugin/auth_socket.so


however, I see you posted today.  My error is from previous version.  Will check again.
Comment 10 John Marino freebsd_committer 2014-11-16 21:24:32 UTC
now it's far, far worse.  The entire plist patch is wrong.  All the files you removed are showing as missing.  I'm going to revert that part at least.
Comment 11 Bernard Spil freebsd_committer 2014-11-21 22:27:28 UTC
Created attachment 149696 [details]
Patch to upgrade mysql55-server port to 5.5.40

Hi Marino,

I've removed all the tests as I don't think they should be there (compare mysql55-server).
Haven't found out how mysql55-server fixes that (check-plist is OK there) but found http://dev.mysql.com/doc/refman/5.5/en/source-configuration-options.html 
Where to install the mysql-test directory. As of MySQL 5.5.32, to suppress installation of this directory, explicitly set the option to the empty value (-DINSTALL_MYSQLTESTDIR=).

Added auth_socket to the plist. Haven't found how mysql55-server removes that either...
Comment 12 Bernard Spil freebsd_committer 2014-11-21 22:28:09 UTC
Created attachment 149697 [details]
Build log with latest patch
Comment 13 John Marino freebsd_committer 2014-11-22 18:19:04 UTC
(In reply to Bernard Spil from comment #11)
> I've removed all the tests as I don't think they should be there (compare
> mysql55-server).

Agreed, especially since I'm the one that removed it from 55.

> Added auth_socket to the plist. Haven't found how mysql55-server removes
> that either...

I'm not sre what that means but this build log doesn't have stage-qa checks in it.
Comment 14 commit-hook freebsd_committer 2014-11-22 18:46:42 UTC
A commit references this bug:

Author: marino
Date: Sat Nov 22 18:46:08 UTC 2014
New revision: 373088
URL: https://svnweb.freebsd.org/changeset/ports/373088

Log:
  databases/mariadb55-(client,server): Upgrade version 5.5.39 => 5.5.40

  PR:		194434
  PR:		194435
  Submitted by:	Bernard Spil
  Approved by:	maintainer timeout (Ukraine)

Changes:
  head/databases/mariadb55-client/Makefile
  head/databases/mariadb55-client/files/patch-CMakeLists.txt
  head/databases/mariadb55-client/files/patch-cmake__jemalloc.cmake
  head/databases/mariadb55-client/files/patch-libservices_CMakeLists.txt
  head/databases/mariadb55-client/files/patch-scripts_mysql_config.sh
  head/databases/mariadb55-client/files/patch-support-files_CMakeLists.txt
  head/databases/mariadb55-server/Makefile
  head/databases/mariadb55-server/distinfo
  head/databases/mariadb55-server/files/patch-cmake__jemalloc.cmake
  head/databases/mariadb55-server/pkg-plist
Comment 15 John Marino freebsd_committer 2014-11-22 18:48:37 UTC
Thanks, it built cleanly in poudriere.
Comment 16 never 2014-11-24 00:19:28 UTC
Well, there is a need to update jemalloc things because of mariadb no longer carries bundled jemalloc.

I will submit patch in the coming week.

And sorry about maintainer timeout. Will change all my maintainership to my more current e-mail, which I read permanently.