Bug 198146 - [devel/gdb] Added 'make check' to run gdb testsuite
Summary: [devel/gdb] Added 'make check' to run gdb testsuite
Status: Closed DUPLICATE of bug 200610
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords: needs-patch, patch
Depends on:
Blocks:
 
Reported: 2015-03-01 22:58 UTC by Yuri Victorovich
Modified: 2015-11-11 09:58 UTC (History)
2 users (show)

See Also:
koobs: maintainer-feedback+


Attachments
patch (624 bytes, patch)
2015-03-01 22:58 UTC, Yuri Victorovich
no flags Details | Diff
check log for FreeBSD 10.1 amd64 (79.47 KB, application/x-bzip)
2015-03-01 23:03 UTC, Yuri Victorovich
no flags Details
check log for Arch linux for comparison (10.97 KB, application/x-bzip)
2015-03-01 23:04 UTC, Yuri Victorovich
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2015-03-01 22:58:48 UTC
Created attachment 153653 [details]
patch

Currently 815 cases are reported to fail on FreeBSD 10.1 amd64, compared to 616 on Arch linux.
But it still makes sense to have the target to run it in Makefile.

Relevant bug report https://sourceware.org/bugzilla/show_bug.cgi?id=18067 , reporting to gdb many linux failures.
Comment 1 Yuri Victorovich freebsd_committer 2015-03-01 23:03:34 UTC
Created attachment 153654 [details]
check log for FreeBSD 10.1 amd64
Comment 2 Yuri Victorovich freebsd_committer 2015-03-01 23:04:06 UTC
Created attachment 153655 [details]
check log for Arch linux for comparison
Comment 3 luca.pizzamiglio 2015-04-09 12:00:40 UTC
Hi Yuri,
thanks for your help.

I' like to integrate your patch (with a fix about a missing dependency) for the next gdb 7.9
Comment 4 Yuri Victorovich freebsd_committer 2015-04-09 12:04:02 UTC
Thanks!

Just please don't add dejagnu as a dependency of gdb, because it is only for check. Notice will suffice.
Comment 5 luca.pizzamiglio 2015-11-10 17:01:11 UTC
This will be solved with Bug 200610
Comment 6 Kubilay Kocak freebsd_committer freebsd_triage 2015-11-11 03:31:13 UTC
@Yuri,

This change needs to use TEST_DEPENDS (for dejagnu), do-test (from the new test framework in the tree) and TEST_TARGET (which i believe defaults to check)

post-build comment should be also removed since the existence of a do-test target means it can be run at any time and implicitly since it exists.

@Luca, setting maintainer-feedback to - means 'feedback not received'. If you want to reject a patch for any reason, use maintainer-approval and set it to - 

You can mouseover any flag name for tooltip help descriptions on what each value means and can be used for.
Comment 7 luca.pizzamiglio 2015-11-11 09:06:55 UTC
(In reply to Kubilay Kocak from comment #6)

@koobs, sorry for the misuse of maintainer-feedback flag.

I would set maintainer-approval to - to the submitted patch, but it doesn't work: I open the patch, I change the flag and I push the "Submit" button; I did it twice and nothing happened. Maybe it's a permission/credential stuff.

A second problem with this bug entry is that it's kinda duplicated: Bug 200610 has a solution to implement tests. I mentioned it in comment #4, but I guess I should be more explicit and use the word "duplicated", because I've not enough right to set relationship status between bug entries.
Comment 8 Tijl Coosemans freebsd_committer 2015-11-11 09:58:26 UTC

*** This bug has been marked as a duplicate of bug 200610 ***