Bug 200610 - devel/gdb: please provide opt-in support for tests
Summary: devel/gdb: please provide opt-in support for tests
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Tijl Coosemans
URL:
Keywords: needs-patch
: 198146 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-06-03 03:04 UTC by Enji Cooper
Modified: 2015-11-11 12:08 UTC (History)
5 users (show)

See Also:
luca.pizzamiglio: maintainer-feedback+


Attachments
Patch introducing the target "test" (367 bytes, patch)
2015-11-10 14:56 UTC, luca.pizzamiglio
luca.pizzamiglio: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Enji Cooper freebsd_committer 2015-06-03 03:04:16 UTC
gdb/testsuite in the gdb tarball contains a lot of tests for gdb. It would be nice if we could install those tests to /usr/local/tests/gdb*, then integrate them in to Kyua (eventually). For now installing the tests would be wonderful.

It seems that they need:

- dejagnu (explicitly)
- gcc (implicitly -- there are a number of issues with using clang in base it seems).
- gmake (maybe only from the top-level WORKDIR... not sure)

I still need to churn through the test suite (I ran the gdb 7.7 test suite with minor issues detecting some libraries), but having it to start out with would allow me to go through all of the issues and file bugs upstream with the FSF folks.
Comment 1 luca.pizzamiglio 2015-06-18 12:48:36 UTC
Hi Garrett,

A previous work on it is already done.

gmake is already required, but in case of tests, it's required also as RUNNING_DEPENDS.

I tried to run those tests (not in /usr/local/test, but directly from the gdb source tree) and the number of error is huge (> 800).

I'll try to figure out all implications and to provide a patch soon.
Comment 2 luca.pizzamiglio 2015-09-28 13:30:23 UTC
I've tried to work on this, but it seems a little bit complicated.

Tests are written to be executed in the gdb source tree; moving them without source tree requires some work, especially editing several dejagnu test cases and bringing some extra files. Moreover, the pkg-plist would become huge.

Some works is going on tests on ports (https://reviews.freebsd.org/D3680); it could solve a lot of problems that I've and I would wait that that work is accepted by portmgr before to go any further...
Comment 3 luca.pizzamiglio 2015-11-10 14:56:42 UTC
Created attachment 162962 [details]
Patch introducing the target "test"

This patch add the target "test" using the new test framework recently added.

Note: Tests fail with error code 2, because gdb tests has a huge amount of unexpected failures (1448) [on linux and I've got ~800]
That means that, the test target doesn't proof the port's correctness (actually gdb works) despite the test's failures.
Comment 4 luca.pizzamiglio 2015-11-10 15:00:16 UTC
The new patch makes Bug 198146 obsolete/duplicated
Comment 5 Tijl Coosemans freebsd_committer 2015-11-11 09:58:26 UTC
*** Bug 198146 has been marked as a duplicate of this bug. ***
Comment 6 commit-hook freebsd_committer 2015-11-11 12:07:06 UTC
A commit references this bug:

Author: tijl
Date: Wed Nov 11 12:06:33 UTC 2015
New revision: 401237
URL: https://svnweb.freebsd.org/changeset/ports/401237

Log:
  Enable regression tests

  PR:		200610
  Submitted by:	luca.pizzamiglio@gmail.com (maintainer)

Changes:
  head/devel/gdb/Makefile