Bug 200773 - ports: commit-hook changes bug state while they should only make comments
Summary: ports: commit-hook changes bug state while they should only make comments
Status: Open
Alias: None
Product: Services
Classification: Unclassified
Component: Bug Tracker (show other bugs)
Version: unspecified
Hardware: Any Any
: Normal Affects Some People
Assignee: Bugmeister
URL:
Keywords: needs-qa
Depends on:
Blocks: 200537
  Show dependency treegraph
 
Reported: 2015-06-10 21:55 UTC by Xin LI
Modified: 2020-03-27 12:15 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xin LI freebsd_committer 2015-06-10 21:55:26 UTC
I got this email, which suggests that commit hook for ports commit would make changes to the state, but they are (at least currently) supposed to add additional comments based on the commit messages only.

=======
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=200537

Xin LI <delphij@FreeBSD.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|New                         |Closed
         Resolution|---                         |FIXED

commit-hook@freebsd.org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
         Resolution|FIXED                       |---
             Status|Closed                      |New

--- Comment #9 from Xin LI <delphij@FreeBSD.org> ---
Got maintainer approval and fix committed.

--- Comment #10 from commit-hook@freebsd.org ---
A commit references this bug:

Author: delphij
Date: Wed Jun 10 20:29:40 UTC 2015
New revision: 389144
URL: https://svnweb.freebsd.org/changeset/ports/389144

Log:
  MFH: r389143

  Security update to 1.5.5, while there also move the
  upstream to github.

  PR:        200537
  Approved by:    ports-secteam

Changes:
_U  branches/2015Q2/
  branches/2015Q2/databases/pgbouncer/Makefile
  branches/2015Q2/databases/pgbouncer/distinfo
  branches/2015Q2/databases/pgbouncer/pkg-descr

-- You are receiving this mail because: You are on the CC list for the bug. 
======
Comment 1 Xin LI freebsd_committer 2015-06-10 21:56:16 UTC
Add portmgr@ to Cc per suggestion from bugmeister.
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2015-11-02 06:55:00 UTC
@Xin, am I understanding correctly that this is a bug, defined by:

"post-commit hook re-opens issue if referenced in commit log (PR: <id>), if the issue is already closed"

Or is the report more general than that? My understanding at the moment is that the bug is this bit only:

=======================
Resolution: FIXED → ---
Status: Closed → New
=======================

I'm trying to reconcile the statement in this issue summary that bugzilla 'should only make comments'. 

Do you mean it should *never* change state, or only *if* the issue is already closed, OR *already* in the state it was going to be in if bugzilla were to change it.
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2016-08-23 04:41:32 UTC
Found what appears to be another example of this in bug 211681
Comment 4 Mathieu Arnold freebsd_committer 2018-01-09 09:30:18 UTC
It's strange, I usually work on stuff, close the PR as I commit in git and dcommit when I'm done for the session/day, I never saw that happen.
Comment 5 Matthias Andree freebsd_committer 2020-03-27 12:15:55 UTC
Just hit this in https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=245098#c3 (commit-hook).