Bug 204497 - [NEW PORT] graphics/aseprite: Animated sprite editor & pixel art tool
Summary: [NEW PORT] graphics/aseprite: Animated sprite editor & pixel art tool
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords: feature, patch, patch-ready
Depends on: 204487 204492 204508
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-12 11:45 UTC by Yuri Victorovich
Modified: 2016-05-20 19:16 UTC (History)
1 user (show)

See Also:


Attachments
shar archive (17.91 KB, application/shar)
2015-11-12 11:45 UTC, Yuri Victorovich
no flags Details
poudriere log (43.23 KB, text/plain)
2015-11-12 11:47 UTC, Yuri Victorovich
no flags Details
shar archive (17.89 KB, text/plain)
2015-11-12 12:18 UTC, Yuri Victorovich
no flags Details
shar archive (10.58 KB, text/plain)
2015-11-12 19:36 UTC, Yuri Victorovich
no flags Details
shar archive (18.00 KB, text/plain)
2015-12-04 03:05 UTC, Yuri Victorovich
no flags Details
shar archive (10.17 KB, text/plain)
2015-12-04 22:23 UTC, Yuri Victorovich
no flags Details
theme-a97924.sh (3.61 KB, text/plain)
2016-02-05 20:26 UTC, Kurt Jaeger
no flags Details
shar archive (10.70 KB, text/plain)
2016-02-05 22:15 UTC, Yuri Victorovich
no flags Details
shar archive (10.30 KB, text/plain)
2016-03-12 20:42 UTC, Yuri Victorovich
no flags Details
theme-ebe4cb.sh (3.97 KB, application/x-sh)
2016-03-13 09:56 UTC, Kurt Jaeger
no flags Details
shar archive (10.70 KB, text/plain)
2016-05-20 06:40 UTC, Yuri Victorovich
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2015-11-12 11:45:00 UTC
Created attachment 163048 [details]
shar archive

http://www.aseprite.org/

Here is the video demo: http://imgur.com/t3ZGRzw
Comment 1 Yuri Victorovich freebsd_committer 2015-11-12 11:47:11 UTC
Created attachment 163049 [details]
poudriere log
Comment 2 Yuri Victorovich freebsd_committer 2015-11-12 12:18:08 UTC
Created attachment 163051 [details]
shar archive
Comment 3 Yuri Victorovich freebsd_committer 2015-11-12 19:36:02 UTC
Created attachment 163068 [details]
shar archive
Comment 4 Yuri Victorovich freebsd_committer 2015-12-04 03:05:18 UTC
Created attachment 163833 [details]
shar archive
Comment 5 Dmitry Marakasov freebsd_committer 2015-12-04 14:13:07 UTC
(In reply to yuri from comment #4)
> Created attachment 163833 [details]
> shar archive

You should not bundle third party code with the port. There is a way to get this file from pixman port:

EXTRACT_DEPENDS=        ${NONEXISTENT}:${PORTSDIR}/x11/pixman:extract

post-extract:
    @${CP} `${MAKE} -C ${PORTSDIR}/x11/pixman -V WRKSRC` ${WRKSRC}/...

see irc/gseen.mod for example, grep portstree for :extract for some more examples.
Comment 6 Yuri Victorovich freebsd_committer 2015-12-04 22:23:45 UTC
Created attachment 163856 [details]
shar archive
Comment 7 Kurt Jaeger freebsd_committer 2016-02-05 20:26:08 UTC
Created attachment 166626 [details]
theme-a97924.sh
Comment 8 Kurt Jaeger freebsd_committer 2016-02-05 20:27:26 UTC
Strange build problem on 11amd:

[ 13%] Building CXX object src/ui/CMakeFiles/ui-lib.dir/theme.cpp.o
Assertion failed: (NumReferences == 0 && "Node deleted while references remain"), function ~CallGraphNode, file /usr/src/lib/clang/libllvmipa/../../../contrib/llvm/include/llvm/Analysis/CallGraph.h, line 179.
c++: error: unable to execute command: Abort trap (core dumped)
c++: error: clang frontend command failed due to signal (use -v to see invocation)
FreeBSD clang version 3.7.1 (tags/RELEASE_371/final 255217) 20151225
Target: x86_64-unknown-freebsd11.0
Thread model: posix
c++: note: diagnostic msg: PLEASE submit a bug report to https://bugs.freebsd.org/submit/ and include the crash backtrace, preprocessed source, and associated run script.
c++: note: diagnostic msg: 
********************

PLEASE ATTACH THE FOLLOWING FILES TO THE BUG REPORT:
Preprocessed source(s) and associated run script(s) are located at:
c++: note: diagnostic msg: /tmp/theme-a97924.cpp
c++: note: diagnostic msg: /tmp/theme-a97924.sh
c++: note: diagnostic msg: 


********************
*** Error code 254

Stop.
make[4]: stopped in /home/pi/myp/graphics/aseprite/work/.build
*** Error code 1

The .sh is attached, the .cpp see

http://people.freebsd.org/~pi/logs/theme-a97924.cpp
Comment 9 Kurt Jaeger freebsd_committer 2016-02-05 20:28:04 UTC
uname:

FreeBSD 11.0-CURRENT #0 r294096M
Comment 10 Yuri Victorovich freebsd_committer 2016-02-05 20:40:36 UTC
This is clang failure.

They normally want users to file bugs with testcase files like these:
> c++: note: diagnostic msg: /tmp/theme-a97924.cpp
> c++: note: diagnostic msg: /tmp/theme-a97924.sh
So that the clang team can fix it.
Comment 11 Yuri Victorovich freebsd_committer 2016-02-05 20:41:12 UTC
I will add the line fixing the compiler version.
Comment 12 Yuri Victorovich freebsd_committer 2016-02-05 21:29:11 UTC
I reproduced the crash and submittedn the bug report for clang: https://llvm.org/bugs/show_bug.cgi?id=26499
Comment 13 Yuri Victorovich freebsd_committer 2016-02-05 22:15:16 UTC
Created attachment 166634 [details]
shar archive

Always use clang-36 for now.

Tested on 10.3-PRERELEASE amd64
Comment 14 Kurt Jaeger freebsd_committer 2016-03-06 09:35:00 UTC
Sorry that I did not react earlier.

There's an update to 1.1.3 out there, this means the GH_TAGNAMEs have to be changed ?

And:

[ 61%] Building CXX object src/app/CMakeFiles/app-lib.dir/util/freetype_utils.cpp.o
/home/pi/myp/graphics/aseprite/work/aseprite-b659747/src/app/util/freetype_utils.cpp:24:10: fatal error: 
      'ftglyph.h' file not found
#include <ftglyph.h>
         ^
1 error generated.
*** Error code 1
Comment 15 Kurt Jaeger freebsd_committer 2016-03-06 09:45:09 UTC
If I change

CMAKE_ARGS+= -DFREETYPE_INCLUDE_DIR=${LOCALBASE}/include/freetype2/freetype

it fails here:


[ 74%] Building CXX object src/app/CMakeFiles/app-lib.dir/xml_document.cpp.o
In file included from /home/pi/myp/graphics/aseprite/work/aseprite-b659747/src/app/util/freetype_utils.cpp:24:
/usr/local/include/freetype2/freetype/ftglyph.h:36:10: fatal error: 'ft2build.h' file not found
#include <ft2build.h>
         ^
Comment 16 Yuri Victorovich freebsd_committer 2016-03-12 20:42:37 UTC
Created attachment 168060 [details]
shar archive

Updated to 1.1.3.
Passes poudriere on 10.3-PRERELEASE.
Comment 17 Kurt Jaeger freebsd_committer 2016-03-13 09:32:50 UTC
testbuilds@work
Comment 18 Kurt Jaeger freebsd_committer 2016-03-13 09:55:12 UTC
triggers another compiler crash on 11 (?), fails on 9.3a, see

http://people.freebsd.org/~pi/logs/graphics__aseprite-93a-1457861510.txt

Attachment of the compiler failure follows.
Comment 19 Kurt Jaeger freebsd_committer 2016-03-13 09:56:04 UTC
Created attachment 168083 [details]
theme-ebe4cb.sh

other crash
Comment 20 Kurt Jaeger freebsd_committer 2016-03-13 09:57:58 UTC
The theme-ebe4cb.cpp is at

http://people.freebsd.org/~pi/logs/theme-ebe4cb.cpp
Comment 21 Yuri Victorovich freebsd_committer 2016-05-20 06:40:21 UTC
Created attachment 170496 [details]
shar archive

Updated to 1.1.5.6.
Compiler crashes are all gone.

Ready to commit.
Comment 22 Kurt Jaeger freebsd_committer 2016-05-20 18:22:29 UTC
testbuilds@work
Comment 23 commit-hook freebsd_committer 2016-05-20 19:15:35 UTC
A commit references this bug:

Author: pi
Date: Fri May 20 19:15:24 UTC 2016
New revision: 415574
URL: https://svnweb.freebsd.org/changeset/ports/415574

Log:
  New port: graphics/aseprite

  Aseprite is an open source program to create animated sprites.

  Its main features are:
  * Sprites are composed by layers & frames (as separated concepts).
  * Supported color modes: RGBA, Indexed (palettes up to 256 colors),
    and Grayscale.
  * Load/save sequence of PNG files and GIF animations
    (and FLC, FLI, JPG, BMP, PCX, TGA).
  * Export/import animations to/from Sprite Sheets.
  * Tiled drawing mode, useful to draw patterns and textures.
  * Undo/Redo for every operation.
  * Real-time animation preview.
  * Multiple editors support.
  * Pixel-art specific tools like filled Contour, Polygon, Shading mode, etc.
  * Onion skinning

  WWW: http://www.aseprite.org/

  PR:		204497
  Submitted by:	Yuri Victorovich <yuri@rawbw.com>

Changes:
  head/graphics/Makefile
  head/graphics/aseprite/
  head/graphics/aseprite/Makefile
  head/graphics/aseprite/distinfo
  head/graphics/aseprite/files/
  head/graphics/aseprite/files/patch-src_app_resource__finder.cpp
  head/graphics/aseprite/files/patch-src_app_util_freetype__utils.cpp
  head/graphics/aseprite/files/patch-src_base_file__handle.cpp
  head/graphics/aseprite/files/patch-src_base_fs__unix.h
  head/graphics/aseprite/pkg-descr
  head/graphics/aseprite/pkg-plist
Comment 24 Kurt Jaeger freebsd_committer 2016-05-20 19:15:49 UTC
Committed, thanks!