Bug 204711 - textproc/jq: Update to 1.5
Summary: textproc/jq: Update to 1.5
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dmitry Marakasov
URL:
Keywords: needs-patch, needs-qa, patch
: 204710 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-11-21 08:15 UTC by Yuri Victorovich
Modified: 2015-12-14 20:30 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (jnlin)


Attachments
patch (2.29 KB, patch)
2015-11-21 08:15 UTC, Yuri Victorovich
no flags Details | Diff
poudriere log (21.87 KB, text/plain)
2015-11-21 08:15 UTC, Yuri Victorovich
no flags Details
patch (2.31 KB, patch)
2015-11-21 08:37 UTC, Yuri Victorovich
no flags Details | Diff
patch (2.39 KB, patch)
2015-11-29 08:25 UTC, Yuri Victorovich
no flags Details | Diff
Improved version of the patch (2.22 KB, patch)
2015-12-03 10:16 UTC, Dmitry Marakasov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2015-11-21 08:15:16 UTC
Created attachment 163367 [details]
patch
Comment 1 Yuri Victorovich freebsd_committer 2015-11-21 08:15:55 UTC
Created attachment 163368 [details]
poudriere log
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2015-11-21 08:18:26 UTC
*** Bug 204710 has been marked as a duplicate of this bug. ***
Comment 3 Yuri Victorovich freebsd_committer 2015-11-21 08:37:23 UTC
Created attachment 163369 [details]
patch

Clarified what ONIGURUMA option is
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2015-11-27 01:42:34 UTC
@Yuri

1) OPTIONS_* helpers should be placed before bsd.port.options.mk include
2) .if ${PORT_OPTIONS:MONIGURUMA} can be converted into an options helper
3) bsd.port.options.mk is probably not necessary after (2)
Comment 5 Yuri Victorovich freebsd_committer 2015-11-28 17:05:46 UTC
@Kubilay,

> 2) .if ${PORT_OPTIONS:MONIGURUMA} can be converted into an options helper

This case is special, because --without-oniguruma happens to be broken in the upstream release. https://github.com/stedolan/jq/issues/1021 We need to wait until the next release to do what you suggested.
Comment 6 Kubilay Kocak freebsd_committer freebsd_triage 2015-11-29 01:43:00 UTC
(In reply to yuri from comment #5)

You can use <OPTION>_CONFIGURE_ON instead of <OPTION>_CONFIGURE_WITH so that the --without-* case isn't set/run
Comment 7 Yuri Victorovich freebsd_committer 2015-11-29 08:25:10 UTC
Created attachment 163644 [details]
patch
Comment 8 Dmitry Marakasov freebsd_committer 2015-12-02 19:16:52 UTC
- Please do not add extra tab to each line
- Please group options-dependent knobs together, these should follow OPTIONS_DEFINE
Comment 9 Yuri Victorovich freebsd_committer 2015-12-02 20:05:07 UTC
> - Please do not add extra tab to each line
Why?
This makes it aligned and look cleaner. Is number of tabs standardized anywhere?

> - Please group options-dependent knobs together, these should follow OPTIONS_DEFINE
Please suggest such check to ports-mgmt/portlint, because it is used to sign off on the order of lines.
Comment 10 Dmitry Marakasov freebsd_committer 2015-12-03 10:13:44 UTC
(In reply to yuri from comment #9)
> > - Please do not add extra tab to each line
> Why?
> This makes it aligned and look cleaner. Is number of tabs standardized
> anywhere?

Two tabs is de-facto standard all over the tree, except for long options blocks where more tabs is really quite useful. The change also adds unneeded diff noise.

> > - Please group options-dependent knobs together, these should follow OPTIONS_DEFINE
> Please suggest such check to ports-mgmt/portlint, because it is used to sign
> off on the order of lines.

You can suggest a check for portlint yourself.
Comment 11 Dmitry Marakasov freebsd_committer 2015-12-03 10:16:15 UTC
Created attachment 163806 [details]
Improved version of the patch

Suggested version of the patch with the following improvements:

- Don't introduce unneeded whitespace changes
- Group options together
- Add LICENSE
- Switch to pkg-plist
Comment 12 Yuri Victorovich freebsd_committer 2015-12-03 10:40:55 UTC
> Two tabs is de-facto standard all over the tree
Readability is better when all columns are aligned. Your version is less readable.

> You can suggest a check for portlint yourself.
I didn't suggest the change, you did.
Comment 13 Dmitry Marakasov freebsd_committer 2015-12-03 11:53:39 UTC
(In reply to yuri from comment #12)
> Readability is better when all columns are aligned. Your version is less
> readable.

This is arguable. To make all columns aligned you'll need 4 tabs, and wasted horizontal space do not improve readbility at all. Which is more important, we have uniform formatting for all ports, and we're gonna stick to it.

> > You can suggest a check for portlint yourself.
> I didn't suggest the change, you did.

I didn't, I don't care of portlint and I don't understand how it even is related.
Comment 14 commit-hook freebsd_committer 2015-12-14 20:30:03 UTC
A commit references this bug:

Author: amdmi3
Date: Mon Dec 14 20:29:47 UTC 2015
New revision: 403735
URL: https://svnweb.freebsd.org/changeset/ports/403735

Log:
  - Update to 1.5
  - Add LICENSE
  - Optionize ONIGURAMA

  PR:		204711
  Submitted by:	yuri@rawbw.com, amdmi3
  Approved by:	maintainer timeout (jnlin@csie.nctu.edu.tw, 3 weeks)

Changes:
  head/textproc/jq/Makefile
  head/textproc/jq/distinfo
  head/textproc/jq/pkg-plist