Bug 207750 - math/py-numpy: Run-time errors as it can't find /usr/local/lib/gcc48/libgfortran.so.3
Summary: math/py-numpy: Run-time errors as it can't find /usr/local/lib/gcc48/libgfort...
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-python mailing list
URL:
Keywords: needs-qa
: 217968 (view as bug list)
Depends on: 208120
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-06 18:58 UTC by Zane C. Bowers-Hadley
Modified: 2018-01-16 13:08 UTC (History)
8 users (show)

See Also:
bugzilla: maintainer-feedback? (python)


Attachments
py-numpy build log (319.73 KB, text/plain)
2016-03-06 18:58 UTC, Zane C. Bowers-Hadley
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zane C. Bowers-Hadley 2016-03-06 18:58:04 UTC
Created attachment 167772 [details]
py-numpy build log

Attempting to run something like osmocom_fft results in the issue below...

[kitsune@vixen42]/home/kitsune% osmocom_fft 
Traceback (most recent call last):
  File "/usr/local/bin/osmocom_fft", line 34, in <module>
    from gnuradio import blocks
  File "/usr/local/lib/python2.7/site-packages/gnuradio/blocks/__init__.py", line 34, in <module>
    from stream_to_vector_decimator import *
  File "/usr/local/lib/python2.7/site-packages/gnuradio/blocks/stream_to_vector_decimator.py", line 23, in <module>
    from gnuradio import gr
  File "/usr/local/lib/python2.7/site-packages/gnuradio/gr/__init__.py", line 44, in <module>
    from top_block import *
  File "/usr/local/lib/python2.7/site-packages/gnuradio/gr/top_block.py", line 30, in <module>
    from hier_block2 import hier_block2
  File "/usr/local/lib/python2.7/site-packages/gnuradio/gr/hier_block2.py", line 25, in <module>
    import pmt
  File "/usr/local/lib/python2.7/site-packages/pmt/__init__.py", line 58, in <module>
    from pmt_to_python import pmt_to_python as to_python
  File "/usr/local/lib/python2.7/site-packages/pmt/pmt_to_python.py", line 22, in <module>
    import numpy
  File "/usr/local/lib/python2.7/site-packages/numpy/__init__.py", line 180, in <module>
    from . import add_newdocs
  File "/usr/local/lib/python2.7/site-packages/numpy/add_newdocs.py", line 13, in <module>
    from numpy.lib import add_newdoc
  File "/usr/local/lib/python2.7/site-packages/numpy/lib/__init__.py", line 8, in <module>
    from .type_check import *
  File "/usr/local/lib/python2.7/site-packages/numpy/lib/type_check.py", line 11, in <module>
    import numpy.core.numeric as _nx
  File "/usr/local/lib/python2.7/site-packages/numpy/core/__init__.py", line 14, in <module>
    from . import multiarray
ImportError: /lib/libgcc_s.so.1: version GCC_4.6.0 required by /usr/local/lib/gcc48/libgfortran.so.3 not found
Exit 1


[kitsune@vixen42]/home/kitsune% uname -a
FreeBSD vixen42.vulpes.vvelox.net 10.3-BETA3 FreeBSD 10.3-BETA3 #1 r296090: Fri Feb 26 06:29:58 CST 2016     kitsune@vixen42.vulpes.vvelox.net:/usr/obj/usr/src/sys/GENERIC  amd64


[root@vixen42]/arc/src/ports/math/py-numpy# make showconfig
===> The following configuration options are available for py27-numpy-1.10.4,1:
     DOCS=off: Build and/or install documentation
     SUITESPARSE=on: Use AMD and UMFPACK in SuiteSparse
     TESTS=off: Install test suite requirements
====> Options available for the single BLASLIB: you have to select exactly one of them
     ATLAS=off: ATLAS blas implementation
     NETLIB=on: Blas implementation from Netlib
     OPENBLAS=off: OpenBLAS blas implementation
===> Use 'make config' to modify these settings



[root@vixen42]/arc/src/ports/math/py-numpy# cat /etc/src.conf 
WITHOUT_LPR=yes
WITHOUT_SENDMAIL=yes



[root@vixen42]/arc/src/ports/math/py-numpy# cat /etc/make.conf 
CUPS_OVERWRITE_BASE=yes
#DEFAULT_VERSIONS+=5.18
DEFAULT_VERSIONS+=    perl5=5.22
Comment 1 VK freebsd_triage 2016-06-14 17:05:34 UTC
I have tried replicating this issue as there was just another inquiry about that same failure in #freebsd@Freenode, but I couldn't. It wasn't related to osmocom_fft but merely importing numpy would trigger it.

I tried importing numpy and specifically, repeat that last import before the ImportError in this report, it didn't fail.

I built numpy with poudriere, and only had to change math/suitesparse config to use Netlib, because Openblas fails to build like that.

FreeBSD 10.3-p5 (amd64), ports from SVN head. Clean poudriere jail just for this test.
Comment 2 Olivier Duchateau freebsd_committer 2016-06-14 18:35:52 UTC
It's not Numpy's problem, but rather GNU Radio. I already encountered this error with several applications (especially Pitivi devel release, Flowblade).

Import of modules with Numpy is very "fragile", it doesn't support circular import (in fact relative import). GNU Radio must import each own modules globally (it's not a trivial process, especially when there are many).

Using sys.path() method is generally helpful.
Comment 3 Ryder Dain 2016-06-14 19:35:37 UTC
(In reply to Vladimir Krstulja from comment #1)

Hi Vlad, that was me inquiring, btw: yes, the port will build in poudriere just fine with math/suitesparse set to the same.

However, the (single) bug here probably bears repeating: 'import numpy' while using the interactive shell throws the same error as seen and reported in bug #188114, and can be solved the same way. Calling the shell as

    env LD_LIBRARY_PATH=/usr/local/lib/gcc48 python 

removes the problem. However, this *only* affected me in the interactive shell, which indicates it may likely be my problem – I'm building a clean instance now to try this out on without any prior settings, and I'll leave another comment if and when I find out what the difference was.
Comment 4 Shane 2016-06-15 08:31:29 UTC
This has come up a few times. Setting LD_LIBRARY_PATH is a known workaround. If you have several apps with this issue then you may want to set this in your shell startup file (.cshrc or .bashrc) or create a substitute script that is found in your path before the real app that sets this and then calls the real app.

bug #208120 is looking at a way to fix this properly.
Comment 5 Shawn Webb 2017-01-25 22:46:12 UTC
I'm seeing this, too. This is preventing me from running comms/gnuradio successfully.
Comment 6 Jason W. Bacon freebsd_committer 2017-03-21 13:48:34 UTC
I was able to solve this permanently by deleting gcc and everything that depends on it, and then reinstalling numpy.

If I can narrow it down more, I'll report back, but this appears to be a pkg upgrade failure of some sort.

FreeBSD unixdev.ceas bacon ~ 402: cat junk.py
#!/usr/bin/env python

import sys,os
import numpy

print 'Hello!\n'

FreeBSD unixdev.ceas bacon ~ 403: python2 junk.py
Traceback (most recent call last):
  File "junk.py", line 4, in <module>
    import numpy
  File "/usr/local/lib/python2.7/site-packages/numpy/__init__.py", line 142, in <module>
    from . import add_newdocs
  File "/usr/local/lib/python2.7/site-packages/numpy/add_newdocs.py", line 13, in <module>
    from numpy.lib import add_newdoc
  File "/usr/local/lib/python2.7/site-packages/numpy/lib/__init__.py", line 8, in <module>
    from .type_check import *
  File "/usr/local/lib/python2.7/site-packages/numpy/lib/type_check.py", line 11, in <module>
    import numpy.core.numeric as _nx
  File "/usr/local/lib/python2.7/site-packages/numpy/core/__init__.py", line 14, in <module>
    from . import multiarray


<<<ROOT@unixdev.ceas>>> /home/bacon 1005 # pkg delete -y gcc\*

[snip irrelevant pkg output]

ImportError: /lib/libgcc_s.so.1: version GCC_4.6.0 required by /usr/local/lib/gcc49/libgfortran.so.3 not found
Proceed with deinstalling packages? [y/N]: y
[1/84] Deinstalling py27-qiime-1.9.1...
[1/84] Deleting files for py27-qiime-1.9.1: 100%
[2/84] Deinstalling py27-statsmodels-0.6.1_1...
[2/84] Deleting files for py27-statsmodels-0.6.1_1: 100%
[3/84] Deinstalling hs-bio-0.5.3_2...
[3/84] Deleting files for hs-bio-0.5.3_2: 100%
[4/84] Deinstalling ghemical-3.0.0_9...
[4/84] Deleting files for ghemical-3.0.0_9: 100%
[5/84] Deinstalling py27-biom-format-2.1.5_1...
[5/84] Deleting files for py27-biom-format-2.1.5_1: 100%
[6/84] Deinstalling brian-1.4.3...
[6/84] Deleting files for brian-1.4.3: 100%
[7/84] Deinstalling py27-pandas-0.19.2...
[7/84] Deleting files for py27-pandas-0.19.2: 100%
[8/84] Deinstalling hs-QuickCheck-2.8.1...
[8/84] Deleting files for hs-QuickCheck-2.8.1: 100%
[9/84] Deinstalling petsc-3.7.4...
[9/84] Deleting files for petsc-3.7.4: 100%
[10/84] Deinstalling libghemical-3.0.0_7...
[10/84] Deleting files for libghemical-3.0.0_7: 100%
[11/84] Deinstalling octave-4.0.3_2...
[11/84] Deleting files for octave-4.0.3_2: 100%
[12/84] Deinstalling py27-scipy-0.19.0...
[12/84] Deleting files for py27-scipy-0.19.0: 100%
[13/84] Deinstalling arpack++-1.2_7...
[13/84] Deleting files for arpack++-1.2_7: 100%
[14/84] Deinstalling py27-numexpr-2.6.2...
[14/84] Deleting files for py27-numexpr-2.6.2: 100%
[15/84] Deinstalling py27-bottleneck-1.0.0...
[15/84] Deleting files for py27-bottleneck-1.0.0: 100%
[16/84] Deinstalling py27-patsy-0.4.1...
[16/84] Deleting files for py27-patsy-0.4.1: 100%
[17/84] Deinstalling py27-matplotlib-1.5.3_1...
[17/84] Deleting files for py27-matplotlib-1.5.3_1: 100%
[18/84] Deinstalling py27-h5py-2.6.0...
[18/84] Deleting files for py27-h5py-2.6.0: 100%
[19/84] Deinstalling pyfasta-0.5.2_1...
[19/84] Deleting files for pyfasta-0.5.2_1: 100%
[20/84] Deinstalling pycogent-1.9...
[20/84] Deleting files for pycogent-1.9: 100%
[21/84] Deinstalling hs-tf-random-0.5_2...
[21/84] Deleting files for hs-tf-random-0.5_2: 100%
[22/84] Deinstalling hs-parsec-3.1.9...
[22/84] Deleting files for hs-parsec-3.1.9: 100%
[23/84] Deinstalling hs-old-time-1.1.0.3...
[23/84] Deleting files for hs-old-time-1.1.0.3: 100%
[24/84] Deinstalling hs-tagsoup-0.13.3...
[24/84] Deleting files for hs-tagsoup-0.13.3: 100%
[25/84] Deinstalling mpqc-2.3.1_28...
[25/84] Deleting files for mpqc-2.3.1_28: 100%
[26/84] Deinstalling qrupdate-1.1.2_4...
[26/84] Deleting files for qrupdate-1.1.2_4: 100%
[27/84] Deinstalling superlu-5.2.1_1...
[27/84] Deleting files for superlu-5.2.1_1: 100%
[28/84] Deinstalling scalapack-2.0.2_10...
[28/84] Deleting files for scalapack-2.0.2_10: 100%
[29/84] Deinstalling plink-1.07_5...
[29/84] Deleting files for plink-1.07_5: 100%
[30/84] Deinstalling libtsnnls-2.3.3_5...
[30/84] Deleting files for libtsnnls-2.3.3_5: 100%
[31/84] Deinstalling levmar-2.6_5...
[31/84] Deleting files for levmar-2.6_5: 100%
[32/84] Deinstalling lapacke-3.5.0_1...
[32/84] Deleting files for lapacke-3.5.0_1: 100%
[33/84] Deinstalling lapack95-1.0_11...
[33/84] Deleting files for lapack95-1.0_11: 100%
[34/84] Deinstalling kktdirect-0.5_5...
[34/84] Deleting files for kktdirect-0.5_5: 100%
[35/84] Deinstalling harminv-1.3.1_8...
[35/84] Deleting files for harminv-1.3.1_8: 100%
[36/84] Deinstalling gretl-1.9.13_7...
[36/84] Deleting files for gretl-1.9.13_7: 100%
Unknown media type in type 'chemical/x-alchemy'
Unknown media type in type 'chemical/x-cache'
Unknown media type in type 'chemical/x-cactvs-ascii'
Unknown media type in type 'chemical/x-cactvs-binary'
Unknown media type in type 'chemical/x-cactvs-table'
Unknown media type in type 'chemical/x-cdx'
Unknown media type in type 'chemical/x-cdxml'
Unknown media type in type 'chemical/x-chem3d'
Unknown media type in type 'chemical/x-cif'
Unknown media type in type 'chemical/x-cml'
Unknown media type in type 'chemical/x-daylight-smiles'
Unknown media type in type 'chemical/x-dmol'
Unknown media type in type 'chemical/x-gamess-input'
Unknown media type in type 'chemical/x-gamess-output'
Unknown media type in type 'chemical/x-gaussian-input'
Unknown media type in type 'chemical/x-gaussian-log'
Unknown media type in type 'chemical/x-genbank'
Unknown media type in type 'chemical/x-gulp'
Unknown media type in type 'chemical/x-hin'
Unknown media type in type 'chemical/x-inchi'
Unknown media type in type 'chemical/x-inchi-xml'
Unknown media type in type 'chemical/x-jcamp-dx'
Unknown media type in type 'chemical/x-macromodel-input'
Unknown media type in type 'chemical/x-mdl-molfile'
Unknown media type in type 'chemical/x-mdl-rdfile'
Unknown media type in type 'chemical/x-mdl-rxnfile'
Unknown media type in type 'chemical/x-mdl-sdfile'
Unknown media type in type 'chemical/x-mdl-tgf'
Unknown media type in type 'chemical/x-mmcif'
Unknown media type in type 'chemical/x-mol2'
Unknown media type in type 'chemical/x-mopac-graph'
Unknown media type in type 'chemical/x-mopac-input'
Unknown media type in type 'chemical/x-mopac-out'
Unknown media type in type 'chemical/x-msi-car'
Unknown media type in type 'chemical/x-msi-hessian'
Unknown media type in type 'chemical/x-msi-mdf'
Unknown media type in type 'chemical/x-msi-msi'
Unknown media type in type 'chemical/x-ncbi-asn1'
Unknown media type in type 'chemical/x-ncbi-asn1-binary'
Unknown media type in type 'chemical/x-ncbi-asn1-xml'
Unknown media type in type 'chemical/x-pdb'
Unknown media type in type 'chemical/x-shelx'
Unknown media type in type 'chemical/x-vmd'
Unknown media type in type 'chemical/x-xyz'
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
[37/84] Deinstalling getdp-2.8.0_1...
[37/84] Deleting files for getdp-2.8.0_1: 100%
[38/84] Deinstalling py27-numpy-1.11.2_2,1...
[38/84] Deleting files for py27-numpy-1.11.2_2,1: 100%
[39/84] Deinstalling ltl-1.9.1_4...
[39/84] Deleting files for ltl-1.9.1_4: 100%
[40/84] Deinstalling R-cran-optparse-1.3.2...
[40/84] Deleting files for R-cran-optparse-1.3.2: 100%
[41/84] Deinstalling R-cran-randomForest-4.6.7_6...
[41/84] Deleting files for R-cran-randomForest-4.6.7_6: 100%
[42/84] Deinstalling xlapack-3.5.0_3...
[42/84] Deleting files for xlapack-3.5.0_3: 100%
[43/84] Deinstalling hs-random-1.1...
[43/84] Deleting files for hs-random-1.1: 100%
[44/84] Deinstalling hs-primitive-0.6...
[44/84] Deleting files for hs-primitive-0.6: 100%
[45/84] Deinstalling hs-mtl-2.2.1...
[45/84] Deleting files for hs-mtl-2.2.1: 100%
[46/84] Deinstalling hs-text-1.2.1.3...
[46/84] Deleting files for hs-text-1.2.1.3: 100%
[47/84] Deinstalling hs-old-locale-1.0.0.7...
[47/84] Deleting files for hs-old-locale-1.0.0.7: 100%
[48/84] Deinstalling hs-extensible-exceptions-0.1.1.4_7...
[48/84] Deleting files for hs-extensible-exceptions-0.1.1.4_7: 100%
[49/84] Deinstalling hs-parallel-3.2.0.6...
[49/84] Deleting files for hs-parallel-3.2.0.6: 100%
[50/84] Deinstalling suitesparse-4.0.2_5...
[50/84] Deleting files for suitesparse-4.0.2_5: 100%
[51/84] Deinstalling lapack-3.5.0_1...
[51/84] Deleting files for lapack-3.5.0_1: 100%
[52/84] Deinstalling arpack-96_14...
[52/84] Deleting files for arpack-96_14: 100%
[53/84] Deinstalling linpack-1.0_7...
[53/84] Deleting files for linpack-1.0_7: 100%
[54/84] Deinstalling lapack++-2.5.4_1...
[54/84] Deleting files for lapack++-2.5.4_1: 100%
[55/84] Deinstalling mcmc-jags-4.2.0...
[55/84] Deleting files for mcmc-jags-4.2.0: 100%
[56/84] Deinstalling R-cran-getopt-1.20.0...
[56/84] Deleting files for R-cran-getopt-1.20.0: 100%
[57/84] Deinstalling R-cran-permute-0.9.4...
[57/84] Deleting files for R-cran-permute-0.9.4: 100%
[58/84] Deinstalling R-cran-RColorBrewer-1.1.2...
[58/84] Deleting files for R-cran-RColorBrewer-1.1.2: 100%
[59/84] Deinstalling blas-3.5.0_3...
[59/84] Deleting files for blas-3.5.0_3: 100%
[60/84] Deinstalling libint-1.1.6_1...
[60/84] Deleting files for libint-1.1.6_1: 100%
[61/84] Deinstalling cblas-1.0_5...
[61/84] Deleting files for cblas-1.0_5: 100%
[62/84] Deinstalling mpich2-1.5_5,5...
[62/84] Deleting files for mpich2-1.5_5,5: 100%
[63/84] Deinstalling mopac-7.1.15_1,1...
[63/84] Deleting files for mopac-7.1.15_1,1: 100%
[64/84] Deinstalling GraphicsMagick-1.3.25_1,1...
[64/84] Deleting files for GraphicsMagick-1.3.25_1,1: 100%
[65/84] Deinstalling trlan-201009_4...
[65/84] Deleting files for trlan-201009_4: 100%
[66/84] Deinstalling slatec-4.1_5...
[66/84] Deleting files for slatec-4.1_5: 100%
[67/84] Deinstalling qd-2.3.7_5...
[67/84] Deleting files for qd-2.3.7_5: 100%
[68/84] Deinstalling netcdf-fortran-4.4.4_1...
[68/84] Deleting files for netcdf-fortran-4.4.4_1: 100%
[69/84] Deinstalling miracl-5.6_1,1...
[69/84] Deleting files for miracl-5.6_1,1: 100%
[70/84] Deinstalling ghc-7.10.2_1...
[70/84] Deleting files for ghc-7.10.2_1:  65%
pkg: /usr/local/share/doc/ghc-7.10.2/html/libraries/doc-index.html different from original checksum, not removing
[70/84] Deleting files for ghc-7.10.2_1: 100%
[71/84] Deinstalling eispack-1.0_7...
[71/84] Deleting files for eispack-1.0_7: 100%
[72/84] Deinstalling cgnslib-3.2.1_6,1...
[72/84] Deleting files for cgnslib-3.2.1_6,1: 100%
[73/84] Deinstalling openblas-0.2.19,1...
[73/84] Deleting files for openblas-0.2.19,1: 100%
[74/84] Deinstalling ised-2.7.1_1...
[74/84] Deleting files for ised-2.7.1_1: 100%
[75/84] Deinstalling star-2.5.2a...
[75/84] Deleting files for star-2.5.2a: 100%
[76/84] Deinstalling cd-hit-4.6.6...
[76/84] Deleting files for cd-hit-4.6.6: 100%
[77/84] Deinstalling FastTree-2.1.8_1...
[77/84] Deleting files for FastTree-2.1.8_1: 100%
[78/84] Deinstalling openmpi-1.10.6...
[78/84] Deleting files for openmpi-1.10.6: 100%
[79/84] Deinstalling R-3.3.3...
[79/84] Deleting files for R-3.3.3: 100%
[80/84] Deinstalling py27-ipython-5.3.0...
[80/84] Deleting files for py27-ipython-5.3.0: 100%
[81/84] Deinstalling sumaclust-1.0.20...
[81/84] Deleting files for sumaclust-1.0.20: 100%
[82/84] Deinstalling py27-scikit-bio-0.2.3...
[82/84] Deleting files for py27-scikit-bio-0.2.3: 100%
[83/84] Deinstalling gcc-4.9.4...
[83/84] Deleting files for gcc-4.9.4: 100%
[84/84] Deinstalling gcc-ecj-4.5...
[84/84] Deleting files for gcc-ecj-4.5: 100%

<<<ROOT@unixdev.ceas>>> /home/bacon 1006 # pkg install py27-numpy
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
The following 8 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
        py27-numpy: 1.11.2_2,1
        suitesparse: 4.0.2_5
        openblas: 0.2.19,1
        gcc: 4.9.4
        gcc-ecj: 4.5
        lapack: 3.5.0_1
        blas: 3.5.0_3
        cblas: 1.0_5

Number of packages to be installed: 8

The process will require 576 MiB more space.
18 MiB to be downloaded.

Proceed with this action? [y/N]: y
[1/8] suitesparse-4.0.2_5.txz                  :   3%   48 KiB  49.2kB/s    00:2[1/8] suitesparse-4.0.2_5.txz                  : 100%    1 MiB   1.3MB/s    00:01    
[2/8] openblas-0.2.19,1.txz                    :  10%    1 MiB   1.1MB/s    00:0[2/8] openblas-0.2.19,1.txz                    :  37%    4 MiB   2.6MB/s    00:0[2/8] openblas-0.2.19,1.txz                    :  64%    6 MiB   2.7MB/s    00:0[2/8] openblas-0.2.19,1.txz                    :  90%    9 MiB   2.6MB/s    00:0[2/8] openblas-0.2.19,1.txz                    : 100%    9 MiB   2.5MB/s    00:04    
[3/8] gcc-ecj-4.5.txz                          :  58%  800 KiB 819.2kB/s    00:0[3/8] gcc-ecj-4.5.txz                          : 100%    1 MiB   1.4MB/s    00:01    
[4/8] lapack-3.5.0_1.txz                       :  27%    2 MiB   1.8MB/s    00:0[4/8] lapack-3.5.0_1.txz                       :  67%    4 MiB   2.6MB/s    00:0[4/8] lapack-3.5.0_1.txz                       : 100%    6 MiB   3.2MB/s    00:02    
[5/8] blas-3.5.0_3.txz                         : 100%  128 KiB 131.3kB/s    00:01    
[6/8] cblas-1.0_5.txz                          : 100%   48 KiB  48.8kB/s    00:01    
Checking integrity... done (0 conflicting)
[1/8] Installing gcc-ecj-4.5...
[1/8] Extracting gcc-ecj-4.5: 100%
[2/8] Installing gcc-4.9.4...
[2/8] Extracting gcc-4.9.4: 100%
[3/8] Installing openblas-0.2.19,1...
[3/8] Extracting openblas-0.2.19,1: 100%
[4/8] Installing blas-3.5.0_3...
[4/8] Extracting blas-3.5.0_3: 100%
[5/8] Installing suitesparse-4.0.2_5...
[5/8] Extracting suitesparse-4.0.2_5: 100%
[6/8] Installing lapack-3.5.0_1...
Extracting lapack-3.5.0_1: 100%
[1/8] Installing cblas-1.0_5...
[1/8] Extracting cblas-1.0_5: 100%
[2/8] Installing py27-numpy-1.11.2_2,1...
[2/8] Extracting py27-numpy-1.11.2_2,1: 100%
Message from gcc-4.9.4:
To ensure binaries built with this toolchain find appropriate versions
of the necessary run-time libraries, you may want to link using

  -Wl,-rpath=/usr/local/lib/gcc49

For ports leveraging USE_GCC, USES=compiler, or USES=fortran this happens
transparently.
Message from cblas-1.0_5:
===>   NOTICE:

The cblas port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port


FreeBSD unixdev.ceas  bacon ~ 405: python junk.py
Hello
Comment 7 Mark Linimon freebsd_committer freebsd_triage 2017-03-23 22:00:10 UTC
*** Bug 217968 has been marked as a duplicate of this bug. ***
Comment 8 Walter Schwarzenfeld freebsd_triage 2018-01-16 13:07:55 UTC
This port is deprecated; you may wish to reconsider installing it:

Unsupported by upstream. Use GCC 6 or newer instead..

seems overcome by events.