Bug 217968 - math/py-numpy: Possible regression with fortran linkage
Summary: math/py-numpy: Possible regression with fortran linkage
Status: Closed DUPLICATE of bug 207750
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Mark Linimon
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-20 20:24 UTC by Jason W. Bacon
Modified: 2017-03-23 22:00 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (python)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason W. Bacon freebsd_committer 2017-03-20 20:24:26 UTC
The following error started appearing since running pkg upgrade this morning.  The qiime-test script had been working for the past couple weeks and there have been no major changes to the qiime port lately.

I can still build and run fortran programs using -Wl,-rpath,/usr/local/lib/gcc49.

This looks to me like a numpy link error, maybe failing to use rpath to load the correct libgcc?

Thanks,

    Jason

FreeBSD unixdev.ceas  bacon ~ 403: ./qiime-test qiime-tests/
Traceback (most recent call last):
  File "./all_tests.py", line 10, in <module>
    from qiime.util import (parse_command_line_parameters, get_options_lookup,
  File "/usr/local/lib/python2.7/site-packages/qiime/util.py", line 35, in <module>
    from numpy import (array, zeros, shape, vstack, ndarray, asarray,
  File "/usr/local/lib/python2.7/site-packages/numpy/__init__.py", line 142, in <module>
    from . import add_newdocs
  File "/usr/local/lib/python2.7/site-packages/numpy/add_newdocs.py", line 13, in <module>
    from numpy.lib import add_newdoc
  File "/usr/local/lib/python2.7/site-packages/numpy/lib/__init__.py", line 8, in <module>
    from .type_check import *
  File "/usr/local/lib/python2.7/site-packages/numpy/lib/type_check.py", line 11, in <module>
    import numpy.core.numeric as _nx
  File "/usr/local/lib/python2.7/site-packages/numpy/core/__init__.py", line 14, in <module>
    from . import multiarray
ImportError: /lib/libgcc_s.so.1: version GCC_4.6.0 required by /usr/local/lib/gcc49/libgfortran.so.3 not found
Comment 1 Shane 2017-03-21 03:57:02 UTC
Duplicate of bug #207750

A workaround is setting LD_LIBRARY_PATH
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2017-03-23 22:00:10 UTC

*** This bug has been marked as a duplicate of bug 207750 ***