Bug 213861 - lang/expect stage failure on arm64
Summary: lang/expect stage failure on arm64
Status: Closed DUPLICATE of bug 214205
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm64 Any
: --- Affects Only Me
Assignee: Pietro Cerutti
URL:
Keywords:
Depends on: 214205
Blocks: 201763
  Show dependency treegraph
 
Reported: 2016-10-28 18:32 UTC by Glen Barber
Modified: 2016-11-04 15:49 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (tcltk)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Glen Barber freebsd_committer 2016-10-28 18:32:04 UTC
=======================<phase: stage          >============================
===>  Staging for expect-5.45.3
===>   Generating temporary packing list
(echo 'if {![package vsatisfies [package provide Tcl] 8.6]} {return}' ;  echo 'package ifneeded Expect 5.45.3  [list load [file join $dir libexpect5453.so]]' ) > pkgIndex.tcl
 install  -s -m 555 libexpect5453.so /wrkdirs/usr/ports/lang/expect/work/stage/usr/local/lib/expect5.45.3/libexpect5453.so
 : /wrkdirs/usr/ports/lang/expect/work/stage/usr/local/lib/expect5.45.3/libexpect5453.so
 Install pkgIndex.tcl /wrkdirs/usr/ports/lang/expect/work/stage/usr/local/lib/expect5.45.3
 install  -s -m 555 expect /wrkdirs/usr/ports/lang/expect/work/stage/usr/local/bin/expect
TCL_LIBRARY=`echo /usr/local/include/tcl8.6/library`  LD_LIBRARY_PATH=".:/usr/local/lib/tcl8.6:"  PATH=".:/usr/local/lib/tcl8.6:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/nonexistent/bin"  TCLLIBPATH="." /usr/local/bin/tclsh8.6 ./fixline1 /usr/local/bin < ./example/timed-run > timed-run
*** Signal 11

Stop.
make[1]: stopped in /wrkdirs/usr/ports/lang/expect/work/expect5.45
*** Error code 1

Stop.
make: stopped in /usr/ports/lang/expect
Comment 1 Pietro Cerutti freebsd_committer 2016-10-31 10:44:59 UTC
Can we please get a core-dump of tclsh8.6?
Comment 2 Pietro Cerutti freebsd_committer 2016-11-04 09:27:55 UTC
I can reproduce on ref12-aarch64.freebsd.org. Vanilla tclsh from fossil trunk (http://core.tcl.tk/tcl/timeline?y=ci&t=trunk) segfaults at startup.
Looking into it..
Comment 3 Ed Maste freebsd_committer 2016-11-04 15:49:17 UTC

*** This bug has been marked as a duplicate of bug 214205 ***